Last Comment Bug 367756 - SeaMonkey v1.1 doesn't start up properly, when Quick Launch is enabled!
: SeaMonkey v1.1 doesn't start up properly, when Quick Launch is enabled!
Status: VERIFIED DUPLICATE of bug 368418
:
Product: Core Graveyard
Classification: Graveyard
Component: QuickLaunch (AKA turbo mode) (show other bugs)
: 1.8 Branch
: x86 Windows XP
: -- major (vote)
: ---
Assigned To: quicklaunch
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-22 09:56 PST by MuldeR
Modified: 2012-10-25 11:16 PDT (History)
8 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description MuldeR 2007-01-22 09:56:09 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2pre) Gecko/20070111 SeaMonkey/1.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2pre) Gecko/20070111 SeaMonkey/1.1

When SeaMonkey's Quick Launch Icon is still active and SeaMonkey is launched from startmenu, it sometimes doesn't start up. All I get is an empty/blank window :-( So I  have to close SeaMonkey and try again. That makes Quick Launch unusable with all SeaMonkey v1.1 builds! This bug happens with SeaMonkey v1.1 (official release) and also with some v1.1 nightlies I tested. There was no such problem in v1.0.7.

See screenshots:
http://mulder.dummwiedeutsch.de/temp/SeaMonkey_Bug1.jpg
http://mulder.dummwiedeutsch.de/temp/SeaMonkey_Bug2.jpg


Reproducible: Sometimes

Steps to Reproduce:
1. Run SeaMonkey v1.1 and enable Qucik Launch Icon in options
2. Exit SeaMonkey and make sure Quick Launch is still active
3. Run SeaMonkey from Startmenu
Actual Results:  
SeaMonkey starts up, but the window is empty/blank!

http://mulder.dummwiedeutsch.de/temp/SeaMonkey_Bug1.jpg
http://mulder.dummwiedeutsch.de/temp/SeaMonkey_Bug2.jpg

Expected Results:  
SeaMonkey should startup properly.
Comment 1 Andreas 2007-01-22 23:44:46 PST
Works for me.

Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.8.1.2pre) Gecko/20070111 SeaMonkey/1.1
Comment 2 Dan 2007-01-23 10:44:54 PST
Not sure if it's related to this bug, but seems to.
Computer 1: WinXPSP1 - Seamonkey 1.0.6
Computer 2: WinXPSP2 - Seamonkey 1.0.7
I updated both of them with Seamonkey 1.1 and observe the same behaviour:

I've got quicklaunch enabled on boot time. Once a navigator is opened from the quicklaunch icon, no more windows (mail, navigator or so) can be opened from it. Also couldn't launch new navigator windows from desktop icon.
Clicking links on other applications so not open a new tab on existing window (as configured on preferences) or load onto an existing tab.

If I exit seamonkey from quicklaunch icon (thus, disabling the quicklaunch itself) everything begins to work OK.

Reproducible: always
Comment 3 Tim 2007-01-25 06:53:01 PST
I too have a quicklaunch problem in SeaMonkey 1.1, looks like the same ... upgrade from Seamonkey 1.0.7 on XP Home.  I have appearance prefs to show mail/news only on start (not navigator).

To reproduce...
1. Exit seamonkey from the quicklaunch icon (check no seamonkey processes are running)
2. Launch seamonkey (my mail/news windows appears)- BUT the quicklaunch icon does not appear even if quicklaunch is set in the preferences
3. Unset quicklaunch pref, OK, then set quicklaunch in the prefs, OK- the quicklaunch icon appears.
4. Exit seamonkey by closing all the windows.
5. Observe Seamonkey process ID changes as quicklaunch restart seamonkey.
6. Launch seamonkey - the quicklaunch icon is still there, but the navigator (not mail) window.  Seamonkey has the PID as in 5.
7. Exit seamonkey by closing all seamonkey windows - the quicklaunch icon is still there, but the seamonkey still has process ID as in 5 - ie seamonkey did not really exit.
8. Repeat 6 and 7 as much as you like.
9. Exit seamonkey from the quicklanch icon and you go back to 1.

Confirmed that disabling quicklaunch in the prefs works - seamonkey process dies every time you close the last window.  

Looks like it maybe something to do with the (a) starting quicklaunch when the seamonkey process starts, and/or (b) start of the new seamonkey process by quicklaunch when you exit seamonkey , which then stops seamonkey exiting properly.
Comment 4 Bill Cassel 2007-01-29 12:42:03 PST
Upgraded from SeaMonkey 1.07 to 1.1 and now, when I use Quick Launch, it will not start both mail and browser although setting in preferences-appearance are marked to do so.  Only Navigator opens and sometimes Navigator will open in a small box in the upper left corner of the screen and won't function.  I have not had any problem with this prior to installing 1.1.  No problem if Quick Launch is disabled.
Comment 5 MuldeR 2007-01-29 12:46:51 PST
@Bill Cassel
What you describe is exactly what I experience with all SM v1.1 builds!
Comment 6 MuldeR 2007-02-13 10:02:01 PST
The latest Nightly Build of SeaMonkey 1.5a seem to fix the problem.
Can other users confirm? Will the fix be included in 1.1 branch ???
Comment 7 Bill Cassel 2007-02-13 11:26:44 PST
I loaded SeaMonkey 1.5a, Build ID: 2007021209, and still cannot get both navigator and mail to open with quick launch either on or off.   
Comment 8 Wayne Mery (:wsmwk, NI for questions) 2007-02-13 11:31:18 PST
Chris, perhaps this, bug 367680 or bug 366569 is what you refer to in bug 368423 and 368424 - "dupe that here ..." 

chris probably wants to keep to one issue per bug and has opened a series of bugs for QL, so you can dup your bug to one of these:
bug 368418
bug 368421
bug 368423
bug 368424

FWIW, there are ~60 open bugs against quicklaunch.
Comment 10 Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2007-02-26 16:55:12 PST
Neil, would this one have been fixed by your patch?
Comment 11 neil@parkwaycc.co.uk 2007-02-27 03:11:55 PST
Well, since this is a QL startup bug, then it's possible that it's relevant.
Comment 12 Tim 2007-03-01 05:22:28 PST
(In reply to comment #3)
> I too have a quicklaunch problem in SeaMonkey 1.1, looks like the same ...
> upgrade from Seamonkey 1.0.7 on XP Home.  I have appearance prefs to show
> mail/news only on start (not navigator).
> 
> To reproduce...
> 1. Exit seamonkey from the quicklaunch icon (check no seamonkey processes are
> running)
> 2. Launch seamonkey (my mail/news windows appears)- BUT the quicklaunch icon
> does not appear even if quicklaunch is set in the preferences
> 3. Unset quicklaunch pref, OK, then set quicklaunch in the prefs, OK- the
> quicklaunch icon appears.
> 4. Exit seamonkey by closing all the windows.
> 5. Observe Seamonkey process ID changes as quicklaunch restart seamonkey.
> 6. Launch seamonkey - the quicklaunch icon is still there, but the navigator
> (not mail) window.  Seamonkey has the PID as in 5.
> 7. Exit seamonkey by closing all seamonkey windows - the quicklaunch icon is
> still there, but the seamonkey still has process ID as in 5 - ie seamonkey did
> not really exit.
> 8. Repeat 6 and 7 as much as you like.
> 9. Exit seamonkey from the quicklanch icon and you go back to 1.
> 
> Confirmed that disabling quicklaunch in the prefs works - seamonkey process
> dies every time you close the last window.  
> 
> Looks like it maybe something to do with the (a) starting quicklaunch when the
> seamonkey process starts, and/or (b) start of the new seamonkey process by
> quicklaunch when you exit seamonkey , which then stops seamonkey exiting
> properly.
> 

This problem appear to have been resolved with an upgrade to SM 1.1.1.  The application appears to correctly exit, the QL icon disappears and reappears as previously as the processes restart.
Comment 13 Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2007-03-01 05:52:13 PST
(In reply to comment #12)
> (In reply to comment #3)
> > I too have a quicklaunch problem in SeaMonkey 1.1, looks like the same ...
> > upgrade from Seamonkey 1.0.7 on XP Home.  I have appearance prefs to show
> > mail/news only on start (not navigator).
> > 
> > To reproduce...
> > 1. Exit seamonkey from the quicklaunch icon (check no seamonkey processes are
> > running)
> > 2. Launch seamonkey (my mail/news windows appears)- BUT the quicklaunch icon
> > does not appear even if quicklaunch is set in the preferences
> > 3. Unset quicklaunch pref, OK, then set quicklaunch in the prefs, OK- the
> > quicklaunch icon appears.
> > 4. Exit seamonkey by closing all the windows.
> > 5. Observe Seamonkey process ID changes as quicklaunch restart seamonkey.
> > 6. Launch seamonkey - the quicklaunch icon is still there, but the navigator
> > (not mail) window.  Seamonkey has the PID as in 5.
> > 7. Exit seamonkey by closing all seamonkey windows - the quicklaunch icon is
> > still there, but the seamonkey still has process ID as in 5 - ie seamonkey did
> > not really exit.
> > 8. Repeat 6 and 7 as much as you like.
> > 9. Exit seamonkey from the quicklanch icon and you go back to 1.
> > 
> > Confirmed that disabling quicklaunch in the prefs works - seamonkey process
> > dies every time you close the last window.  
> > 
> > Looks like it maybe something to do with the (a) starting quicklaunch when the
> > seamonkey process starts, and/or (b) start of the new seamonkey process by
> > quicklaunch when you exit seamonkey , which then stops seamonkey exiting
> > properly.
> > 
> 
> This problem appear to have been resolved with an upgrade to SM 1.1.1.  The
> application appears to correctly exit, the QL icon disappears and reappears as
> previously as the processes restart.
> 

Duping to bug 368418 since apparently Neil's patch there fixed this issue too.

*** This bug has been marked as a duplicate of bug 368418 ***
Comment 14 Bill Cassel 2007-03-01 10:32:51 PST
I downloaded SeaMonkey 1.1.1 yesterday, 2/28, and as of yet, I have not had any problems with quicklaunch.  SeaMonkey seem to be opening properly with no errors.
1.1.1 seems to have addressed my problem.  
Comment 15 Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2007-03-01 15:55:28 PST
(In reply to comment #14)
> I downloaded SeaMonkey 1.1.1 yesterday, 2/28, and as of yet, I have not had any
> problems with quicklaunch.  SeaMonkey seem to be opening properly with no
> errors.
> 1.1.1 seems to have addressed my problem.  
> 

Thanks for confirming.  Marking verified.

Note You need to log in before you can comment on or make changes to this bug.