place signature below my reply (above the quote) not working properly, for some identities

RESOLVED DUPLICATE of bug 278453

Status

Thunderbird
Account Manager
--
major
RESOLVED DUPLICATE of bug 278453
11 years ago
5 years ago

People

(Reporter: TJ Draper, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: version 2 alpha 1 (20060724)

No matter how many times I tell it to place my signature above the quoted text it will not!!!
When I go back into the preferences, it has reverted back to the option to place signature below quoted text.

Reproducible: Always

Steps to Reproduce:
1. Choose tools>Account Settings>[Your Account]>Manage Identities
2. Select an identity and click Edit
3. Choose the Composition & Addressing tab
4. Check Mark "Automatically quote the original message when replying"
5.  From the pop-up menu "Then," chose "start my reply above the quote" then in the "and place my signature" pop-up menu chose "below my reply (above the quote)
Actual Results:  
Repeating steps 1  through 4 and then looking at the pop-up menu will confirm that it did not save the preference to place signature above quote (also replying to a message will confirm this).

Expected Results:  
Software should have placed my signature above quoted text.

Comment 1

11 years ago
This works fine for me on todays branch build (linux). Do try out a recent nightly, in case it happens to be broken in 2.0a1. In general, for reporting bugs, please always use recent builds.

Comment 2

11 years ago
I can reproduce the same bug since 1.x and following all versions including the latest I use: version 2.0.0.0 (20070326) on winXP.

The bug appears (for me) on my secondary identities, the primary identity works as expected.

Comment 3

11 years ago
I handle only one identity. Nevertheless, I reproduce exactly the same bug : when I choose "Under my answer (above the quotation)", Thunderbird doesn't save this preference.

I run Thunderbird 2.0.0.0 (20070326) in French on WinXP.

Comment 4

11 years ago
This is identical to <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=345396">Bug 345396</a>. A workaround was published there: open the Configuration Editor (Tools... Options... Advanced... General... Config editor) and change every variable whose name contains "sig_bottom" to FALSE.

Updated

11 years ago
Duplicate of this bug: 385181

Updated

11 years ago
Duplicate of this bug: 388650

Comment 7

10 years ago
I can reproduce the same issue using version 2.0.0.9 (20071031) on Mac 10.5 with multiple accounts and one identity. 

Only way to get it to work properly is to use the Config Editor and set sig_bottom to false for each account. Does not work from the preferences pane.

Comment 8

10 years ago
Confirming based on a few duplicates...
Assignee: mscott → nobody
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Hardware: Macintosh → All
Summary: Signatures not working properly → place signature below my reply (above the quote), for some identities

Updated

10 years ago
Summary: place signature below my reply (above the quote), for some identities → place signature below my reply (above the quote) not working properly, for some identities

Updated

10 years ago
Duplicate of this bug: 415953

Updated

10 years ago
Duplicate of this bug: 345396

Comment 11

10 years ago
Is this solved with bug 278453 fixed?
Duplicate of this bug: 442574

Comment 13

10 years ago
I didn't dupe bug 442574 right away against this one here because it was not clear from the description in that bug whether the problem also occurs to main or single identities (if not, this would have been bug 278453 instead).
The same applies to a couple of other reports marked as duplicate here, only comment #3 and comment #7 indicate scenarios different from bug 278453.

Again, it would be helpful to see if anybody of those affected can reproduce this with a Shredder Alpha or nightly trunk build to verify if it is fixed.


Comment 14

10 years ago
I can reproduce this with 2.0.0.14 (under Linux) for others than the main identity. (The main identity works as expected, placing the signature above the citation).
Workaround works for me.

Comment 15

10 years ago
This is fixed for Thunderbird 3.0, but the patch was not included in 2.0.

Source:
https://bugzilla.mozilla.org/show_bug.cgi?id=442574

Comment 16

10 years ago
I use 2.0.0.16: first identity works, others won't.
the workaround works fine for new messages but in answers, if you change the identity, the signature is added and not replaced.
@dayslipper: probably fixed in 3.0 -- where do I get 3.0???

Comment 17

10 years ago
(In reply to comment #16)
> I use 2.0.0.16: first identity works, others won't.

Again, this is bug 278453 and fixed for 3.0, look for announcements for Shredder Alpha 2 coming up. Of interest for *this* bug are cases where reporters state that it also happens for the main identity, and whether or not this is fixed by the same patch in 3.0 now.

Comment 18

9 years ago
Hello,

Have you seen in the "éditeur de configuration" in outils - options - avancé - général (I don't know how to say in english : maybe about:config)

mail.identity.idx.sig_bottom is true by default you should change for "false" for all identities and it works !

Comment 19

8 years ago
The workaround with sig_bottom works, in the way it places the signature at the right place. But it won't replace the old signature, it just places the new one above the old one...
Will there may be a backport to 2.x?

Updated

5 years ago
Duplicate of this bug: 425479

Comment 21

5 years ago
(In reply to rsx11m from comment #11)
> Is this solved with bug 278453 fixed?

This clearly works with current release builds with the STR provided, and no reports on versions later than 2.0.0.x came in, thus finally closing this as a duplicate of the other bug.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 278453
You need to log in before you can comment on or make changes to this bug.