Unknown DB performance issue (Lost connection to MySQL server during query)

VERIFIED DUPLICATE of bug 408766

Status

()

Bugzilla
Query/Bug List
VERIFIED DUPLICATE of bug 408766
12 years ago
10 years ago

People

(Reporter: justdave, Unassigned)

Tracking

Details

Attachments

(1 attachment)

Created attachment 251337 [details]
query debug info

The Summary is a dummy, we can fix it to be more accurate once we figure out what the issue is.

Been having a lot of people mail in "Lost connection to MySQL server" errors since the upgrade.  Sometimes they seem random.  This one I can reproduce at will, so I'm assuming the query is taking longer to run than the timeouts are set for.

Debug info attached.

Comment 1

12 years ago
How long does the query take if you run it actually in the MySQL console?

Updated

11 years ago
Duplicate of this bug: 389925
OK, I was told recently that MySQL has a total lifetime timeout on connections, meaning any given connection cannot last longer than the timeout, even if it's not idle.  Supposedly this timeout defaults to 8 hours.  I can't seem to find it documented anywhere, however.  But given that we're using mod_perl, and connections are being pooled, it's quite possible we've been hitting this timeout as apache processes grow to be that old.  Perhaps we need to set a time limit on how old an apache process can get, or keep track of how long our MySQL connections have been open and kill them off ourselves before they get that old.

Updated

11 years ago
Duplicate of this bug: 390599

Comment 6

11 years ago
i like my testcase better, as the query that's failing is trivial, and the problem is that a previous query combined with expensive charting has caused the simple query to be unfortunately aborted. 

Comment 7

10 years ago
Isn't this fixed by bug 408766?

Comment 8

10 years ago
Yes, this bug and that one sound identical, to me.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 408766

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.