The default bug view has changed. See this FAQ.

Apache::DBI is a premature optimization that causes trouble

RESOLVED FIXED in Bugzilla 3.0

Status

()

Bugzilla
Database
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Max Kanat-Alexander, Assigned: Max Kanat-Alexander)

Tracking

3.0.2
Bugzilla 3.0
Bug Flags:
approval +
approval3.0 +

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
Currently Bugzilla requires and uses Apache::DBI to maintain connections to the database.

However, connecting to the database only takes a tiny fraction of a second, and there isn't load enough on any Bugzilla database anywhere to justify it. 

On the other hand, in certain circumstances the database handles seem to stay open after a request ends, leading to weird "server went away" errors from MySQL.

So overall, we don't need it and it seems to be causing us problems.
(Assignee)

Comment 1

9 years ago
Created attachment 293617 [details] [diff] [review]
v1
Assignee: database → mkanat
Status: NEW → ASSIGNED
Attachment #293617 - Flags: review?
(Assignee)

Updated

9 years ago
Attachment #293617 - Flags: review? → review?(justdave)
Attachment #293617 - Flags: review?(justdave) → review+
(Assignee)

Updated

9 years ago
Flags: approval?
Flags: approval3.0?
(Assignee)

Comment 2

9 years ago
<justdave> and you'll be happy to know that we got the error messages working on the cluster, and there have been no ocurrences whatsoever of "Lost connection to MySQL server during query" since our config change yesterday :)

(He means the change made in this patch.)
Flags: approval?
Flags: approval3.0?
Flags: approval3.0+
Flags: approval+
(Assignee)

Comment 3

9 years ago
tip:

Checking in mod_perl.pl;
/cvsroot/mozilla/webtools/bugzilla/mod_perl.pl,v  <--  mod_perl.pl
new revision: 1.8; previous revision: 1.7
done
Checking in Bugzilla/DB.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/DB.pm,v  <--  DB.pm
new revision: 1.107; previous revision: 1.106
done
Checking in Bugzilla/Install/Requirements.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Install/Requirements.pm,v  <--  Requirements.pm
new revision: 1.41; previous revision: 1.40
done
Checking in docs/xml/installation.xml;
/cvsroot/mozilla/webtools/bugzilla/docs/xml/installation.xml,v  <--  installation.xml
new revision: 1.148; previous revision: 1.147
done

3.0 branch:

Checking in mod_perl.pl;
/cvsroot/mozilla/webtools/bugzilla/mod_perl.pl,v  <--  mod_perl.pl
new revision: 1.5.2.2; previous revision: 1.5.2.1
done
Checking in Bugzilla/DB.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/DB.pm,v  <--  DB.pm
new revision: 1.93.2.4; previous revision: 1.93.2.3
done
Checking in Bugzilla/Install/Requirements.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Install/Requirements.pm,v  <--  Requirements.pm
new revision: 1.29.2.2; previous revision: 1.29.2.1
done
Checking in docs/xml/installation.xml;
/cvsroot/mozilla/webtools/bugzilla/docs/xml/installation.xml,v  <--  installation.xml
new revision: 1.136.2.7; previous revision: 1.136.2.6
done
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Keywords: relnote
Resolution: --- → FIXED
Whiteboard: [relnote 3.0.3]
(Assignee)

Updated

9 years ago
Blocks: 441592
(Assignee)

Comment 4

9 years ago
relnoted for 3.0.3 long ago, removing relnote keyword.
Keywords: relnote
Whiteboard: [relnote 3.0.3]
(Assignee)

Updated

9 years ago
Duplicate of this bug: 366884
You need to log in before you can comment on or make changes to this bug.