Closed Bug 367159 Opened 14 years ago Closed 13 years ago

[Mac] Date picker disappears after it is clicked on, before user selects a date

Categories

(Calendar :: Calendar Views, defect)

PowerPC
macOS
defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: cmtalbert, Assigned: dbo)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.2pre) Gecko/20070116 Calendar/0.4a1

On Mac branch builds, the datepicker disappears before the user has a chance to click on a date.  This occurs on all instances of the datepicker, and seems to have happened as far back as Lightning 0.3 (on the mac). The problem does not occur on Windows or Linux. 

(Testing on Mac OS X 10.4.8, PPC)
 

Reproducible: Always

Steps to Reproduce:
1. Install a branch build of Sunbird or Lightning on Mac
2. Find a datepicker and click it's drop down
Actual Results:  
Datepicker appears briefly, then disappears.

Expected Results:  
Datepicker should be available for user to use in selecting a date.

This looks pretty poor as far as UI goes, and so I am marking as major.
Summary: Date picker disappears after it is clicked on, before user selects a date → [Mac] Date picker disappears after it is clicked on, before user selects a date
Someone with Mac please verify:

For Sunbird this should be fixed by the checkin from Bug 346318 Comment #35.

In Lightning the issue still exists because the '#ifndef MOZ_SUNBIRD' workaround doesn't apply to Thunderbird.
Stefan,

It is as you described.  Sunbird does not have this problem after the resolution of Bug 346318 however the problem persists in Lightning for datepickers only making Lightning somewhat useless on the Mac platform.  Timepickers are unaffected.

I am testing on Mac OS X 10.4.9, Intel.
Confirming Lightning date pickers are not usable on Mac.
Flags: blocking-calendar0.7+
Confirming Lightning 0.5 (build 2007062503) date pickers are not usable on Mac. The problem was reproduced on two MacOS 10.4 laptops, both running Thunderbird 2.0.0.4 (build 20070604) with the aforementioned release of Lightning. In addition, the date picker is working fine on both laptops in Sunbird 0.3.1.
Duplicate of this bug: 390121
Assignee: nobody → daniel.boelzle
Duplicate of this bug: 396181
Attached patch poor man's fixSplinter Review
This patch makes the control at least a bit usable: The user can travel the months and pick a date. However, changing the month or year via drop-down freezes the control.
I'd like to have this poor man's fix in for 0.7; better than nothing. We should strongly consider refurbishing the date pickers for 0.9 (also w.r.t. bug 356505).
Attachment #281163 - Flags: review?(michael.buettner)
Comment on attachment 281163 [details] [diff] [review]
poor man's fix

I witnessed that it works on Mac. I'm shuddering when looking at that, but *eyes closed* -> r=mickey.
Attachment #281163 - Flags: review?(michael.buettner) → review+
Checked in on HEAD and MOZILLA_1_8_BRANCH.

Follow-up bug 396417 for the month/year freeze issue.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.7
verified poor man's fix, picker is usable.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.