Closed Bug 396417 Opened 12 years ago Closed 8 years ago

[Mac] Datepicker freezes after changing month/year

Categories

(Calendar :: General, defect)

PowerPC
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: dbo, Assigned: Fallen)

References

Details

Attachments

(1 file, 1 obsolete file)

On Mac branch builds, the datepicker freezes after selecting a month or year via dropdown. This occurs on all instances of the datepicker; the problem does not
occur on Windows or Linux.
Duplicate of this bug: 397816
[trolling] This bug is still alive on Tb2.0.0.9 + Lg0.8pre(2008012320).

When year changed, the datepicker freezes. OTOH when month changed, the datepicker just exits instead of update its contents. And make matters worse, the right/left arrows on the datepicker does NOT work. This means we couldn't create events for next month or later.

IMO this bug is worth Major or higher for Mac users.
Flags: wanted-calendar0.8?
Flags: wanted-calendar0.8? → wanted-calendar0.8+
Bug 416161 reports the same issue for Windows but only for the Agendas datepicker.
bug 416161 isn't the same problem but similar. The arrows do work in windows but the month freezes the window as does the year.
Not going to happen for 0.8.
Flags: wanted-calendar0.8+ → wanted-calendar0.8-
This bug was added as a follow up for Bug 367159 that added a hack to make the datepicker usable on Mac OS X branch builds. This hack still exists in comm-central builds: <http://mxr.mozilla.org/comm-central/search?string=mUseReshowHack&find=/calendar/>

The corresponding |#ifndef MOZ_SUNBIRD| workaround in /widget/src/mac/nsMacWindow.cpp doesn't exist in mozilla-central anymore.

Is the hack in datetimepickers.xml still required in 1.0pre builds?

Does this issues still exists in 1.0pre builds?
(In reply to comment #6)
> Is the hack in datetimepickers.xml still required in 1.0pre builds?
needs investigation

> Does this issues still exists in 1.0pre builds?
No, the datepicker currently works well on Mac (trunk).

WFM? Or WFM after investigation resp. potential cleanup?
Duplicate of this bug: 464073
Duplicate of this bug: 450904
Duplicate of this bug: 483683
Attached patch Remove reshow hack - v1 (obsolete) — Splinter Review
It seems we can remove the reshow hack. This patch is tested on mac, will test windows/linux soon (therefore not requesting review yet)
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Is this a duplicate of bug #278877 ?
Sorry I meant bug #286747 in comment #12
Duplicate of this bug: 286747
Patch works on windows
Tested on Linux, debitrotted and comment removed
Attachment #512254 - Attachment is obsolete: true
Attachment #581566 - Flags: review?(ssitter)
Comment on attachment 581566 [details] [diff] [review]
Remove reshow hack - v2

r=ssitter (I don't have access to Mac OS X and therefore cannot test if this patch fixes or breaks anything on this system)
Attachment #581566 - Flags: review?(ssitter) → review+
Pushed to comm-central changeset 298e996a1267
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4
Any particular reason why the removing of the obsolete comment that was part of the patch I reviewed didn't make it into the final patch that was pushed to comm-central?
Oh, sorry about that. I had this patch locally on my mac and assumed it was the same one as on the bug. Will fix.
You need to log in before you can comment on or make changes to this bug.