The default bug view has changed. See this FAQ.

Importer (Win Eudora, Address Book). Unable to import if Eudora is using '.nnt' format

RESOLVED FIXED

Status

Thunderbird
Migration
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Matt Dudziak, Assigned: Geoffrey C. Wenger)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-penelope)

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
The problem is that it is not possible to import Address Books from Eudora if Eudora is using the '.nnt' file format. The Penelope importer does not recognize this file format.

To reproduce:

- Set Eudora to hide Address Book files from simple viruses
- Attempt to import the Address Book into Penelope 
- Note error in Penelope:
"No address books were found to import".
(Assignee)

Updated

10 years ago
Component: General → Migration
Product: Penelope → Thunderbird
Target Milestone: 0.5 → ---
Version: 0.1 → unspecified
(Assignee)

Comment 1

10 years ago
Created attachment 260603 [details] [diff] [review]
Patch that fixes bug. Note patch was not created with CVS.
Attachment #260603 - Flags: superreview?
Attachment #260603 - Flags: review?
(Assignee)

Updated

10 years ago
Attachment #260603 - Flags: superreview?(bienvenu)
Attachment #260603 - Flags: superreview?
Attachment #260603 - Flags: review?(bienvenu)
Attachment #260603 - Flags: review?

Comment 2

10 years ago
Comment on attachment 260603 [details] [diff] [review]
Patch that fixes bug. Note patch was not created with CVS.

I'll try to port this to the trunk after I've finished getting rid of nsFileSpec...
Attachment #260603 - Flags: superreview?(bienvenu)
Attachment #260603 - Flags: superreview+
Attachment #260603 - Flags: review?(bienvenu)
Attachment #260603 - Flags: review+

Comment 3

10 years ago
Standard8 points out that the patch has tabs in it - in general, we want spaces instead of tabs, and a 2 or 4 space indent, depending on the prevailing code. (Yeah, I realize that the import code is *full* of tabs, but we don't want to add more)

Since I'm going to have to apply this patch by hand, it's not such a big deal, but in the future
(Assignee)

Comment 4

10 years ago
We can chat in #penelope or via AIM tomorrow (Thurs.) regarding this. I realize that typically spaces would normally be used, but assumed that since the importer code has almost no use of spaces (i.e. tabs are pretty much all that is used) I shouldn't introduce a few lines with spaces (mixing tabs and spaces can be ugly depending on the settings of the person viewing your code). Sorry for the incorrect assumption and trouble here.
(Assignee)

Updated

10 years ago
Whiteboard: penelope-fixed
(Assignee)

Updated

10 years ago
Whiteboard: penelope-fixed → fixed-penelope
Matt, you might also take a look at bug 280006 and bug 274021 

Comment 6

10 years ago
Created attachment 263805 [details] [diff] [review]
fix I'm going to check in

This is what I'm going to land on the trunk - it uses nsIFile instead of nsfilespec.

Comment 7

10 years ago
fixed on trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Duplicate of this bug: 280006
You need to log in before you can comment on or make changes to this bug.