Open Bug 368909 Opened 15 years ago Updated 9 years ago

Reloading a loading XML page causes a well-formedness error to appear briefly

Categories

(Core :: XML, defect, P3)

defect

Tracking

()

REOPENED

People

(Reporter: jruderman, Assigned: peterv)

References

()

Details

(Keywords: regression, testcase)

Steps to reproduce:
1. Start loading http://www.hixie.ch/tests/evil/page-loading/incremental/001.cgi?mime=text%2Fxml&delay=1&repeats=10
2. Press Cmd+R (reload) or click the home button.

Result: "no element found" XML error

Expected: cancel the load peacefully, like when I press Esc (stop).
Seeing this issue with
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7pre) Gecko/2007070804 Minefield/3.0a7pre
(Hit CTRL+R while loading the url in the bug, well-formedness error is displayed for one second - that is, before the server sends start of the content).

I agree with Jesse, the display should look like the same as hitting the Esc.

Hardware/OS should be set to ALL/ALL.
OS: Mac OS X → All
Hardware: Macintosh → All
I tried several times to reproduce this, but couldn't. Is it still an issue?

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a9pre) Gecko/2007102705 Minefield/3.0a9pre ID:2007102705
The URL isn't displaying incrementally at all for me now :(
Is this a dupe of bug 401613? If not, can you please have a look at this one, Peter?
Assignee: xml → peterv
Flags: blocking1.9? → blocking1.9+
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 401613
The testcase doesn't work at all now, probably because of a problem on Hixie's server, so this is currently impossible to test.

Sicking and jst, why do you think this is a dup of bug 401613?
Apparently Hixie's server has decided to gzip the output of his script :/
Duplicate of this bug: 422962
This isn't a duplicate.  The issue here is that we stop the old load and start the new one.  But stopping the old load cancels the parser partway, so the XML content sink never gets the closing tags it's expecting and shows the yellow screen of death.  All this happens before the new load gets a response, so we get a brief flash of YSOD for the page we're _leaving_.

Not sure whether the XML sink can usefully detect this situation.
Status: RESOLVED → REOPENED
Flags: blocking1.9?
Resolution: DUPLICATE → ---
(In reply to comment #9)
> The issue here is that we stop the old load and start
> the new one.  But stopping the old load cancels the parser partway, so the XML
> content sink never gets the closing tags it's expecting and shows the yellow
> screen of death.

How is hitting the stop button handled? As far as I know, no yellow screen of death appears if I hit the stop button during the loading (perhaps I've been just lucky?). Doesn't the parser report (to XML sink) that it got killed partway?
Wouldn't hold the release for this.  Marking wanted1.9.0.x.  If people feel otherwise, please re-nom.  The XML still loads, albeit it is still ugly for a second.
Flags: wanted1.9.0.x+
Flags: tracking1.9+
Flags: blocking1.9?
Flags: blocking1.9-
> How is hitting the stop button handled?

Same exact way.  Same exact error code.  Of course, I can't reproduce this bug as originally filed, nor with a large XML file loaded from a file:// URI.  Can you?
If someone can still reproduce this, please tell us how and renominate accordingly.
Flags: wanted1.9.0.x+ → wanted1.9.0.x-
>If someone can still reproduce this
Yes, please see this screen shot:

http://misc.xstandard.com/mozilla/parsing-error.gif

... it was taken using build:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008052206 Minefield/3.0pre

> renominate accordingly
Sorry, don't know how to do this.

> please tell us how
This happens over a slow Internet connection. Since we don't have access to a slow Internet connection any longer, I reproduced the problem using a proxy server set to simulate modem speed. Here are the steps:

1. Onto your local computer, install proxy server called Fiddler2 from:
http://fiddler2.com/dl/Fiddler2Setup.exe

2. Run Fiddler2. From the Rules menu, select:

Performance > Simulate Modem speeds

and

Performance > Disable Caching

3. In Firefox, set the manual proxy connection to localhost on port 8888.

4. Go to xhtml.com or xstandard.com and click around.

Renominating for dot-release
Flags: wanted1.9.0.x- → wanted1.9.0.x?
RE: Comment #14, last point should read:

4. Go to xstandard.com and click around.

Flags: wanted1.9.0.x? → wanted1.9.0.x+
QA Contact: ashshbhatt → xml
nominating for 3.1 in case Jonas still cares about it. Clearing "wanted1.9.0.x" because we don't care enough to push for a fix, but if it does get fixed on trunk we'll look at a small, safe patch.
Flags: wanted1.9.0.x+ → blocking1.9.1?
Flags: blocking1.9.1? → blocking1.9.1-
Duplicate of this bug: 529384
Duplicate of this bug: 801416
(In reply to Jesse Ruderman from comment #6)
> The testcase doesn't work at all now, probably because of a problem on
> Hixie's server, so this is currently impossible to test.

Find a new testcase here: http://www.vogtner.de/mozilla/801416
Surprisingly the YSsOD in most cases contain no text.
You need to log in before you can comment on or make changes to this bug.