Closed Bug 374189 Opened 15 years ago Closed 13 years ago

[Linux/SunOS] Ctrl+Y for "Downloads" doesn't work when focus is in a textbox (conflicts with "Redo")

Categories

(Firefox :: Keyboard Navigation, defect)

All
Linux
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 3.6a1

People

(Reporter: lijuan1.wang, Assigned: crusader)

References

(Blocks 1 open bug, )

Details

(Keywords: polish, verified1.9.1)

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.8.1.2) Gecko/20070312 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.8.1.2) Gecko/20070312 Firefox/2.0.0.2

The shortcut 'Ctrl+Y' should Opens the Downloads window.If left click on an editable space,for ex,location bar,web search space,search in the page space.Then press 'Ctrl+Y',can not open the downloads window.

Reproducible: Always

Steps to Reproduce:
1.Left click on main web page
2.Left click on anywhere of the web page((except the editable space)
3.press 'Ctrl+Y'

4.Left click on an editable space,for ex,location bar,web search space,search in the page space.
5.Left click on anywhere of the web page((except the editable space)
6.Press 'Ctrl+Y'
Actual Results:  
After#3:Pop out the Downloads window
After#4:The Downloads window can not pop out


Expected Results:  
No matter where you click,the shortcut should open the Downloads window.

After#3:Pop out the Downloads window
After#4:Pop out the Downloads window


test based on vermillion_61_dev SPARC,X86
This is caused by the shortcut conflicts between "Downloads" and "Redo". It should be also reproducible on Linux as the link shows: http://www.mozilla.org/support/firefox/keyboard.
Reproducible on Solaris 10 7/07 s10s_u4wos_04 SPARC

Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8.1.1) Gecko/20070131 Firefox/2.0.0.1

Reproduced on Trunk :
Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9a3) Gecko/20070330 Firefox/3.0a3

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 383784
Summary: Sometimes,the shortcut 'Ctrl+Y' for 'downloads' window doesn't work → [Linux/SunOS] Ctrl+Y for "Downloads" doesn't work when focus is in a textbox (conflicts with "Redo")
Duplicate of this bug: 276297
Reproduced  on Firefox 3 B1 RC3
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1
Reproduced on Firefox 3.1 b1
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b1) Gecko/20081007 Firefox/3.1b1
marking for relnote
Keywords: relnote
This has been a problem since 2.0.0.x. Not going to relnote it now.
Keywords: relnote
OS: SunOS → Linux
Hardware: x86 → All
Any chance this can be fixed for 3.1 for parity with other platforms?
Flags: blocking-firefox3.1?
Not as a blocker, no. Need to find someone incented to fix it.

I know I'll regret this, but why isn't the shortcut for Downloads Ctrl_+J on Linux?
Flags: wanted-firefox3.1+
Flags: blocking-firefox3.1?
Flags: blocking-firefox3.1-
Keywords: polish
Ctrl-J seems to focus the search box for me. Redo is also Ctrl-Shift-Z for me.
No bug, but I found bonsai say "Adds linux shortcut entity for the download manager (Ctrl-Y) before l10n freeze. Gnome shortcut (Shift-Ctrl-Z) will be used for Redo. r+a=ben", http://bonsai.mozilla.org/cvslog.cgi?file=mozilla/toolkit/locales/en-US/chrome/mozapps/downloads/downloads.dtd&rev=1.1.2.7
Actually, bug 258788 seems to be the culprit, searched for more check-ins in that time window.
This is my first attempt at a fix for Firefox. Please advise and I hope this helps!
Attachment #362486 - Flags: review?
Attachment #362486 - Flags: approval1.9.1?
Attachment #362486 - Flags: review? → review?(mconnor)
I attached my attempted patch for this bug. I changed the hotkey for the download manager in Linux to Ctrl-M from Ctrl-Y since changing that hotkey rather than all the redo keys seemed easier. I checked and it doesn't appear that it conflicts with any other hotkeys.

Please note that I am participating in a class that deals with open source work so any criticism or comments would be appreciated. Thanks.
Hrm.  It's way too much of a long weekend for this.  We seem to support Ctrl+J as an alternate shortcut for search, in case people are using emacs keybindings, but I don't know if that's worth using up Ctrl+M instead.

We could go to Ctrl+Shift+Y instead, rather than eat a different key shortcut.  Alternate shortcuts are the bane of my existence sometimes.  http://mxr.mozilla.org/mozilla-central/source/content/xbl/builtin/unix/platformHTMLBindings.xml is where the redo  shortcuts live, it's not a huge change, but will also break people, I'm less inclined to break Redo than Downloads.
The problem can be solved by making changes in the 2 files, browser.dtd and downloads.dtd.  Basically, we just need to change 'y' to other key not used for any short cut.  I used 'e' and it is working even when focus is in the textbox.

(browser/locales/en-US/chrome/browser/browser.dtd ).

-<!ENTITY downloadsUnix.commandkey      "y"> 
+<!ENTITY downloadsUnix.commandkey     "e">   

(toolkit/locales/en-US/chrome/mozapps/downloads/downloads.dtd).

-<!ENTITY cmd.close2Unix.commandKey      "y"> 
+<!ENTITY cmd.close2Unix.commandKey     "e">
Yes, that's exactly what the existing patch does, except it uses m.  I think I'm more inclined to go to Ctrl+Shift+Y than consume another key.
This should do the trick. I changed it so that it`s Ctrl+Shift+Y to open the download manager now.
Attachment #362486 - Attachment is obsolete: true
Attachment #363026 - Flags: review?(mconnor)
Attachment #363026 - Flags: approval1.9.1?
Attachment #362486 - Flags: review?(mconnor)
Attachment #362486 - Flags: approval1.9.1?
Attachment #363026 - Flags: ui-review+
Attachment #363026 - Flags: review?(mconnor)
Attachment #363026 - Flags: review+
Attachment #363026 - Flags: approval1.9.1?
Attachment #363026 - Flags: approval1.9.1+
This is ready to land now, adding checkin-needed
Keywords: checkin-needed
Attachment #363026 - Attachment description: changed the download manager hotkey to require shift on Unix → changed the download manager hotkey to require shift on Unix [Checkin: Comment 22]
Comment on attachment 363026 [details] [diff] [review]
changed the download manager hotkey to require shift on Unix
[Checkin: Comment 22]


http://hg.mozilla.org/mozilla-central/rev/f4c28aa22bff
Assignee: nobody → crusader
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: [needs 1.9.1 landing]
Target Milestone: --- → Firefox 3.2a1
Version: unspecified → Trunk
Status: RESOLVED → VERIFIED
Verified
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090305 Minefield/3.2a1pre

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4pre) Gecko/20090305 Shiretoko/3.1b4pre
Blocks: 1551057
You need to log in before you can comment on or make changes to this bug.