Closed Bug 37650 Opened 24 years ago Closed 24 years ago

Initial values in text boxes not being displayed.

Categories

(Core :: XUL, defect, P3)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: morse, Assigned: kinmoz)

References

Details

(Whiteboard: [nsbeta2+] Fix checked in.)

Attachments

(1 file)

Go to cookie viewer (tasks->personal managers->cookie manager->display cookies) 
and select a cookie.  Its properties are supposed to be displayed in the box in 
the lower part of the viewer.  But instead the property fields remain blank.  If 
you click on any of the fields, the value for that field suddenly appears.

Assigning to Ben although I know this is not his problem.  But at least he'll 
know whom to reassign this to.
Keywords: nsbeta2
Component: XPApps → Cookies
QA Contact: sairuh → tever
Component: Cookies → XPApps
This is not a cookie problem and so components should not be set to "cookies".  
Ben has informed me that it occurs in prefs as well, although I have not yet 
been able to get a build all week-end that allows the prefs panel to come up -- 
it loops reporting "inefficient xul".
As of today's build I am able to get to prefs panel and I verified that it 
indeed has the same problem.  Updating summary line to reflect that it is not a 
cookie-viewer problem but rather a text box problem.
Summary: Cookie properties not being displayed in cookie viewer → Initial values in text boxes not being displayed.
duh, this shouldn't go to tever... ;-)
Component: XPApps → XP Toolkit/Widgets
QA Contact: tever → jrgm
*** Bug 37929 has been marked as a duplicate of this bug. ***
...and this is seen on linux as well as mac.
OS: Windows NT → All
Hardware: PC → All
I originally observed this on windows.  So if you are saying that you see it on 
both linux and mac, then it's on all three.
*** Bug 38474 has been marked as a duplicate of this bug. ***
triaging for Don...
Target Milestone: --- → M17
adding kin to the cc list.
*** Bug 38582 has been marked as a duplicate of this bug. ***
Putting on [nsbeta2+] radar for beta2 fix.
Whiteboard: [nsbeta2+]
someone in your group, beth? 
Assignee: ben → beppe
sending this to the font man! erik
Assignee: beppe → erik
Beth, since the text appears when you click on any of the fields, it doesn't
sound like a font problem to me. Perhaps it's an event system problem or a text
field problem? I don't know who owns those. Do you?
Assignee: erik → beppe
thanks Erik -- I'll try to narrow it down and get this to the correct person
kin, can you take a look at this please
Assignee: beppe → kin
Target Milestone: M17 → M16
Accepting bug.
Status: NEW → ASSIGNED
I think I have a fix for this. I'll attatch my patch to the bug. I have to do 
more testing on it, and run it past buster@netscape.com.
That patch fixed the cookie viewer problem.  r=morse.  Thanks kin.
Whiteboard: [nsbeta2+] → [nsbeta2+] Fix in hand expect to check it in on 05/31/00.
aren't bug 24598 and this pretty much the same, just in different places?
Fix checked in:

Modified AttributeChanged() to allow us to set the value attribute
even though mEditor is null.

r=morse@netscape.com  a=beppe@netscape.com
Status: ASSIGNED → RESOLVED
Closed: 24 years ago
Resolution: --- → FIXED
Whiteboard: [nsbeta2+] Fix in hand expect to check it in on 05/31/00. → [nsbeta2+] Fix checked in.
*** Bug 24598 has been marked as a duplicate of this bug. ***
verified fixed -- mac/linux/win32 -- 2000053109 comm. builds
(with one minor related behaviour uncovered -- bug #41109).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.