Closed Bug 37877 Opened 20 years ago Closed 4 years ago

Netscape content in mozilla sidebar customize dialog

Categories

(SeaMonkey :: Sidebar, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: BenB, Unassigned)

References

(Blocks 1 open bug)

Details

If you click on "Sidebar|Customize...", you'll find a full bunch of AOL's
services. On the other hand, Altavista etc. in the search panel seems to have
vanished.

What does a Mozilla hacker need a Netscape Horoscope panel for? If somebody
really wants this, Netscape can provide links to those panels on its webpage. We
can't ship with every panel in the world in the options list, can we?

Somebody unbiased should determine, which panels should be shipped as options
and which not.
Blocks: 14532
Adjusting summary to match other 14532-blocking bugs.
Summary: Revisit shipping panel options → (Shipping) Panel options need cleanup
Who, pray tell, would you consider to be unbiased?
You (I hope).
Each time I open "Customize Sidebar", I am surprised anew. This time, I seem to
be fed by a Netscape server with panel opens (not just panel contents). My
custom, direct from cvs Mozilla build shows as panel options:

 What's Related
 Search
 Bookmarks
Lieblinge [(extremely bad translation of "Favorites" into German)]
  ConSors Discount-Broker
  DAB Online Brokerage
  eBay Germany
  investorworld
  lastminute.com
  TicketOnline
My Netscape Network
  Gesamtes Netzwerk
 International

I get not hit searching for "consors" on our CVS rep, so this data must be
fetched from the net. The localized content suggests an embedding in the
Netscape Network. So, this bug got security-relevant.

Please, I am here to work. I don't want to be snooped, nor distracted by
commercial stuff. If you need to test network-fetched content,
- provide an option to disable it
- set up test cases on mozilla.org servers, not Netscape servers
*before* you check it into the tree and enable it.
Severity: normal → major
BTW: I wrote this *after* I took a deep breath :).
Blocks: 44845
m18, resummarizing.
Summary: (Shipping) Panel options need cleanup → Netscape content in mozilla sidebar customize dialog
Target Milestone: --- → M18
I'm sure it's trivial to plug in another side-bar directory should anyone ever 
set one up (the panels themselves can already come from anywhere), but until 
someone does why not take advantage of the Netscape collection? There is some 
interesting stuff in there along with the horoscopes crap.

I frankly don't see that it's worth anyone's time to set up a sidebar provider 
on mozilla.org simply to be "not Netscape" (and if it's worthwhile enough to 
you to do it, Ben, you should assign the bug to yourself rather than slamm).  
But if Netscape 6 is a success it would be quite interesting if someone like 
Yahoo set one up. Nothing like competition to improve the quality of offerings.

We should consider what might need to be done from a privacy standpoint for 
PR3. The panel list should only be requested when you try to customize, and if 
you don't have any netscape-hosted panels there shouldn't ever be a request to 
netscape.com for anything. If you think the sidebar is pinging netscape.com 
when all you have is mozilla.org panels then we've got a problem I'm interested 
in but it should be filed as a separate bug. Assign that to me for now if you 
like since I'm the manager of some privacy-related stuff like cookies.
Filed bug 46400 about querying netscape.com servers.

I think, this bug is still valid.
No longer blocks: 44845
Depends on: 52997
Depends on: 46400
No longer depends on: 46400
Reassigning 50 Sidebar bugs to Matt.  I was told this was going to be done 
shortly about two months ago, but it clearly hasn't been.  I think that's long 
enough for all these bugs to remain assigned to nobody.

Feel free to filter all this spam into the trashcan by looking for this string 
in the message body: ducksgoquack
Assignee: slamm → matt
spam : changing qa to sujay (New Sidebar QA)
QA Contact: shrir → sujay
I think this is fixed (?). Ben, can you please give an update whether this still
exists?
No change
Target Milestone: M18 → ---
The problem is in all.js and all-ns.js

all.js ends with:

pref("sidebar.customize.all_panels.url",
"http://sidebar-rdf.netscape.com/%LOCALE%/sidebar-rdf/%SIDEBAR_VERSION%/all-panels.rdf");
pref("sidebar.customize.more_panels.url", "http://dmoz.org/Netscape/Sidebar/");

You probably want to replace that first entry with something that is non-netscape.

all-ns.js contains:
pref("sidebar.customize.more_panels.url",
"http://info.netscape.com/fwd/sidusodp/http://search.netscape.com/mysidebar.tmpl");

Probably what netscape would then want to do is the
"sidebar.customize.all_panels.url" entry to all-ns.js

If mozilla and ns6 had their own default/prefs files, then the user would get to
see each "correct" sidebar directory when they are in the appropriate application.
Let's try and fix this for mozilla0.9.6.
Assignee: matt → sgehani
Target Milestone: --- → mozilla0.9.6
My last comments were made under an erroneous interpretation of the "fix" for
this bug.  I was assuming we just needed to move a pref or two from all.js ->
all-ns.js.  But in fact this is not the case.  When we have/find a non-Netscape
sidebar directory that mozilla wants we can make this change.  
Target Milestone: mozilla0.9.6 → Future
asa!!!
Bugzilla Bug 49367 Mozilla.org needs a sidebar server

i think benc meant 'staff!'
Depends on: 49367
I should have said: "timeless!!!"
I now found that all the "let's remove every trace of the 'Netscape curse word'
from my self-written Mozilla" bugs have been filed by netscape-word-hater
extraordinaire Ben Bucksch...

Btw: netscape.com folks, do you seriously need to pay attention to guys like Mr.
 "Menendez brother" Bucksch, and his anti-netscape irrelevant "bugs" like this???

This goes to him and the other folks monitoring this, huh, "bug":

Why the anti-Netscape bias? Is Netscape leaving the Mozilla.org project?
Last time I looked, Netscape started this project. Netscape is funding
it. Netscape is promoting it, and still suddenly "netscape" is a curse word??.

Look at Sun and their OpenOffice / StarOffice... OpenOffice is open source, YET,
when you check the "about..." you see "Copyright Sun Microsystems, and
openoffice.org contributors". I don't see why Mozilla's about box couldn't be
the same, after all, it IS the result of Netscpae AND the open source community.
Luckily, OpenOffice.org is an open source project not ashamed of
praising (instead of biting) the hand that feeds them.

I am seeing a small but growing anti-Netscape movement in the Mozilla.org
community, some extremists that wish that Netscape (the browser and the company)
"would just go away". In my opinipon, these elements are of little value to
Mozilla.org, and the development of corporate-sponsored open source projects.

I'm frankly tired of all the "remove Netscape"-bashing.  First it was Netscape
and now AOL who has spent a lot of money developing Mozilla -- true, there's
some amount of outside development, but the bulk of it has been funded by AOL
for use in their Netscape product.  The least you can do is lend a few kind words.

Personally, I use the Netscape-branded browser (Netscape 7 is a very good
browser on all three platforms) and I use their portal site.  You should, too. 
All of this stupid Slashdot groupthink of "Mozilla good, Netscape bad!"
completely ignores the fact that if there were no Netscape, there would be no
Mozilla.

Or the more likely scenario -- if AOL hadn't acquired Netscape, Netscape might
have gone out of business without the backing of a big tech player, and most of
you would be using Mozilla 0.2 right now.

Give Netscape some credit, folks, even if it means just a small little word
somewhere in the about box or in the docs.

They're trying to be a good open source citizen.  Don't disappoint them with a
childish "take take take" attitude.

Just my $0.02
Fernando


1. I don't hate Netscape. I very much value its contributions. But this is
Mozilla. "Netscape" is a trademark, for a start.
2. Please don't attack me personally, esp. not for stuff I wrote 2.5 years ago.
I didn't attack Netscape, nor did I attack any persons.
3. Please don't copy&paste the same, long comment in 3 bugs. This is spam.
4. AOL is known to trace its customers, and I don't want to be traced while I
work on Mozilla. Similarily, I am a bit offended by finding horoscope crap in
Mozilla (no matter how it got there, as long as I didn't ask for it). There is
not place for such stuff in Mozilla IMHO.
> Give Netscape some credit, folks, even if it means just a small little word
> somewhere in the about box or in the docs.

Oh, I am all for that. Netscape should get a big "Thanks" there.

(The above comment were a response to the comment in all 3 bugs.)

I don't mind much this being WONTFIXed. I don't want to get into more flamewars.
I don't care anymore.

People who dislike this can use Beonex Communicator, which contacts servers as
little as possible.
Assignee: sgehani → stolenclover
Severity: major → normal
Status: NEW → ASSIGNED
Product: Browser → Seamonkey
Is this still an issue? Has the problem been resolved?
If so (or not), please update this bug.
Assignee: danielwang → sidebar
Status: ASSIGNED → NEW
QA Contact: sujay
More "turned into a grotesque mockery" than "resolved": a very few still work, most return 404s, or full-sized 404 HTML pages, or full-sized pages, or a notice that you should look for other tabs at netscape.com URLs that redirect to the download page for NS8. 
You may want to read bug 384178, especially bug 384178 comment 3 on this. To summarize, this category doesn't exist anymore, but I've tried to rebuild it and it will be published again soon on dmoz.org if everything goes as expected.
Assignee: sidebar → nobody
Priority: P3 → --
QA Contact: sidebar
Target Milestone: Future → ---
Blocks: 1292481
This one probably expired with fix for "Bug 14532 - Netscape-branded content in Mozilla tree", at least nowadays there are  no longer links pointing to Netscape Contents.

No idea how to make this one "EXPIRED"
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
I think this is fixed (?). Ben, can you please give an update whether this still
exists?
like this website :http://artisanparisweb.com/
You need to log in before you can comment on or make changes to this bug.