bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Pressing delete (backspace) on keyboard does not go back in history



Camino Graveyard
11 years ago
9 years ago


(Reporter: Paul Borokhov (lensovet), Assigned: Stuart Morgan)



Mac OS X


(Whiteboard: [camino-2.0])



11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

With build Version 2007050405 (2.0a1pre) of Camino, pressing backspace has no effect when the page has focus. Previously it would go back one page. Cmd-bracket works as expected.
Shift-backspace also does not work as forward.

ps. my browser.backspace_action value is 0, so that's not the culprit.

Reproducible: Always

Steps to Reproduce:
1. Load a page
2. Click on a link
3. Make sure page has focus, then press backspace
Actual Results:  
Nothing happens

Expected Results:  
Browser goes back one page

Comment 1

11 years ago
apologies for the incorrect UA used for reporting this – should be Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.9a5pre) Gecko/20070504 Camino/2.0a1pre
Stuart, I presume this is also bug 379199?

Comment 3

11 years ago
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 379199


11 years ago

Comment 4

11 years ago
Reopening; this will need to be fixed in Camino (probably the same way 405744 will be).
Keywords: regression
Resolution: DUPLICATE → ---
Target Milestone: --- → Camino2.0
Version: unspecified → Trunk


11 years ago
Ever confirmed: true
Summary: Pressing backspace on keyboard does not go back in history → Pressing delete (backspace) on keyboard does not go back in history

Comment 5

10 years ago
I've spend some time looking at this, and I'm not convinced that re-implementing this feature given the current state of trunk is reasonable; see bug 379199 comment 28.
well that sucks, i use this every day. :(

Comment 8

10 years ago
Yeah, I use it every time I use a browser (of any flavor). I downloaded the 2.0a1pre nightly from 3 days ago (2008101700) to fix another problem (wouldn't launch without crashing), and ended up not being able to use the Delete key to go back.

Comment 9

10 years ago
We are aware that it doesn't work, which is why the bug is open. It's not a question of wanting the behavior to work, it's finding a technical solution that addresses the issues raised in comment 5.


9 years ago
Duplicate of this bug: 475649


9 years ago
Hardware: PowerPC → All
I really expected we'd have seen more complaints about this; either people are reading the release notes, or not that many people really use it.

Stuart, do we have any strategy to fix this (something like bug 462234?), or should this get moved off the 2.0 list?

Comment 12

9 years ago
Fixing it that way scares me, so this will likely be pushed, but let's leave it for the moment so that I remember to look into it at the same time and see if I think it's not as bad as I think.

Comment 13

9 years ago
Given that JS could reasonably want to handle delete, I don't think it's a good idea to try to hack around this; we'd almost certainly break web pages. I think we either need bug 379199 fixed, or we need to mini-fork and put a workaround in Cocoa widgets (doing what I suggest in 379199, even if only for the delete key).

Comment 14

9 years ago
i agree this is an important feature. having it on top of the issues list is probably why not many people complain, i myself came here only now to see if there are developments on this because i knew it was a known issue..
sadly it appears it won't be easily fixed :(

Comment 15

9 years ago
any news on this?

Comment 16

9 years ago
If there were news, it would be in the bug; please don't comment just to ask for updates.


9 years ago
Duplicate of this bug: 499597

Comment 18

9 years ago
please have this bug fixed. the delete key is a general feature people do a lot when browsing. this is actually a reason why I am not using the beta of camino 2 right now. I tried it for several times now, but all the time the delete key does not work

Comment 19

9 years ago
Fixed by the checkin in bug 519922.
Assignee: nobody → stuart.morgan+bugzilla
Last Resolved: 11 years ago9 years ago
Component: Accessibility → General
QA Contact: accessibility → general
Resolution: --- → FIXED
Whiteboard: [camino-2.0]
You need to log in before you can comment on or make changes to this bug.