[REGRESSION]Clicking on a drop down menu causes surrounding text to be selected when mouse moved

VERIFIED FIXED in M16

Status

()

Core
Layout: Form Controls
P1
critical
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: WD, Assigned: mjudge)

Tracking

({regression})

Trunk
x86
Windows 95
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; m16) Gecko/20000505
BuildID:    2000050513

When an item or the scrollbar of a dropdown menu is clicked, it causes the mouse
to go into "hilite mode".   That is, when the mouse is moved around, it hilites
the text that it is moved over

Reproducible: Always
Steps to Reproduce:
1.Go to http://www.mozilla.org/quality/help/bug-form.html
2.Click the down arrow for the "Component" pulldown menu.
3.Click the scrollbar for the dropdown menu once
4.Move the mouse around the page (over text)


Actual Results:  The text moved over is hilited	

Expected Results:  The text is not affected

Comment 1

18 years ago
Reproduced this bug (sorta) in M15, Mac OS 9.0.4, MRJ 2.2, carbon libs 1.0.4.

After linking to the above page, drop down menu scrollbar doesn't work.
Scrolling in the menu field does work.  Text *does not* highlight, however.

Comment 2

18 years ago
Win98SE build 50608 - Same behaviour
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

18 years ago
I've seen this for awhile.  I assume it's a dup since I never reported it, but 
I'm not sure.

Comment 4

18 years ago
yes, this is really bad and I don't think it is a dup.
Severity: normal → critical
Status: NEW → ASSIGNED
Priority: P3 → P1
Target Milestone: --- → M16

Comment 5

18 years ago
I am tracking this down, the regression occurred sometime between 4/8 and 4/15
Keywords: regression
Summary: Clicking on a drop down menu causes surrounding text to be hilited when mouse moved → [REGRESSION]Clicking on a drop down menu causes surrounding text to be hilited when mouse moved

Comment 6

18 years ago
The look horrible and really needs to be fixed.
Whiteboard: nsbeta2

Comment 7

18 years ago
After doing literally 15 or more date/time based pulls I narrowed it down to 
Mike Judge's MouseCapture checkin on 04/11/00 20:00.  I am not sure why it took 
so long for someone to notice the problem.

To reproduce, load the attachment I will be adding, click on the combobox, 
scroll the scrollbar with the mouse. Now, move the mouse off of the dropdown 
down. It is in some funky state and thinks we are trying to do selection in the 
document.

Mike, your MouseCapture checkin has horked the dropdown. I am reassigning this 
to you because you know the capture code.
Assignee: rods → mjudge
Status: ASSIGNED → NEW
Keywords: nsbeta2
Summary: [REGRESSION]Clicking on a drop down menu causes surrounding text to be hilited when mouse moved → [REGRESSION]Clicking on a drop down menu causes surrounding text to be selected when mouse moved
Whiteboard: nsbeta2

Comment 8

18 years ago
Created attachment 8578 [details]
simple test

Comment 9

18 years ago
An additional point is that the dropdown list never gets the MouseUp call as a 
DOM lsietener. It used to get this.
(Assignee)

Comment 10

18 years ago
hmm. ok i guess when D&D start we need to release the mouse capture both system 
wide and view wide.  calling CaptureMouse(context,PR_FALSE) and following up 
with a selection->SetMouseDownState(PR_FALSE) will stop selection from 
continuing. the 'Widget(tm)' level capturing is kinda out of my league here. 
Curently the windows code captures the mouse for the given window when a mouse 
down occurs.  I will fix what I can then you can tell me if thats good enough.
Status: NEW → ASSIGNED

Comment 11

18 years ago
[nsbeta2+]
Whiteboard: [nsbeta2+]

Comment 12

18 years ago
Is this why I cannot jump to a time at www.tvguide.com/listings/ web site?  Go
there and pull down the first list to select a different day.  Notice nothing
happens using mozilla.  Now try netscape 4.72 and it works.
(Assignee)

Comment 13

18 years ago
this should be fixed in this mornings builds. please verify
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

18 years ago
Very close!          The original behavior is almost all gone.    But try this 
out:           (This happens with my 2000051520 build)

On the URL associated with this bug, 
1. click on the dropdown menu for "component"
2. Scroll the sidebar on this dropdown menu.  (notice no text gets hilited)
3. Now, while the dropdown menu is still open, click at the very top of the web 
page area.

All text between the "Component" dropdown menu and where you clicked is hilited.
I believe this bug is still related do what was originally filed, and a new bug 
report does not need to be created, right?

-WD
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 15

18 years ago
ok got this one fixed. please retest
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Updated

18 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 16

18 years ago
I do not yet see the problem fixed as of 200051613
Is it just that the fix hasn't been incorporated into the nightly build yet?

I tried the latest talkback and regular Win32 builds with the same result as 
above.   I tried a Linux build, and it doesn't quite hilite the text as with 
Win32, but the behavior is not quite right there either.   With the first click 
(which would have left text hilited on Win32), the drop-down menu disappears but 
leaves a thin line around where the edge of the dropdown was.   A second click 
elsewhere on the page removes this "ghost outline".

The Linux result sounds different than the Win32, but I believe that in both 
cases, it's caused by improper handling of clicking elsewhere while a dropdown 
menu is open.       When testing, make sure that you move the scrollbar on the 
dropdown menu up and down before clicking elsewhere.   (otherwise, I believe the 
behavior is normal)


-WD

Comment 17

18 years ago
you have to wait for the check in to hit, Mike checked it in around 5:00 or so, 
your build was made at 1:00. Rule of thumb, wait till the next day to verify a 
fix.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 18

18 years ago
Ok, Sorry if I'm jumping the gun here, but I'm still seeing this as of 
2000051620.

What's new about this build is that when I move the scrollbar on the dropdown 
menu, the *entire page* is scrolled along with it.     (along with the text 
being hilited when I click elsewhere on the page)

Re-Open?      
(I'm still kinda learning the ropes here with BugZilla...   sorry)

Comment 19

18 years ago
No problem, and it is confusing as to when to reopen a bug. But, to answer 
your question - you need to check and see if the original stated issue was 
resolved. If the original issue is resolved, then go ahead and mark this as 
verified. Then open a new bug for the new issue. We try to keep one issue per 
bug, it makes it easier to track.
(Reporter)

Comment 20

18 years ago
OK, I've filed the following bugs which I believe are both somewhat related to 
this original bug:

Bug 39601
Bug 39603

Comment 21

18 years ago
39601 and 39602 are duplicates of this bug, because none of this behavior 
existed before mjudge's fix.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 22

18 years ago
*** Bug 39601 has been marked as a duplicate of this bug. ***

Comment 23

18 years ago
*** Bug 39603 has been marked as a duplicate of this bug. ***

Comment 24

18 years ago
*** Bug 38442 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Blocks: 38925

Comment 25

18 years ago
Another issue: after a couple of clicks dropdowns stop dropping down.

Updated

18 years ago
Blocks: 39629
(Assignee)

Comment 26

18 years ago
ahh i see. just adjust the style on the drop down combo box to be user-select: 
none. i will check this in when i can.
Status: REOPENED → ASSIGNED
(Assignee)

Comment 27

18 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 28

18 years ago
Verified 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.