Closed Bug 388509 Opened 12 years ago Closed 11 years ago

URL without a scheme in the Mail Start Page prefs UI doesn't work

Categories

(Thunderbird :: Preferences, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b3

People

(Reporter: stephend, Assigned: mkmelin)

References

Details

Attachments

(1 file)

Build ID: Today's trunk Win32 builds (this is really cross-platform, though).

Summary: URL without a scheme in the Mail Start Page won't load

Steps to Reproduce:

1. In the "Thunderbird Start Page" section, enter a path/hostname without a scheme, such as www.coleypharma.com or coleypharma.com
2. On Windows, click OK (on Mac, just dismiss the dialog)
3. Click "Go | Start Page"

Expected Results:

The URL without a scheme, entered in step #1 loads

Actual Results:

Look like we do a reflow (wiping out Thunderbird's header pane!), but we don't load that page.  Nothing is thrown in the Error Console, either.

David and I chatted on IRC, and we both seemed to think either validation--including but not limited to disabling the OK button (at least on Windows) until we have a scheme we like--is the way to go.
I've changed the summary a little to reflect the fact that we really just want to prevent this in the prefs UI.
Summary: URL without a scheme in the Mail Start Page won't load → shouldn't allow URL without a scheme in the Mail Start Page prefs UI
Firefox allows one to use e.g. www.mozilla.org as homepage. 
Though currently, no start page is working for me... bug 388441.
Component: Mail Window Front End → Preferences
QA Contact: front-end → preferences
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Summary: shouldn't allow URL without a scheme in the Mail Start Page prefs UI → URL without a scheme in the Mail Start Page prefs UI doesn't work
Target Milestone: --- → Thunderbird 3.0b3
Attached patch proposed fixSplinter Review
Use urifixup to allow start pages without scheme etc. 

For offline we have the disk cache nowadays...
Attachment #364568 - Flags: review?(philringnalda)
Though for testing, beware of bug 480606.
Comment on attachment 364568 [details] [diff] [review]
proposed fix

We don't have the disk cache on, say, first run after a version change. If you want to do that, let's do it in a separate bug.
Attachment #364568 - Flags: review?(philringnalda) → review-
Well, for those special cases where we are offline and don't have the page in cache the "Offline Mode" error page is shown. It has a bit browser specific text, but other than that, isn't that an improvement over a totally blank area?
Yep, you might be able to make that case (probably to Bryan, who'll be on your side anyway since he thinks it should never under any circumstances be blank) in the bug on doing it. Or you might wind up getting stuck with doing mail/locales/en_US/chrome/overrides/netError.dtd ;)
Depends on: 483011
Comment on attachment 364568 [details] [diff] [review]
proposed fix

So, any reason not to do this now when we have our own error page?
Attachment #364568 - Flags: ui-review?(clarkbw)
Attachment #364568 - Flags: review?(philringnalda)
Attachment #364568 - Flags: review-
Comment on attachment 364568 [details] [diff] [review]
proposed fix

looks good
Attachment #364568 - Flags: ui-review?(clarkbw) → ui-review+
Attachment #364568 - Flags: review?(philringnalda) → review+
Comment on attachment 364568 [details] [diff] [review]
proposed fix

Sure.
changeset:   2463:4f81a119cef8
http://hg.mozilla.org/comm-central/rev/4f81a119cef8

->FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.