bcc should be the default for all mail lists unless specified differently

RESOLVED DUPLICATE of bug 283400

Status

RESOLVED DUPLICATE of bug 283400
11 years ago
10 years ago

People

(Reporter: wperko, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511
Build Identifier: 2.0.0.5 (20070716)

Hi, In today's eMail SPAMMER hell the end user (like me) should be able to have a friends list in the address book that when selected automatically posts the names and email address into the "Bcc" field rather than the "To:" field.  This helps to prevent passing on names when people forward emails along and to keep the friends on my left hidden from the friends on my right.  

I expect that when I click on a list of address' from the address book that Thunderbird will automatically change the "To" to a "Bcc" type addressing, and/or that I can set an "Always Bcc" in the address book when creating mailing lists to protect email address of all my friends.


Reproducible: Always

Steps to Reproduce:
1. I type in the email address list name.
2. I forget to change from "To" to "Bcc" to the left of addressing.
3. 
Actual Results:  
I inadvertantly send out all the names on the list viewable to the world.

Expected Results:  
When I add a mailing list to any address line in Thunderbird all the address' would be converted to a "Bcc" to prevent accidental posting everybodys email address to everybody else on the list and the next persons inadvertant forwarding of the email to their other friends who move the list along. 


Thunderbird should automatically convert any email list of address' to a "Bcc" befor sending the mail out to force the user to return to a "To" style addressing if needed.

Thunderbird should let the end user specify as "Always Bcc" or not in the address book for each email list

Comment 1

11 years ago
Shouldn't these

<https://bugzilla.mozilla.org/show_bug.cgi?id=163498>
<https://bugzilla.mozilla.org/show_bug.cgi?id=378531>

belong in one single bug, e. g. "Bcc handling in Address Book", which would
include lists?

A setting for an address to default to Bcc as soon as there are several
addresses included in sending a message might be a nice thing. Presumably, it
might be turned into part of electronic address preferences as in vCard etc.
standards (<http://en.wikipedia.org/wiki/VCard>).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 283400
You need to log in before you can comment on or make changes to this bug.