Closed Bug 389787 Opened 13 years ago Closed 11 years ago

[Proto] Event dialog: Customizing toolbar mode (full, icons, text) not working

Categories

(Calendar :: General, defect)

Sunbird 0.7
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: lijuan1.wang, Assigned: berend.cornelius09)

References

Details

Attachments

(1 file, 1 obsolete file)

Reproduce steps:
1. Launch thunderbird, focus on calendar panel
2. On thunderbird main menu: File->New->Event
3. Pop out a "New Event" dialog,in the dialog,View->Toolbar->Customize
4. Pop out "Customize Toolbar" dialog.In the buttom, select "Show" as "Text" in the drop down box

Expected result:
After #4: Toolbar of "New Event" dialog should only show text.

Actual result:
After #4: Toolbar of "New Event" dialog still show "icons and text"
Confirmed using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.6pre) Gecko/20070726 Calendar/0.7pre
Component: Calendar Views → General
OS: SunOS → All
QA Contact: views → general
Summary: In "New Event" dialog, view-toolbars can't be customized → [Proto] Event dialog: Customizing toolbar mode (full, icons, text) not working
Also confirmed with Lightning 0.7pre (2007072704) on WinXP.

Hint:
sun-calendar-customize-toolbar.js is not included in sun-calendar-customize-toolbar.xul.

For Sunbird only:
Cancel button doesn't work:
Error: onCancel is not defined
Source File: chrome://global/content/bindings/dialog.xml
Line: 357

chrome://messenger/skin/addressbook/addressbook.css
chrome://messenger/skin/messengercompose/messengercompose.css
chrome://messenger/skin/smime/msgCompSMIMEOverlay.css
chrome://messenger/skin/primaryToolbar.css

Those CSS files are referenced in sun-calendar-customize-toolbar.xul but not available in Sunbird.

Hardware: PC → All
(In reply to comment #2)
> For Sunbird only: Cancel button doesn't work
Filed as Bug 389700
Component: General → Theme
Product: Calendar → Firefox
Target Milestone: --- → Firefox 3
Version: Lightning 0.5 → Trunk
Oops, sorry, my bad, returning to the right component, awfully sorry about stomping your target milestone, please send hatemail to this address :(
Component: Theme → General
Product: Firefox → Calendar
Target Milestone: Firefox 3 → ---
Version: Trunk → Sunbird 0.7
Still happens in lightning 0.9pre (2008033120) on TB 2.0.0.16. Nominating for tb-integration.
Flags: tb-integration?
I don't think this bug would block tb-integration.
Flags: tb-integration? → tb-integration-
Attached patch patch v. #1 (obsolete) — Splinter Review
I have stolen some rules from the global toolbarbutton.css file and now it works fine. What I still do not understand is why the rules in this original file were not applied.
Assignee: nobody → Berend.Cornelius
Status: NEW → ASSIGNED
Attachment #352535 - Flags: review?(philipp)
Comment on attachment 352535 [details] [diff] [review]
patch v. #1

I'd suggest just adding a rule to base/jar.mn:

% style chrome://calendar/content/calendar-event-dialog.xul chrome://global/skin/toolbar.css

I believe toolbar.css is not included through global.css.
Attachment #352535 - Flags: review?(philipp) → review-
Attached patch patch v. #2Splinter Review
Good solution and seems to work fine. Thank you!
Attachment #352535 - Attachment is obsolete: true
Attachment #354089 - Flags: review?(philipp)
Comment on attachment 354089 [details] [diff] [review]
patch v. #2

r=philipp.

We should make sure this is also done for Sunbird, the same problem may exist there too?
Attachment #354089 - Flags: review?(philipp) → review+
Duplicate of this bug: 471775
>We should make sure this is also done for Sunbird, the same problem may exist
>there too?
I tested the patch under Sunbird and it worked fine, too.
patch pushed to comm-central:
http://hg.mozilla.org/comm-central/rev/f97b9c228b6f

->fixed
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Checked in lightning and sunbird 20090106 -> VERIFIED

Follow up bug: No small icons in edit event/task dialog available

https://bugzilla.mozilla.org/show_bug.cgi?id=472466
Status: RESOLVED → VERIFIED
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.