Closed Bug 390763 Opened 13 years ago Closed 13 years ago

Hidden preference for collect incoming address doesn't work (code missing in msgHdrViewOverlay.js)

Categories

(Thunderbird :: Address Book, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: intendentedelleacque, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: 

The hidden preference "mail.collect_email_address_incoming" doesn't work on Thunderbird 2.0.x, because the code about it in msgHdrViewOverlay.js is missing.

Notice that here the code is present:
http://lxr.mozilla.org/mozilla1.8.0/source/mail/base/content/msgHdrViewOverlay.js#417

but in msgHdrViewOverlay.js inside messenger.jar the code is different and that part is missing.

Reproducible: Always

Steps to Reproduce:
1. set the hidden preference "mail.collect_email_address_incoming" to true
2. click on a mail in Inbox
Actual Results:  
The sender address should be added in addressbook

Expected Results:  
The sender address is not added in addressbook
Sorry, the "Actual results" and the "Expected Results" are invert...
Yes, it was intentionally removed in bug 331924 - sorry, but supporting hidden preferences is very expensive, particularly for ones that we expect to be very, very rarely used, since regressions in behavior they affect aren't likely to show up until the last minute, or more often after the last minute has already passed. I'd recommend looking around for someone to write an extension, if one doesn't already exist.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → INVALID
Ok, writing an extension that does it (if it's useful for someone), it's not difficult.
Anyway I think that the file mailnews.js should be modified, deleting the prefs mail.collect_email_address_incoming and mail.collect_email_address_newsgroup, because otherwise users could be confused and think that it's a bug in the program and not a intentional choice.
Hi, since some of you mentioned that the preference "mail.collect_email_address_incoming" is not necessarily useful, I just wanted to jump in to describe one possible purpose :

It's actually quite a nice option and there are quite a lot of add-ins for Outlook that allow you to do just that : automatically add incoming+outgoing addresses (optionally in both cases of course).

It's nice because that allows you to automatically keep track of people when they change their email addresses. Be honest: who does check if the email address in the email matches the one in the address book EVERYTIME when a new email comes in ? (particularly if the address book used is an external one because of the fancier options like the photographs you can add in the Outlook address book for example)
Often the email reader does not even see the address of the sender, because by default Thunderbird displays the sender alias only, not the actual address.

So if, let's say, your friend sends you an email from "Peter Pan <peterpan@hotmail.com>", and then definitely switches to "Peter Pan <peterpan@yahoo.com>" you will never realize the change as you only see "Peter Pan" and consequently you will never update your address book. If you are not aware of that change for any reason (and there are hundreds of reasons : he lost your address or didn't include you in the warning or you overlooked his warning or you deleted it alongside with spam messages,etc.), now the trouble begins, because when picking his address from your address book, you will send him a mail to his old address <peterpan> that he won't ever be able read of course.
Now there are 100 of ways to loose contact if it's a friend who lives 1000 of kilometers away and of whom you only have his mail address: he lost your address, or you - too - change your address, or he stops writing because he thinks you have never written (your message disappeared in his old account), etc. etc. ....

The way I use that option is to automatically add all outgoing and incoming addresses to "collected addresses". From time to time I delete addresses that I don't want to keep and then I move all the rest to "my personal addresses" (my second address book in Thunderbird). Then I use the Thunderbird extension "Duplicate Contact Manager" to merge the new info to the existing contacts and then delete the duplicates. This only costs me ~5 minutes per month for ~500 contacts (because not each contact has changed) and I rather loose 5 min per month than some friends spread across the globe that I met when travelling.

If people receive spam, they don't have to enable this option, but if they don't (as me), it's a perfect way to make sure, your address book is up to date.
Duplicate of this bug: 466948
You need to log in before you can comment on or make changes to this bug.