Flash animation hides DHTML dropdown menus

RESOLVED DUPLICATE of bug 258089

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 258089
11 years ago
11 years ago

People

(Reporter: Yannick De Visscher, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20061201 Firefox/2.0.0.6 (Ubuntu-feisty)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20061201 Firefox/2.0.0.6 (Ubuntu-feisty)

A flash animation seems to be always on a top layer in a page. This way it can hide dropdown menus or other dhtml components. Flash can't be affected by applying a z-index. I have this problem on my website but a perfect example can be seen on the adobe.com website and also on www.philips.com.
I'm sorry to say this but it's not the case in internet explorer.
I hope this can be easily solved.

Reproducible: Always

Comment 1

11 years ago
This is likely a duplicate of bug 111920.

Can you give us a URL where you see this problem?

"seen on the adobe.com website" is too unspecific.
(Reporter)

Comment 2

11 years ago
the homepage itselfs:
http://www.adobe.com/

the top menu (solutions|products|support|...) is covered by the flash animation below it.
(Reporter)

Comment 3

11 years ago
by the way I tried the wmode=transparent "solution"
no luck there...

Comment 4

11 years ago
Looks like wmode=transparent is simply not implemented for Linux in Firefox 2. There is a still ongoing effort to fix this in what will become Firefox 3:

bug 137189 – Windowless plug-in support for X (WMODE)
bug 258089 – plug-in obscures(?) pull-down menus generated by Javascript (DHTML)
bug 389549 – embeded flash object ignores wmode=transparent in Linux

As mentioned in bug 137189, Adobe needs to update its Flash plugin as well for this to work.

Comment 5

11 years ago
resolving as duplicate of bug 258089
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 258089
You need to log in before you can comment on or make changes to this bug.