Closed Bug 393584 Opened 13 years ago Closed 2 years ago

should bookmark sidebar and organizer search on descriptions, string annotations?

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 265048

People

(Reporter: moco, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

should bookmark sidebar and organizer search search on descriptions, string annotations, and tag names

right now, all we do is a case insensitive find in nsNavHistory::FilterResultSet() for url and title, but there are notes in that method for how to extend this to also search on annotations.

I think this makes a lot of sense, given that we have tags and description column in the bookmark organizer.

see also bug #393574.

note, if we think we are going to do this, bug #386396 would become WONTFIX.
Summary: should bookmark sidebar and organizer search search on descriptions, string annotations, and tag names → should bookmark sidebar and organizer search search on descriptions, string annotations, and tag names?
I agree, If we can't search in tags they become pretty useless.
I think it is important for the user to understand why their results match the search they entered.  So I would argue that the search field in the bookmarks sidebar should only match against title, since that is the only information displayed.

if they want to search against everything else, they can use the bookmarks organizer, or the location bar.

>I agree, If we can't search in tags they become pretty useless.

I think we should allow users to search against them in the location bar (bug #393508)

They are also useful for faceted browsing in the bookmarks organizer (bug #393512)

and for creating smart folders.
About the bookmarks sidebar, what about chosing the fields it searches against ?

> I think we should allow users to search against them in the location bar (bug
> #393508)

I agree
 

>About the bookmarks sidebar, what about chosing the fields it searches against

I don't think there is enough room in the bookmarks sidebar for specifying specific fields to search against with UI, but we could allow this in text, like entering the text tag:tagName
Attached image Search field selector mockup (obsolete) —
What about something like that ?
Another mockup, removed the "Search:" label, and like in the Bookmarks manager put "Search in Bookmarks" in the textbox to save place.
Attachment #278768 - Attachment is obsolete: true
I like these mockups.  I'll create a new iteration of the bookmarks sidebar (bug #393505) to include this type of selector.
Summary: should bookmark sidebar and organizer search search on descriptions, string annotations, and tag names? → should bookmark sidebar and organizer search on descriptions, string annotations, and tag names?
updating summary.

for tags, you can now search for them in both the urlbar (bug #395452), the bookmarks sidebar and the places organizer (bug #395462)
OS: Windows XP → All
Summary: should bookmark sidebar and organizer search on descriptions, string annotations, and tag names? → should bookmark sidebar and organizer search on descriptions, string annotations?
faaborg wrote:

"I think it is important for the user to understand why their results match the
search they entered.  So I would argue that the search field in the bookmarks
sidebar should only match against title, since that is the only information
displayed.

if they want to search against everything else, they can use the bookmarks
organizer, or the location bar."

I've spun this off to bug #405322, as now that we support tag searching, this is now a bug.
I like the mockup created by Darren in comment #6. Searching in the location bar doesn't replace searching in the bookmark sidebar (or the organizer) at least because the search result in the location bar also includes history. I hope this gets implemented before FF 3 is released.
Duplicate of this bug: 421996
ok, what is left seems to be making bookmarks descriptions content searchable in the library (bookmarks sidebar too?). marking already filed (old) Bug 265048 blocking this one.
Blocks: 265048
Flags: blocking-firefox3.1?
Not going to hold the 3.1 release for this, per bug 265048.
Flags: blocking-firefox3.1? → blocking-firefox3.1-
(In reply to comment #0)
> see also bug #393574.

and it seems to me also the bug 406246.
The bug 265048 already talks about searching in the description field when we open bookmarks and manage them. So is the current bug a duplicate of it?
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
Duplicate of this bug: 1441747
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 265048
You need to log in before you can comment on or make changes to this bug.