Layout issues in Applications tab in Options dialog

RESOLVED FIXED in Firefox 3 beta3

Status

()

P4
minor
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: bugzilla, Assigned: myk)

Tracking

({qawanted})

unspecified
Firefox 3 beta3
All
Windows XP
qawanted
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; da; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007091504 Minefield/3.0a8pre

Here are some layout issues I have seen in the new Applications tab ind the Options dialog.

* The list box jumps when the text "The following entries match your search:" is shown/hidden. This is annoying. Maybe the text should not be shown at all.

* The left and right margin of the search bar and list box is twice as thick as the rest of the items in the Options dialog. They are thus misaligned with the buttons in the bottom and the introduction text in the top.

* The select box in the selected item is too far to the left compared to the other items.

* Icons touch each other. It doesn't look great. There should at least be one pixel of space between the icons.

* The selected item is a few items higher than the rest of the items. This is annoying. I don't know exactly why, because I don't think it is annoying that the selected item is higher in the Add-ons manager. Maybe it is because the difference is so small.

Reproducible: Always
(Reporter)

Updated

11 years ago
Depends on: 377784
(Reporter)

Comment 1

11 years ago
Created attachment 281035 [details]
selectbox height

This shows that it is possible to have the same height on the selected item and other items without wasting much vertical space. BTW, this dialog from Windows XP is partly the origin of attachment 269761 [details].
(Assignee)

Comment 2

11 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; da; rv:1.8.1.6)
> Gecko/20070725 Firefox/2.0.0.6
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre)
> Gecko/2007091504 Minefield/3.0a8pre
> 
> Here are some layout issues I have seen in the new Applications tab ind the
> Options dialog.
> 
> * The list box jumps when the text "The following entries match your search:"
> is shown/hidden. This is annoying. Maybe the text should not be shown at all.

Yeah, it doesn't seem particularly necessary.  cc:ing faaborg for his thoughts.


> * The left and right margin of the search bar and list box is twice as thick 
> as the rest of the items in the Options dialog. They are thus misaligned with
> the buttons in the bottom and the introduction text in the top.

The intro text is going away, but we should indeed be aligned with the bottom buttons.


> * The select box in the selected item is too far to the left compared to the
> other items.

I'm afraid I don't understand this issue.  Can you explain further?


> * Icons touch each other. It doesn't look great. There should at least be one
> pixel of space between the icons.

Hmm, I don't see this on Mac and Linux.  Perhaps it's a Windows-only issue?


> * The selected item is a few items higher than the rest of the items. This is
> annoying. I don't know exactly why, because I don't think it is annoying that
> the selected item is higher in the Add-ons manager. Maybe it is because the
> difference is so small.

I agree, it would be better if there was no jumpiness when you move from item to item.


> This shows that it is possible to have the same height on the selected item 
> and other items without wasting much vertical space. BTW, this dialog from
> Windows XP is partly the origin of attachment 269761 [details].

Hmm, it doesn't look great to me the way the dropdown menu hangs over the item below it.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Target Milestone: --- → Firefox 3 M9
(Assignee)

Updated

11 years ago
Assignee: nobody → myk
>> * The list box jumps when the text "The following entries match your search:"
>> is shown/hidden. This is annoying. Maybe the text should not be shown at all.
>
>Yeah, it doesn't seem particularly necessary.  cc:ing faaborg for his thoughts.

Sorry didn't catch that in the UI review, go a head and remove that description as well.

>Hmm, it doesn't look great to me the way the dropdown menu hangs over the
>item below it.

we need to try to avoid that.
(Reporter)

Comment 4

11 years ago
Created attachment 281301 [details]
select box alignment + icons touch

(In reply to comment #2)
> > * The select box in the selected item is too far to the left compared to the
> > other items.
> 
> I'm afraid I don't understand this issue.  Can you explain further?

Marked with two vertical red lines.

> 
> 
> > * Icons touch each other. It doesn't look great. There should at least be one
> > pixel of space between the icons.
> 
> Hmm, I don't see this on Mac and Linux.  Perhaps it's a Windows-only issue?

Marked with a red circle.
(Reporter)

Comment 5

11 years ago
Additions:

* Now that the intro text is gone, there is also a too big top margin compared to the other tabs.

* There should be a tooltip for texts that are too long to be displayed.

* Options in the select box should not be cropped.

* The Feed icon on the tab doesn't feel right.

Further thoughts on:
> * The select box in the selected item is too far to the left compared to the other items.

In the select box a space reserved for a 16x16 icon is missing.
(Assignee)

Comment 6

11 years ago
Requesting wanted-1.9 for this Applications prefpane polish fix.
Flags: blocking-firefox3?
(Assignee)

Comment 7

11 years ago
Note: bug 395141 will affect some of the issues in this bug.
Flags: blocking-firefox3? → blocking-firefox3-
Whiteboard: [wanted-firefox3]
(Reporter)

Comment 8

11 years ago
New items:

* New applications tab icon has a white background, it should have a transparent one.

* "Choose application" option should be removed for the "Application" content type.

* "webcal" should have a better name.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007101005 Minefield/3.0a9pre
>* New applications tab icon has a white background, it should have a
>transparent one.

That's just a temporary icon, it will be refreshed along with every other icon before shipping.

>* "Choose application" option should be removed for the "Application" content
>type.

Where else would be put this option?

>* "webcal" should have a better name.

We want to group multiple content types into a single item, for instance webcal, hCalendar, and .ics into "Calendar"  Unfortunately this might not land in time.  Perhaps in the meantime we should say "webcal protocol"? 

(Reporter)

Comment 10

11 years ago
(In reply to comment #9)
> >* "Choose application" option should be removed for the "Application" content
> >type.
> 
> Where else would be put this option?

In the download dialog this option is not available. If it should be available in this list, it should be called "Run" or something like that. Mostly it does not make sense to open an application with another application.

> >* "webcal" should have a better name.
> 
> We want to group multiple content types into a single item, for instance
> webcal, hCalendar, and .ics into "Calendar"  Unfortunately this might not land
> in time.  Perhaps in the meantime we should say "webcal protocol"? 

Maybe, or something with the word "calendar" in it.

>it does not make sense to open an application with another application.

Sorry, just now figured out what you were talking about.  I agree that this makes little sense.
(Assignee)

Comment 12

11 years ago
It's much easier to track issues when there's a single bug for each issue.  Some of the issues raised in this bug have already been fixed (either because individual bugs were filed on those issues, or because they got fixed in the process of fixing another bug), but others haven't, and it's not clear from this bug report which issues are fixed and which remain.

We should file individual bugs for each remaining issue and then either close this bug or make it be a meta-bug that depends on all the individual bugs.
Keywords: qawanted
(Reporter)

Comment 13

11 years ago
Sorry for being lazy and just putting everything into one bug.

> * The list box jumps when the text "The following entries match your search:"
> is shown/hidden. This is annoying. Maybe the text should not be shown at all.

fixed

> * The left and right margin of the search bar and list box is twice as thick as
> the rest of the items in the Options dialog. They are thus misaligned with the
> buttons in the bottom and the introduction text in the top.

fixed

> * The select box in the selected item is too far to the left compared to the
> other items.

bug 398443

> * Icons touch each other. It doesn't look great. There should at least be one
> pixel of space between the icons.

bug 400217

> * The selected item is a few items higher than the rest of the items. This is
> annoying. I don't know exactly why, because I don't think it is annoying that
> the selected item is higher in the Add-ons manager. Maybe it is because the
> difference is so small.

bug 398445

> * Now that the intro text is gone, there is also a too big top margin compared
> to the other tabs.

fixed

> * There should be a tooltip for texts that are too long to be displayed.

bug 399539

> * Options in the select box should not be cropped.

bug 400218

> * The Feed icon on the tab doesn't feel right.

fixed

> * New applications tab icon has a white background, it should have a
> transparent one.

bug 400219

> * "Choose application" option should be removed for the "Application" content
> type.

bug 400222

> * "webcal" should have a better name.

bug 400224
(Assignee)

Comment 14

11 years ago
Not blocking, so lower priority, and making this a meta-bug which depends on the resolution of the bugs for each individual layout issue.
Priority: P2 → P4
Target Milestone: Firefox 3 M9 → Firefox 3 M11
Flags: wanted-firefox3+
Whiteboard: [wanted-firefox3]
(Assignee)

Comment 15

11 years ago
Removing bug 395647, as it isn't a layout issue.  That's the last open blocker for this meta-bug, so resolving this fixed.  Please do file more bugs as you encounter additional layout issues, but don't reopen this bug, as it has served its original purpose of focusing attention on the immediate issues discovered after the landing of the new Applications prefpane.

Status: NEW → RESOLVED
Last Resolved: 11 years ago
No longer depends on: 395647
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.