Incomplete Import Installation - impossible to restart process

RESOLVED FIXED in Thunderbird 3

Status

Thunderbird
Migration
P2
normal
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: Grenville Strickland, Assigned: Jeff Beckley)

Tracking

Trunk
Thunderbird 3
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: 8.0.0b1

I installed the above software, but had to terminate the process when it was importing the settings and messages of my old Eudora 7.1.0.9 (installed size of 1.5gb).

Now when I attempt to restart or re-install the software it doesn't detect the  importing wasn't completed and fires up the incompleted software - obviously missing personalities and all the messages which were in the old software.

I have tried to remove all the files from the hard-drive and clean as much of my registry as possible, but it has made no difference.

I cannot believe the installation process is a 'One-Shot' affair!

If the installation process is unexpectedly stopped, the software should be capable of picking up where it left off.



Reproducible: Always

Steps to Reproduce:
1. Start the installation.
2. When imnporting the old Eudora, terminate the process.
3. Restart the installation


Expected Results:  
I was expecting 8.0.0b1 to detect the process hadn't of completed and restarted the import. Alternatively instructions for recovery should the install process be unexpectedly interrupted.

As above!

Comment 1

10 years ago
Yes, I agree that it would be good to be able to manually initiate a 'migrate' and not just individual imports.
Assignee: mozilla-bugs → beckley
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Priority: -- → P2
Hardware: PC → All
Target Milestone: --- → 0.1
Version: unspecified → 0.1
(Reporter)

Comment 2

10 years ago
I have finally found that a manual 'import' is possible via the "Tools" and then "Import". However when I did this, the import utility did not import all the latest emails (emails that I had received between the aborted "importing" attempt - Yesterday - and the current date).

In addition, importing the filters did not work, so there is still outstanding issues with the import utility.
(Assignee)

Comment 3

10 years ago
There is a way to get the full import to kick off again, but it's not very obvious: you have to specify the "-migration" option on the command-line when restarting.

I'm going to be submitting a patch that will add UI to the Tools->Import dialog for doing a full profile migration in addition to the piece-by-piece method that's currently in there.

Moving this to Thunderbird, as that's where the fix will be.
Assignee: beckley → nobody
Component: Installer → Migration
Product: Penelope → Thunderbird
QA Contact: installer → migration
Target Milestone: 0.1 → ---
Version: 0.1 → Trunk
(Assignee)

Updated

10 years ago
Status: NEW → ASSIGNED
Component: Migration → Installer
Target Milestone: --- → Thunderbird0.2
Version: Trunk → 0.9
(Assignee)

Updated

10 years ago
Assignee: nobody → beckley
Status: ASSIGNED → NEW
Component: Installer → Migration
Target Milestone: Thunderbird0.2 → ---
Version: 0.9 → Trunk
(Assignee)

Comment 4

10 years ago
Created attachment 286799 [details] [diff] [review]
Manual migration implementation

This patch adds some UI to the Tools->Import dialog to allow the user to start a full profile migration.
Attachment #286799 - Flags: superreview?(mscott)
Attachment #286799 - Flags: review?(bienvenu)

Comment 5

10 years ago
Comment on attachment 286799 [details] [diff] [review]
Manual migration implementation

looks good, thx!
Attachment #286799 - Flags: review?(bienvenu) → review+

Comment 6

10 years ago
Comment on attachment 286799 [details] [diff] [review]
Manual migration implementation

looks good!
Attachment #286799 - Flags: superreview?(mscott) → superreview+
(Assignee)

Updated

10 years ago
Keywords: checkin-needed
Checking in mail/base/content/mailCore.js;
/cvsroot/mozilla/mail/base/content/mailCore.js,v  <--  mailCore.js
new revision: 1.36; previous revision: 1.35
done
Checking in mail/locales/en-US/chrome/messenger/importDialog.dtd;
/cvsroot/mozilla/mail/locales/en-US/chrome/messenger/importDialog.dtd,v  <--  importDialog.dtd
new revision: 1.7; previous revision: 1.6
done
Checking in mailnews/import/resources/content/importDialog.js;
/cvsroot/mozilla/mailnews/import/resources/content/importDialog.js,v  <--  importDialog.js
new revision: 1.44; previous revision: 1.43
done
Checking in mailnews/import/resources/content/importDialog.xul;
/cvsroot/mozilla/mailnews/import/resources/content/importDialog.xul,v  <--  importDialog.xul
new revision: 1.28; previous revision: 1.27
done
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b4pre) Gecko/2008022502 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

This is missing the SeaMonkey part (DTD file, and maybe JS file too):
{{
Error: undefined entity
Source File: chrome://messenger/content/importDialog.xul
Line: 72, Column: 9
Source Code:
        <radio value="all" id="allRadio" label="&importDialog.allTitle;"/>
}}

I suggest to move this bug to "Core / MailNews: Import".
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: --- → Thunderbird 3

Comment 9

10 years ago
Serge: please file a followup bug instead, mark it regression and blocking this one, cc the assignee of this bug.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
Depends on: 421405
(In reply to comment #4)
> Created an attachment (id=286799) [details]
> Manual migration implementation
> This patch adds some UI to the Tools->Import dialog to allow the user to start
> a full profile migration.

Did anyone check the effect of what happens if you import into an existing profile in this manner? i.e. I have an SM and a TB profile, I decide to move my SM items into TB using the "all" option - is my existing TB profile safe?

I believe it should be, but I'd feel happier knowing someone has checked this as I don't know the TB migration code as well as the SM code.
(In reply to comment #9)
> Serge: please file a followup bug instead, mark it regression and blocking this
> one, cc the assignee of this bug.

Bug 421405 was filed.
(Assignee)

Updated

9 years ago
Duplicate of this bug: 255065
Depends on: 425952
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9pre) Gecko/2008032900 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

This patch broke SeaMonkey (shared) JS too:
I filed bug 425952.
You need to log in before you can comment on or make changes to this bug.