Assertion Failed (assert:null node) when middle-clicking on blank space in Bookmarks Toolbar

VERIFIED FIXED in Firefox 3 beta3

Status

()

Firefox
Bookmarks & History
P3
normal
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: pal-moz, Assigned: mano)

Tracking

({regression})

Trunk
Firefox 3 beta3
regression
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

10 years ago
Created attachment 286291 [details]
screenshot

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007102605 Minefield/3.0a9pre ID:2007102605

see attachment.

maybe regression between 20071024-20071025 nightly.(caused by Bug 399729 ?)
(Reporter)

Comment 1

10 years ago
correct range,
happens after 20071024_1906_firefox-3.0a9pre.en-US.win32.zip
so check-in for Bug 399729 cause this.
(Reporter)

Updated

10 years ago
Blocks: 399729

Updated

10 years ago
Flags: blocking-firefox3?

Updated

10 years ago
Assignee: nobody → mano
Flags: blocking-firefox3? → blocking-firefox3+
Keywords: regression

Updated

10 years ago
Target Milestone: --- → Firefox 3 M11
Priority: -- → P2

Updated

10 years ago
Priority: P2 → P3
Duplicate of this bug: 404022

Updated

10 years ago
OS: Windows XP → All
Hardware: PC → All
Duplicate of this bug: 407479
Duplicate of this bug: 408056
Comment on attachment 293181 [details] [diff] [review]
patch

r=sspitzer, but please fix that typo before checking in:

+ this._selection = this._selection = this.getResult().root;

should be:

+ this._selection = this.getResult().root;
Attachment #293181 - Flags: review?(sspitzer) → review+
mozilla/browser/components/places/content/toolbar.xml 1.112
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 9

10 years ago
verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre)
Gecko/2007121805 Minefield/3.0b3pre
Status: RESOLVED → VERIFIED

Updated

10 years ago
Duplicate of this bug: 409130

Comment 11

10 years ago
Actual contents of error box:

ASSERT: null mode
Stack Trace:
0:PU_nodeIsFolder(null)
1:BT_onClick([object MouseEvent])
2:onclick([object MouseEvent])

Comment 12

10 years ago
restoring CC list...

Updated

10 years ago
Duplicate of this bug: 413724
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.