Bug 405903 (iWeb)

iWeb 2.x/iWeb 08 sites with photos or slideshows do not work in Gecko browsers

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
--
major
RESOLVED FIXED
11 years ago
3 years ago

People

(Reporter: Ryan Thorvilson, Unassigned)

Tracking

Details

(Whiteboard: [see comment 13] rdar://5753107, URL)

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.10) Gecko/20071115 Firefox/2.0.0.10
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.10) Gecko/20071115 Firefox/2.0.0.10

In photo pages created by iweb, the thumbnails will show up but full pictures and slideshows will not work.  They worked just fine in 2.0.0.9 but not in 2.0.0.10.  I checked this site in Internet Explorer and they worked fine.

Reproducible: Always

Steps to Reproduce:
1. Go to any photo album in iweb.
2. Try to view a picture or slideshow
3.
Actual Results:  
Pictures don't show up.

Expected Results:  
Pictures should show up.

Comment 1

11 years ago
Slideshow feature does not work either. Website works in IE and in Safari; and in IE in Windows XP

Comment 2

11 years ago
Same thing is happening to me.  Here are links to Apple.com's official discussion board that explains the issue in more detail, and gives some example sites:

http://discussions.apple.com/thread.jspa?messageID=5982853&#5982853

http://discussions.apple.com/thread.jspa?messageID=5972934&#5972934

This issue started after I upgraded from 2.0.0.9 to 2.0.0.10.  It appears to be some kind of conflict between Firefox and JavaScripting.  Hopefully these links will help.

Duplicate of this bug: 406059

Comment 4

11 years ago
The full error I get on my site:
Error: uncaught exception: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDOMCanvasRenderingContext2D.drawImage]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: http://www.bermione.be/sint-in-turnhout/Scripts/iWebMediaGrid.js :: anonymous :: line 373"  data: no]

The site is http://www.bermione.be/sint-in-turnhout

Comment 5

11 years ago
ditto....maybe i should i put a warning at my home page to view in another browser?

Error: uncaught exception: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDOMCanvasRenderingContext2D.drawImage]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: http://alexispike.com/Scripts/iWebMediaGrid.js :: anonymous :: line 373"  data: no]

Comment 6

11 years ago
I've put this warning on my site - with pain in my heart because I promote Firefox where possible ;-) - but then I looked to the download page of Mozilla and saw there was a v2.0.0.11 online. I downloaded it (Mac version - didn't wait for the automatic update) and tried again: now everything seems ok: the pictures appear again.
v 2.0.0.11 seems to solve the problem (and thus I quickly removed the warning again :-) )

Comment 7

11 years ago
Confirming the issues based on multiple reports and own observation and bumping severity up to Major (major loss of function). 

Added Regression keyword and rewrote title to specify that both pictures and slideshows disappear. But only for items created with iWeb 2.x (from my experience pages created with 1.x appear OK)

Status so far from what I gather is that it works with 2.0.0.9 and 2.0.0.11 but NOT with 2.0.0.10

Also broken on Trunk :  Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008021804 Minefield/3.0b4pre

As this is a regression I would recommend that this blocks the next beta?
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Summary: Does not load iweb pictures → Does not load pictures or slideshows created with iWeb 2.x

Comment 8

11 years ago
Requesting blocking for Firefox 3 to get this on the radar. There are a considerable number of iWeb pages that are broken because of this regression.
Flags: blocking-firefox3?

Updated

11 years ago
Duplicate of this bug: 401653
I get a bunch of JS errors trying to load example pages on trunk, the 2.0.0.10 issue was different and caused by breaking part of <canvas> elements.

there's a bunch of fail related to getElementsByClassName, but we have a native impl now... maybe tech evang to handle that sanely now that its supported and fast?

Comment 11

11 years ago
(In reply to comment #10)
> there's a bunch of fail related to getElementsByClassName, but we have a native
> impl now... maybe tech evang to handle that sanely now that its supported and
> fast?


Good question, and to be honest i don't have an answer. I'm just thinking that users will be surprised when upgrading from Firefox 2 to 3 that it will break all sites made with iWeb 2.x?
So, the canvas error was fixed, but there's a trunk-only error which looks like:

Error: widgetDiv.getElementsByClassName("paginated_only").invoke is not a function
Source File: http://web.mac.com/thorvilson/Ryan_and_Danielles_Website/Scripts/Widgets/HeaderControls/HeaderControls.js
Line: 100

I'm guessing the deal is that our getElementsByClassName doesn't know from ".invoke"

--> Core::DOM
Component: General → DOM
Flags: blocking-firefox3?
Product: Firefox → Core
QA Contact: general → general
Whiteboard: [see comment 12 for error message]
Flags: blocking1.9?

Updated

11 years ago
Flags: tracking1.9? → blocking1.9?
The url in comment 12 seems password protected so I can't actually check to make sure, but my money is on that their getElementsByClassName behaved differently than ours did. We always return a NodeList which doesn't have an .invoke property.

Either their implementation returned the element directly if there was only one match, or they've added .invoke to the array prototype.

Over to evangelism, they are simply breaking because our getElementsByClassName override theirs.
Assignee: nobody → english-us
Component: DOM → English US
Flags: blocking1.9?
Product: Core → Tech Evangelism
QA Contact: general → english-us

Updated

11 years ago
Blocks: 357450
Duplicate of this bug: 421956

Comment 15

11 years ago
I can confirm this bug also for Firefox 3.0 beta 4 on Mac _and_ Windows systems. I also checked with Firefox 2.0.0.12 on windows, and with that version it works fine. Seems as if this gets broken and fixed from one Firefox version to another.
I created a small site with iWeb 2.0 and uploaded it onto my domain, so you can check this.

Comment 16

11 years ago
Er, when I say I have an url, I should post it ;-)

http://www.muenchnetz.de/modesty/Modesty/Willkommen.html

Comment 17

10 years ago
FF Beta5 has the same problem it also can not show the pictures 
Interestingly enough if I do a show source the code seems to be there?
works fine in IE7 and FF2 on Windows
and on Safari and Camino on OSX

Comment 18

10 years ago
Here is a Page that was put together using iWeb 2.0.3 
http://www.catcher.za.org/Pictures/Pages/4x4_Pictures.html
If you use anything other main stream browser it loads fine

Updated

10 years ago
Duplicate of this bug: 422084

Comment 20

10 years ago
Considering this is a Tech Evang issue, i have reported the bug in Apple's bug tracking system as well --> bug 5928040

Comment 21

10 years ago
This bug is still present in FF3 RC1.  

Comment 22

10 years ago
(In reply to comment #21)
> This bug is still present in FF3 RC1.  

See comment 13 : this is a Technology Evangelism bug, meaning that the problem is caused by Apple's iWeb rather than by Firefox. A fix for this problem will therefore have to come in an update of iWeb, rather than in future versions of Firefox. I hope this explains for you why you're still seeing the problem in RC1. 

Whiteboard: [see comment 12 for error message] → [see comment 13] Website needs to be updated

Comment 23

10 years ago
:-(  

Nooooo....
It's a shame to simply pass the buck on this...  Especially since FF2.X and earlier work just fine.  

Knowing Apple, they'll drag their feet on it until the official FF3 release, and the millions of Mac users start complaining in droves (in which case, get ready for a LOT more duplicate bug report filings here). 

(So until Apple does something, everyone using iWeb will need to re-direct FF3 users elsewhere, or post a "Not Compatible with FF3" notice on their sites? -- which is what I'm sadly doing right now.)

Comment 24

10 years ago
I am having the same problem with FF3.  Since it is difficult enough to get even a simple web site to work across three or four different browsers, the last thing we need is updates breaking web sites that worked in the past.  The cost to those of us trying to make a living off the web rapidly gets out of hand.  

I though Mozilla was trying to be part of the solution to this problem.  Turning "Technology Evangelism bugs" into political footballs is just escalating the problem.  Firefox will rapidly disappear if you pursue this course.

Maybe I am overreacting, but I find it hard to understand why this problem was fixed when in showed up in 2.0.0.10 only to be reintroduced in 3.  Seems like a programming management problem to me!  Also if my site passes the WC3 validation test, in a perfect world do I not have a right to expect it will work correctly with all web browsers?

Here are a couple of, I hope, constructive suggestions:  When problems of this kind show up, why not get on the phone and talk to the appropriate people at Apple, Microsoft, etc. and work out a solution that gets the problem solved as quickly as possible?  What about forming an independent committee to review and determine what should be called "Technology Evangelism bugs".  The idea would be to reduce the buck passing.  In the interest of speed one would like to think the industry is small enough that one on one contact could get the job done, but maybe I'm just naive!  Thanks for listening and lets get this problem fixed!!   

Comment 25

10 years ago
Just an update: i got a response from Apple. This bug is also known as their bug ID# 5753107, which is currently investigated by Apple Engineering.
> I am having the same problem with FF3.  Since it is difficult enough to get
> even a simple web site to work across three or four different browsers, the
> last thing we need is updates breaking web sites that worked in the past.  The
> cost to those of us trying to make a living off the web rapidly gets out of
> hand.  
> 
> I though Mozilla was trying to be part of the solution to this problem. 
> Turning "Technology Evangelism bugs" into political footballs is just
> escalating the problem.  Firefox will rapidly disappear if you pursue this
> course.

Please note: The *only* way to avoid problems like this is to simply stop adding features to the DOM. No browser that I know of is considering this path.

Updated

10 years ago
Duplicate of this bug: 433833

Updated

10 years ago
Depends on: 433833

Updated

10 years ago
Keywords: regression
OS: Mac OS X → All
Hardware: Macintosh → All
Summary: Does not load pictures or slideshows created with iWeb 2.x → iWeb 2.x/iWeb 08 sites with photos or slideshows do not work in Gecko browsers
Whiteboard: [see comment 13] Website needs to be updated → [see comment 13]
Duplicate of this bug: 437312

Comment 29

10 years ago
(In reply to comment #28)
> *** Bug 437312 has been marked as a duplicate of this bug. ***


Copying bug 437312 comment 0 into this bug, as it gives a good technical description of the issue:

"iWeb 2.0.3 uses Prototype 1.5 which has a slightly different implementation of
getElementsByClassName() than version 1.6.

iWeb sites use various constructs like:
       widgetDiv.getElementsByClassName("paginated_only").invoke

Firefox RC 1 has a native implementation of getElementsByClassName() and
prevents Prototype 1.5 from overriding it thus causing the above error.

Safari 3.1 also has a native implementation of getElementsByClassName() but
does allow Prototype 1.5 to override the method and therefore iWeb sites render
correctly in Safari."

Comment 30

10 years ago
Is that what bug 390411 is about?  (Would fixing it make these sites work again?)
Last I checked, Prototype 1.5 not only has a different impl of getElementsByClassName, but doesn't try to override if one already exists.  Which means that fixing bug 390411 wouldn't help Prototype 1.5, unless we also lied about whether getElementsByClassName exists.

I'm pretty sure this is all covered in the existing bug reports about Prototype 1.5 (as well as the existing iWeb bug reports; I'm pretty sure I saw one older than this bug).

ccing jresig in case I'm on crack.

Comment 32

10 years ago
I can also confirm this bug for Firefox 3.0rc2 (Linux). To be specific, this site works fine in Firefox 2.0.0.13:

http://tonysmith.us/main/Photos.html

However, in FX3.0rc2, the photos never show up, and the message in the "error console" is as described earlier:

widgetDiv.getElementsByClassName("pagninated_only").invoke is not a function
http://tonysmith.us/main/Scripts/Widgets/HeaderControls/HeaderControls.js Line 100

The recommendation of the Prototype developers is captured here, along with some other explanation:

http://ejohn.org/blog/getelementsbyclassname-pre-prototype-16/

Comment 34

10 years ago
a coworker complained about http://www.kolumbus.fi/jtp/badasses/gig32/gig32.html
(just leaving it here so that he can find it later)

Updated

10 years ago
Alias: iWeb

Comment 35

10 years ago
Created attachment 325187 [details]
Fixed version of Scripts/Widgets/DetailView/DetailView.js generated by iWeb08

Comment 36

10 years ago
Created attachment 325188 [details]
Fixed version of Scripts/Widgets/HeaderControls/HeaderControls.js generated by iWeb08

Comment 37

10 years ago
Since there is still no update for iWeb08 out and I just stumbled over this bug I uploaded two fixed .js files that can be copied in the folders that iWeb08 generates when exporting a website and will make your gallery work again.

My naive fix wraps the lists returned by getElementsByClassName in a Prototype Array to make functions like invoke, each, etc available at these places in the code again.

widgetDiv.getElementsByClassName("paginated_only").invoke
->
$A(widgetDiv.getElementsByClassName("paginated_only")).invoke


If you guys at Apple read this: I'll be looking for a job soon, give me a call ;)

Comment 38

10 years ago
Created attachment 325192 [details]
Fixed version of Scripts/Widgets/DetailView/DetailView.js generated by iWeb08

another small fix
Attachment #325187 - Attachment is obsolete: true

Updated

10 years ago
Duplicate of this bug: 439011

Comment 40

10 years ago
Bug 425752 appears to be a duplicate of this.

Updated

10 years ago
Duplicate of this bug: 425752

Comment 42

10 years ago
I'm seeing the same thing....Any pages created with iWeb that use the Photo template page don't work. Other pictures show up fine. Slideshow also doesn't work. I hope they fix this one soon.

Comment 43

10 years ago
I'm seeing the same thing....Any pages created with iWeb that use the Photo template page don't work. Other pictures show up fine. Slideshow also doesn't work. I hope they fix this one soon.
Duplicate of this bug: 439813

Comment 45

10 years ago
(In reply to comment #32)
> I can also confirm this bug for Firefox 3.0rc2 (Linux). To be specific, this
> site works fine in Firefox 2.0.0.13:
> 
> http://tonysmith.us/main/Photos.html
> 
> However, in FX3.0rc2, the photos never show up, and the message in the "error
> console" is as described earlier:
> 
> widgetDiv.getElementsByClassName("pagninated_only").invoke is not a function
> http://tonysmith.us/main/Scripts/Widgets/HeaderControls/HeaderControls.js Line
> 100
> 

Confirmed.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008061505 Minefield/3.0pre
Duplicate of this bug: 440271

Comment 47

10 years ago
Another confirmation. My iWeb  photo gallery thumbnails (created under iWeb 2) do not appear when viewed with Firefox 3.0.  No problem with Firefox 2 nor with Safari.  Will have to post instructions to my viewers to avoid FF3!  

Comment 48

10 years ago
comment 42 - comment 47: please we do not need more confirmations. This is a known problem, already confirmed by both Mozilla and Apple engineers.

Until Apple updates its iWeb applications, user can apply the fix provided in comment 36 and comment 37.

Thank you :)

Comment 49

10 years ago
I have tried the fixes but it seems to break the site for all the browsers now, so I have reverted back.

Comment 50

10 years ago
The patches work, as you can see on my site 
http://www.muenchnetz.de/modesty/Modesty/Willkommen.html

I think you have done something wrong. Though, the reflection effect still does not work.

Comment 51

10 years ago
Created attachment 326432 [details]
Fixed version of Scripts/Widgets/Comments/Comments.js generated by iWeb08

Patched version of Comments.js, provided by Daryl Grunau.
Whiteboard: [see comment 13] → [see comment 13] rdar://5753107
Duplicate of this bug: 442424

Updated

10 years ago
Duplicate of this bug: 443779

Comment 54

10 years ago
I am also experiencing the same issues with Firefox 3.  This is the first version of firefox that did not display the photos and slideshow correctly for me.  Mozilla, please fix- many thanks.

Currently using Opera USB to view the iWeb sites until firefox is updated.

Thanks!

Comment 55

10 years ago
Created attachment 328292 [details] [diff] [review]
The fix was posted earlier to me.  This will patch firefox/ web problems

This patch was posted earlier by html address to me, but I cannot find this address any more.  But I did download the patch, and as mike.carroll@mac.com
asked for it again, here it is
Duplicate of this bug: 445223

Comment 57

10 years ago
I'm confused after reading comment 29 and comment 31.  Are these sites also broken in Safari?  If not, what is Safari doing differently, and can we copy them?
Jesse: see bug 437312
Duplicate of this bug: 446188

Comment 60

10 years ago
That doesn't answer my question -- it doesn't explain exactly what's different about Safari that lets this site's code override its implementation, and it isn't explicitly WONTFIXed or planned to be fixed.

Comment 62

10 years ago
Looks like it.  Thanks!
Depends on: 390411

Comment 63

10 years ago
Or maybe not, since that's the same bug that comment 31 points to.

Comment 64

10 years ago
I recently applied iWeb Update 2.0.4 (from Apple) and republished each page of my iWeb site. Photos now show up correctly in Firefox 3.0.1 (both Mac and Windows versions).

Note you have to make a minor change to each page, and then republish, for the fix to work.

Comment 65

10 years ago
What 'minor' changes?

Comment 66

10 years ago
I can confirm this seems to have solved my problem as well (iWeb update 2.0.4). You just have to do something like add a space on to a word somewhere on the page so it's been changed. Although I didn't try publishing without touching each photo page.

Comment 67

10 years ago
Ok, so you're talking about just a 'token' change - perhaps one I can go back and change back later.
??

Comment 68

10 years ago
Ummm....... when I try to update it tells me my version 2.0.3 is the current version.  Guess I'll try again later and see if I can update somehow.  thanks everyone!

Comment 70

10 years ago
Well, I have images, I have reflections where I created them, I have lines/strokes, but no drop shadows.  So it's still not displaying like I created it.

Comment 71

10 years ago
Confirming that the iWeb 2.0.4 update fixes the problem.

For those that do NOT host their site on .Mac/MobileMe : if you do "Publish to a folder" in iWeb, and then upload it to your server your site will be Firefox 3 compatible again.

Note: there still appear to be some minor issues (for example the text "XX photos" under each album is slightly clipped)

For those hosting their site on .Mac/MobileMe, maybe here the token change on each picture page is relevant as mentioned in comment 64?

I'm a bit unsure if we can close this particular Tech Evang bug. The underlying issue is fixed by the iWeb 2.0.4 update, but still each site created with pre iWeb 2.0.x versions need to be updated...

Considering that the site mentioned in the URL field of this bug already appears to be working again, i'm resolving this bug as FIXED.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 72

10 years ago
It is NOT necessary to set all pages dirty, there is a "Publish all to MobileMe" in iWeb (have german version, so do not know the exact english wording) which worked for me.

Comment 73

10 years ago
(In reply to comment #70)
> Well, I have images, I have reflections where I created them, I have
> lines/strokes, but no drop shadows.  So it's still not displaying like I
> created it.

That sounds like a totally different issue. This bug is about the photos not showing up *at all*.

Comment 74

10 years ago
Guess you didn't read carefully.  I do have images now, but they are not presenting totally as I created them to be.   Thought this thread was resolved?  

???

Comment 75

10 years ago
(In reply to comment #74)
> Guess you didn't read carefully.

Apparently *you* didn't read carefully.

>  I do have images now

What part of "this bug is about the photos not showing up at all" are you not understanding from my previous comment?

If you are seeing images, you are not experiencing THIS bug. You may be experiencing another bug, but this is certainly not the place to discuss it.
Duplicate of this bug: 448006
Duplicate of this bug: 448720
Duplicate of this bug: 512030

Updated

9 years ago
Duplicate of this bug: 535415
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.