Closed Bug 406708 Opened 12 years ago Closed 12 years ago

Use Vista style tree widget images in places interfaces

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows Vista
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 3

People

(Reporter: faaborg, Unassigned)

References

Details

(Keywords: polish)

Attachments

(3 files)

The Library window, bookmarks sidebar, and history sidebar should be using the same style of tree views found in Windows Photo Gallery and Windows Media Player.  I'll follow up with a screenshot.  These are the effected files:

http://mxr.mozilla.org/seamonkey/source/toolkit/themes/winstripe/global/tree/twisty-clsd.png
http://mxr.mozilla.org/seamonkey/source/toolkit/themes/winstripe/global/tree/twisty-open.png
http://mxr.mozilla.org/seamonkey/source/toolkit/themes/winstripe/global/tree.css#330
It would also be great if we could match the look of selected items
Attached image Vista twisty (closed)
This is the Vista twisty image (closed state), created from scratch, matches 90% the same as Vista's.
Attached image Vista twisty (open)
This is the Vista twisty image (open state), also created from scratch, matches 90% the same as Vista's.
The code to fix this, tested using userChrome.css on Firefox 3 beta 1:

treechildren::-moz-tree-twisty {
	padding-right: 4px;
	padding-top: 1px;
	width: 6px !important;
	list-style-image: url(twisty-clsd-vista.png) !important;
}

treechildren::-moz-tree-twisty(open) {
	width: 6px !important;
	list-style-image: url(twisty-open-vista.png) !important;
}

treechildren::-moz-tree-line,
treechildren::-moz-tree-line(selected, focus) {
	border: 0 !important;
}
This should be in the vista icon set, I assume it is just a simple case of replacing the icons?
Here is how it looks in vista.
Duplicate of this bug: 403149
Blocks: 425582
FIXED by icon landing in bug 430759
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3
*** VERIFIED as fixed! I see these new icons!

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008050606 Minefield/3.0pre

-Mike Lierman
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.