Closed Bug 407399 Opened 14 years ago Closed 13 years ago

Disable prebinding for trunk builds

Categories

(Firefox Build System :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9.1b2

People

(Reporter: mark, Assigned: philor)

References

()

Details

Attachments

(5 files)

The default mozconfigs still specify this for trunk builds:

ac_add_app_options ppc --enable-prebinding

These lines should be removed now that the minimum supported OS version is 10.4 on all architectures.  Prebinding is not a performance improvement on 10.4.
As I discovered tonight, the plague of useless prebinding has spread far-and-wide across the Mozilla world as Firefox has replicated its mozconfig for buildbot, the try-server, etc.
Depends on: 429942
Duplicate of this bug: 458647
I should have known that just treating the infection in Thunderbird, without giving Typhoid Firefox a course of antibiotics too, wouldn't last.
I'm going to need some handholding, since I don't have a clue how the buildbot configs actually work and get pulled and whatnot, but counting on someone else to get rid of prebinding apparently isn't going to work out.
Assignee: nobody → philringnalda
Status: NEW → ASSIGNED
Attachment #341865 - Flags: review?(nthomas)
Adding Apple doc to URL as confirmation.
Comment on attachment 341865 [details] [diff] [review]
[checked in] Fix buildbot-configs, v.1

r+ for the mozilla2/ and mozilla2-staging/ changes, which will be picked up the first build after you push the changes to the repo. Try server config is at mozilla/tools/buildbot-configs/tryserver/mozconfig-mac in cvs; it'll need a helping hand from us to deploy.

Setting r? for Seamonkey and Thunderbird.
Attachment #341865 - Flags: ui-review?(gozer)
Attachment #341865 - Flags: superreview?(kairo)
Attachment #341865 - Flags: review?(nthomas)
Attachment #341865 - Flags: review+
Attachment #341865 - Flags: ui-review?(gozer)
Attachment #341865 - Flags: superreview?(kairo)
Attachment #341865 - Flags: review?(kairo)
Attachment #341865 - Flags: review?(gozer)
Make the bad things go away!
Attachment #341875 - Flags: review?(ted.mielczarek)
And the clone of the bad thing, too.
Attachment #341876 - Flags: review?(kairo)
Attachment #341875 - Attachment is patch: true
Attachment #341875 - Attachment mime type: application/octet-stream → text/plain
Comment on attachment 341865 [details] [diff] [review]
[checked in] Fix buildbot-configs, v.1

Works for me.
Plus, the closer our mozconfigs get between different architectures, the better.
Attachment #341865 - Flags: review?(gozer) → review+
The last one, I hope.
Attachment #341878 - Flags: review?(bhearsum)
Comment on attachment 341875 [details] [diff] [review]
Remove --enable-prebinding in mozilla-central

yes plz.
Attachment #341875 - Flags: review?(ted.mielczarek) → review+
Attachment #341878 - Flags: review?(bhearsum) → review+
Attachment #341878 - Attachment description: Fix tryserver config → [checked in] Fix tryserver config
Comment on attachment 341878 [details] [diff] [review]
[checked in] Fix tryserver config

Checking in mozconfig-mac;
/cvsroot/mozilla/tools/buildbot-configs/tryserver/mozconfig-mac,v  <--  mozconfig-mac
new revision: 1.3; previous revision: 1.2
done
Attachment #341865 - Flags: review?(kairo) → review+
Comment on attachment 341865 [details] [diff] [review]
[checked in] Fix buildbot-configs, v.1

OK, from all I hear this is only on the basis of prebinding being "potentially unhelpful and probably not helpful nowadays" - but there's one argument for the change I can see: it cleans up some buildsystem stuff ;-)
Comment on attachment 341876 [details] [diff] [review]
Remove --enable-prebinding in comm-central

cleaning up the buildsystem is usually stuff I like :)
Attachment #341876 - Flags: review?(kairo) → review+
Pushed the Thunderbird and SeaMonkey mozconfigs in http://hg.mozilla.org/build/buildbot-configs/rev/8a20c6eae8e6 - I'm holding off on the Firefox ones and the dropping support until mozilla-central reopens, despite Ted's attempts to lead me astray ;)
It's like an STD, only not as much fun to get.
Attachment #342396 - Flags: review?(ctalbert)
Comment on attachment 342396 [details] [diff] [review]
[checked in] A dose of penicillin for Sunbird

Looks good to me.  r=ctalbert

Thanks for the flu shot philor
Attachment #342396 - Flags: review?(ctalbert) → review+
Comment on attachment 342396 [details] [diff] [review]
[checked in] A dose of penicillin for Sunbird

http://hg.mozilla.org/build/buildbot-configs/rev/cb1e9eb7d250

Now if I could just get a green tree and sea room with mozilla-central...
Attachment #342396 - Attachment description: A dose of penicillin for Sunbird → [checked in] A dose of penicillin for Sunbird
Comment on attachment 341865 [details] [diff] [review]
[checked in] Fix buildbot-configs, v.1

Pushed the mozilla-central mozconfigs in http://hg.mozilla.org/build/buildbot-configs/rev/91476b111b72
Attachment #341865 - Attachment description: Fix buildbot-configs, v.1 → [checked in] Fix buildbot-configs, v.1
http://hg.mozilla.org/mozilla-central/rev/15996a62596e and http://hg.mozilla.org/comm-central/rev/5d4a98ac7867 and we're done.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.1b2
Version: unspecified → Trunk
I don't see anything else in build config that could have caused bug 459569 'cept this. But, I've been wrong before.
Not guilty, Your Honor.
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.