Open Bug 41250 Opened 21 years ago Updated 10 years ago

automatically download appropriate fonts when a page contains characters that cannot be displayed

Categories

(Core :: Layout: Text and Fonts, defect, P3)

defect

Tracking

()

REOPENED
Future

People

(Reporter: shrir, Unassigned)

References

Details

This bug has been seperated from bug 6585.

Comments from bug 6585 :

>From rbs@maths.uq.edu.au 2000-03-02 18:13 -------

 RFE: going back to the initial questions raised in this bug report, an 
interesting option could be to pool/sort all the missing chars, in view of
possibly sending a one-off feedback to the user (bug 6211, with a listing of
names?), or in view of determining the fonts that can be auto-downloaded (or
suggested for download). Note that it would be hard to implement a 
tooltip --compared to improving the viewsource trick to show their unicode 
in an ERROR-type color, but even achieving this is not straightforward.
Status: NEW → ASSIGNED
Target Milestone: --- → Future
*** Bug 31249 has been marked as a duplicate of this bug. ***
Any update? Some check-ins by ftang seem to suggest that some work related to 
this is going on?
Yes, Frank has started working on the auto font download feature. I'm adding
Frank to the Cc list.
Does this bug deal with the pfr format (Portable Font Resources)?

see info about it at:
http://www.truedoc.com/
http://www.bitstream.com/

This is a feature in Netscape 4.03 and above.  Also, bitstream created an 
ActiveX component to allow IE to work with pfr's.

Seems like Mozilla/Netscape6 should support this.  If it won't, what is the 
reason?  Is Mozilla thinking about creating its own way of downloading fonts?

Jake
erik resign. reassign all his bug to ftang for now.
Assignee: erik → ftang
Status: ASSIGNED → NEW
mark all future new as assigned after move from erik to ftang
Status: NEW → ASSIGNED
Blocks: 70132
is this bug 92596?
(See also bug # 59611/52746)
I have called BitStream to go open source with the TrueDoc PFR technology
for the benefit of the Mozilla project, and they indicated they're ready
to do so. Please see my article on this topic at

http://www.tarunz.org/~vassilii/BitStream.html
We seem to be auto-downloading fonts now, as various bugs and complaints about
the dialogs show (see bug 86525 which asks for a way to turn this off!). Should
this bug be closed?
This bug is about custom fonts.  Bug 86525 is more about language packs than 
fonts as I understand it.  I don't think the two bugs are related much at all.

Jake
*** Bug 167480 has been marked as a duplicate of this bug. ***
==> Layout/fonts
Component: Layout → Layout: Fonts and Text
DUP of bug 70132?
*** Bug 248221 has been marked as a duplicate of this bug. ***
*** Bug 257984 has been marked as a duplicate of this bug. ***
what a hack. I have not touch mozilla code for 2 years. I didn't read these bugs
for 2 years. And they are still there. Just close them as won't fix to clean up.
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → WONTFIX
Mass Reassign Please excuse the spam
Assignee: ftang → nobody
Mass Re-opening Bugs Frank Tang Closed on Wensday March 02 for no reason, all
the spam is his fault feel free to tar and feather him
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Reassigning Franks old bugs to Jungshik Shin for triage - Sorry for spam
Assignee: nobody → jshin1987
Status: REOPENED → NEW
I'm not a software developer, but I'd love to hire someone to patch this bug.
Assignee: jshin1987 → nobody
OS: Windows NT → All
QA Contact: chrispetersen → layout.fonts-and-text
Hardware: x86 → All
With @font-face now implemented, it is possible for pages to provide fonts to cover missing character issues.
Status: NEW → RESOLVED
Closed: 16 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 70132
I think this bug was actually somewhat different; I'm changing the summary to reflect what I think it was for, and un-marking as duplicate.  (I'm not sure whether it's something I think we should do, though.  It might be, if there are appropriate free fonts we could download and effectively make an optional part of the Firefox install.)
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: Auto download of fonts → automatically download appropriate fonts when a page contains characters that cannot be displayed
You need to log in before you can comment on or make changes to this bug.