insert/format menus should work in HTML Source mode

NEW
Unassigned

Status

SeaMonkey
Composer
--
enhancement
18 years ago
8 years ago

People

(Reporter: timeless, Unassigned)

Tracking

({helpwanted})

Trunk
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Gecko/20000601
Open some page in composer
select edit mode: HTML Source
Click Format
Click any menu item that is enabled
It won't do anything [some seem to set selectionlength to 0]
This seems to apply to all
Some of these things should work even in html source mode
esp: Font, Size, Text Style, Color, Heading, Paragraph, List and Align.

The rest should not be enabled if they won't be supported.

Comment 1

18 years ago
All of these menu items aren't going to work in HTML Source mode.
They should be removed or disabled, which is bug 

*** This bug has been marked as a duplicate of 38875 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

18 years ago
The menu items mentioned should be made to work.  See how Amaya and other 
composers do things.  It's a great tool for newbies to be able to pick 
something and see how it becomes html [w/o changing modes].  If you feel that 
this shouldn't make the main release select future.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 3

18 years ago
They cannot be made to work with current design, which is a simple textarea.
Of course we'd like them work, but we have to make compromises to ship.
If Simon manages to fix webshell so we can support multiple editors, then
we have a chance, but I don't know if that is a priority for this release.
I'll keep this as a feature request.
Status: REOPENED → ASSIGNED
Target Milestone: --- → M22

Comment 4

18 years ago
Forgot to add [RFE] to summary.
Summary: options in format menu show enabled but don't work → [RFE] options in format menu show enabled but don't work

Comment 5

18 years ago
Changing summary to better describe the request.
Summary: [RFE] options in format menu show enabled but don't work → [RFE] options in format menu should work in HTML Source mode

Updated

18 years ago
Target Milestone: M22 → Future

Comment 6

17 years ago
*** Bug 88813 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
spam composer change
Component: Editor: Core → Editor: Composer

Comment 8

16 years ago
*** Bug 91267 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Summary: [RFE] options in format menu should work in HTML Source mode → insert/format menus should work in HTML Source mode

Updated

16 years ago
OS: Windows 2000 → All
Hardware: PC → All

Updated

15 years ago
Depends on: 69329
Product: Browser → Seamonkey
(Reporter)

Updated

12 years ago
Keywords: helpwanted
Assignee: cmanske → nobody
Status: ASSIGNED → NEW
Priority: P3 → --
QA Contact: sujay → composer
Target Milestone: Future → ---
This bug is being marked EXPIRED as it has seen no activity in a very long time.

If you think that the issue reported might still be relevant, please test with a recent release of SeaMonkey and if the problem persists feel free to re-open the report. Thank you.

http://www.seamonkey-project.org/
Status: NEW → RESOLVED
Last Resolved: 18 years ago9 years ago
Resolution: --- → EXPIRED
Bulk reopening incorrectly expired bugs - no activity does not constitute no bug - these need proper checking.
Status: RESOLVED → REOPENED
Resolution: EXPIRED → ---

Updated

9 years ago
Severity: major → enhancement
Status: REOPENED → NEW
You need to log in before you can comment on or make changes to this bug.