Closed Bug 414700 Opened 17 years ago Closed 16 years ago

Style identity information contextual dialog on Vista

Categories

(Firefox :: Theme, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 3

People

(Reporter: faaborg, Unassigned)

References

Details

(Whiteboard: [fixed by bug 413060])

Attachments

(1 file)

We need to theme the identity information contextual dialog for XP.  Here is a set of potential styles:

http://people.mozilla.com/~faaborg/files/granParadisoUI/contextulDialogStyleVista_i1.png

Of these, we think we are going to go with the "traditional notification" style for Vista.

Note that bug 403155 is tracking the appearance of the bookmarks contextual dialog, which will use the same visual style.
Flags: blocking-firefox3?
The /\ is less important than styling it nicely.
Component: OS Integration → Theme
Flags: wanted-firefox3+
Flags: blocking-firefox3?
Flags: blocking-firefox3-
Here is a spec, this shows the bookmarking interface, but the same style applies to the identity contextual dialog.  Only difference is that it should hang to the right instead of left.
QA Contact: os.integration → theme
Blocks: 425582
Blocks: 405605
made better by that bug, but I think we should try this for Aero:

#identity-popup{
-moz-appearance: tooltip !important;
}
#identity-popup-container{
background-color: transparent !important;
}

Image: https://bugzilla.mozilla.org/attachment.cgi?id=313894

We should keep menupop for classic.
This will be fixed by bug 413060
Whiteboard: [fixed by bug 413060]
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Alex, is it by design that the left padding of the identity dialog is a big wider than the top padding? It is visible especially for the Larry icon.
Target Milestone: --- → Firefox 3
>Alex, is it by design that the left padding of the identity dialog is a big
>wider than the top padding? 

Nope, they should probably be the same.
(In reply to comment #7)
> Nope, they should probably be the same.

This is bug 432529 now.

All the other things looks good. Verified with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008050606 Minefield/3.0pre ID:2008050606
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: