Closed Bug 416420 Opened 12 years ago Closed 2 years ago

In print preview, back and forward buttons are always enabled

Categories

(Core :: Print Preview, defect, minor)

x86
All
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 137084

People

(Reporter: bugzilla.i.sekler, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008020711 Firefox/3.0b4pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008020711 Firefox/3.0b4pre

The back and forward buttons in the print preview are always enabled even if it is impossible to move from the actually displayed page to another one.

Reproducible: Always

Steps to Reproduce:
1. Open the print preview
2. Click on the forward button till the last page is displayed
3. Click on the back button till the first page is displayed

Actual Results:  
The forward buttons (both end-arrow and right-arrow) remain enabled after the step 2, the back buttons (right-arrow and end-arrow) are enabled after the step 1 and remain enabled after the step 3.

Expected Results:  
The forward buttons are disabled after the step 2, the back buttons after the step 3. and the step 1.

This very minor issue exists both on the branch and on the trunk on Linux and on Windows. The gnomestripe theme has made it much more visible, especially on Ubuntu with its default Human theme for GNOME.

Please move the bug to the proper product, Firefox is definitely wrong as far as Thunderbird uses the same print preview.
Component: General → Print Preview
Product: Firefox → Core
QA Contact: general → printing
Version: unspecified → Trunk
See also more or less related bugs, bug 184537 and bug 389360.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 441024
I'm still seeing this on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3 across all platforms. What's being done to fix this issue?
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 137084
You need to log in before you can comment on or make changes to this bug.