[UX] Print preview doesn't dynamically update page number after scrolling or adjusting settings (doesn't reflect page in view)

NEW
Unassigned

Status

()

--
enhancement
16 years ago
9 months ago

People

(Reporter: ian.graham, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

If I scroll, in print preview, through a multi-page document, the page number
displayed at the top of the window should update to indicate the 'page in view'.
Unfortunately it seems to be stuck at '1', and never changes ......

Reproducible: Always

Steps to Reproduce:
1. Go to a long document and select 'print preview'
2. scroll down to some page number > 2
3. Note that the  page number indicator at the top of the window remains '1'.



Expected Results:  
Mozilla should learn to count.

I will add and RFE suggesting that we add a 'print this page' option from the
preview page, or a 'print selected 'pages'  option as with many word processors.
  I'd like that very much!

Updated

16 years ago
Priority: -- → P5
Summary: Print preview doesn't dynamically update page number to reflect page in view. → Print preview doesn't dynamically update page number to reflect page in view.
Target Milestone: --- → Future

Comment 1

16 years ago
Confirmed in build 2003050714 on Windows NT

Updated

15 years ago
Blocks: 137084

Comment 2

14 years ago
Still there in 20040923 Firefox/0.10, Win XP. Updating the page number in this
way is generally how it's done in word processors. IE guards against it, for
whatever reason, by only allowing you to scroll to the bottom of the current
page and requiring you to use the next and previous buttons to get past it.

Comment 3

13 years ago
WFM suite and Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4)
Gecko/20050715 Firefox/1.0+
don't see how bug 137084 is dependent, but leaving it untouched.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

13 years ago
I still see this problem both on Deer Park Alpha 2:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712
Firefox/1.0+
(Reporter)

Comment 5

13 years ago
I also still see the problem in today's build:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050726
Firefox/1.0+
So I am reopening... 
To redescribe: the bug is that, when you scroll down a multi-page document in
print preview mode, the current page number at the top of the preview frame
(originally set to '1') does not update to reflect the 'in view' page.  
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
*** Bug 275795 has been marked as a duplicate of this bug. ***
Assignee: rods → printing
Status: REOPENED → NEW
QA Contact: sujay

Comment 7

13 years ago
*** Bug 255926 has been marked as a duplicate of this bug. ***

Comment 8

13 years ago
*** Bug 205783 has been marked as a duplicate of this bug. ***

Updated

13 years ago
OS: Windows 2000 → All
Priority: P5 → --
Hardware: PC → All
Target Milestone: Future → ---

Comment 9

13 years ago
*** Bug 315397 has been marked as a duplicate of this bug. ***

Comment 10

13 years ago
If you switch from portrait to landscape, the page COUNT does not get updated either.

*** This bug has been marked as a duplicate of 205783 ***
No longer blocks: 137084
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
Re-opening, see bug 205783 comment 29.
Severity: normal → enhancement
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → NEW
Summary: Print preview doesn't dynamically update page number to reflect page in view. → Print preview doesn't dynamically update page number after scrolling or adjusting settings (doesn't reflect page in view)
Assignee: printing → nobody
QA Contact: printing
Duplicate of this bug: 850835

Updated

a year ago
Duplicate of this bug: 1391498

Updated

9 months ago
Summary: Print preview doesn't dynamically update page number after scrolling or adjusting settings (doesn't reflect page in view) → [UX] Print preview doesn't dynamically update page number after scrolling or adjusting settings (doesn't reflect page in view)

Updated

9 months ago
Duplicate of this bug: 389360
You need to log in before you can comment on or make changes to this bug.