Closed Bug 417217 Opened 12 years ago Closed 5 years ago

"Select only this calendar" is missing in calendar context menu

Categories

(Calendar :: Calendar Views, defect, trivial)

defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1073982

People

(Reporter: Hb, Unassigned)

References

(Depends on 1 open bug)

Details

Attachments

(1 file)

Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13pre) Gecko/20080211 Calendar/0.8pre

Sunbird is commonly used to deal with more than one calendar. Currently several clicks and therefore several asynchronous calculation times are needed to show the items of only one calendar. It is easier to set the read only state for a calendar than to show it's content solely.

The english caption of this menu entry is only a sample. "Show only this" or "Deselect others" might also be possible.
Attachment #303024 - Flags: ui-review?(christian.jansen)
Assignee: nobody → hb
Version: Trunk → unspecified
Status: NEW → ASSIGNED
I wonder what you want to do after you select the single calendar.  Do you eventually want to restore the original selection of calendars?  Would there be a second command in the context menu to do that?

In my case, I normally have my primary calendars selected, but sometimes I want to quickly look at someone else's calendar, then switch back to my calendars.

I think it would be nice if I could hold the left mouse button down on someone else's calendar and the view shows just that calendar.  When I release the button then the view returns to my original selection of calendars.  Maybe it's for a different bug, but I just wanted to mention it.
I'd like to see this solved in a different way. It would be good to offer some sorting ui (for example folders, filtering) this would allow users to organize calendars according to their needs.
Attachment #303024 - Flags: ui-review?(christian.jansen) → ui-review-
Assignee: hb → nobody
Severity: enhancement → trivial
Status: ASSIGNED → NEW
Duplicate of this bug: 203028
Maybe this wouldn't be necessary if we could open the calendar in a new tab.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1073982
You need to log in before you can comment on or make changes to this bug.