Closed Bug 420170 Opened 12 years ago Closed 4 months ago

selected XUL tab has an odd block underneath

Categories

(Core :: Widget: Gtk, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mkmelin, Unassigned)

References

Details

(Keywords: regression, Whiteboard: tpi:-)

As can be seen from attachment (id=294362) in bug 265698 there is now an odd bar under the selected tab in the preferences.

(For me it looks similar to that screenshot, on kubuntu.)

In bug 265698 comment 187 it was said "This is because Ubuntulooks doesn't obey the clip rect. This bug has been reported and corrected in Clearlooks ages ago."

I haven't seen this problem elsewhere, so I assume it can be fixed/worked around somehow. Probably quite a lot of people are going to have this, and it's very ugly.
Severity: trivial → normal
This issue is shown when using themes based on Clearlooks-forks like Rezlooks, Ubuntulooks... But forked ages ago (earlier before the bug in CL was fixed).
The problem isn't present with native gtk. Gecko encounters it because we have no means to get the correct rendering without resorting to clipping, given current gtk theme api.

Perhaps there's a mean to do the clipping ourselves, but it probably means rendering on an offscreen thing and copying back, so it would be slow. I'd rather have this bug corrected directly on ubuntulooks...
I'm sure that's the preferred option, but in the meanwhile, it will bite a lot of ubuntu (and others I assue) linux users:(

Don't happen to know if there's even a bug opened for it in the ubuntu bug tracker, or where the most suitable place would be?
I discussed on IRC with roc and he said that there could be a way for us to do the clipping ourselves, without resorting to an ugly slow hack. The problem is that he was too busy to tell me how to do that, and to discuss if that workaround was needed. Perhaps after the week-end he will be less busy, or at worst after the beta4 freeze.

Note that it would still be a workaround and that ubuntulooks need to be fixed. I don't know if there's a bug for it in the ubuntulooks bug tracker (launchpad ?).
Note that if what I just read in bug 420529 is true, ubuntu would switch to Murrine for the next version.
I was wrong, the only way to clip the theme drawing is to use a temporary surface. It would really suck if we had to do that just to work around a broken theme engine.
Duplicate of this bug: 424762
As said in bug 424762, the Aurora engine has the same bug as ubuntulooks.

Rob, could you report this bug to Aurora, please ? (The bug is that the theme engine doesn't obey the clip rect, and draws too much, see comment 0).
Duplicate of this bug: 461602
As far as I can tell, this bug fits under the obsolete bugs category.

Dao, could you please confirm if my assumption is correct and that this bugs can be resolved as Won't fix due to the fact that the page info and preferences got changed? If the above is correct then also Bug 265698 and probably all its dependencies are in the same won't fix zone.
Flags: needinfo?(dao+bmo)
No, Firefox itself may not use native tabs anymore, but other products / add-ons do, so this is still a valid bug. Or maybe not. Gtk3 may have fixed this.
Flags: needinfo?(dao+bmo)
Whiteboard: tpi-
Whiteboard: tpi- → tpi:-

Don't see this anymore.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.