Closed Bug 422040 Opened 15 years ago Closed 15 years ago

Quit Firefox 3 beta 4 does not give "closing multiple tabs" warning.

Categories

(Firefox :: Tabbed Browser, defect)

PowerPC
macOS
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 419009

People

(Reporter: glenemil, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4

Quitting FF3b3 and FF3b4 does not give "closing multiple tabs" warning despite already enabling it in preferences. Only gives warning upon closing browser window (CMD+SHIFT+W). 

Reproducible: Always

Steps to Reproduce:
1.Open multiple tabs
2.CMD+Q to quit firefox
3.
Actual Results:  
Firefox quits without giving any warning of multiple tab closure.

Expected Results:  
Warning should have been given, as per Firefox 2.
Reporter: Please let us know what you have your Preference set to for Startup in Firefox | Preferences | Main | Startup - Is it "Show my Home Page" or "Show my windows and tabs from last time"
Marcia: Preferences is set to "Show My Home Page".
Marcia: Tried changing preferences to "Show my windows and tabs from last time" - does not change the Quit behavior. CMD+Q still gives a quit without giving multiple tabs closing warning, while Close Window SHIFT+CMD+W will still give the warning.
I can confirm this bug on Mac OS X 10.5.1/10.5.2 and Windows XP Pro with FF3b3 and FF3b4. It gives no warning before closing no matter what start up preferences are set.
On the Beta5pre (as of 3/18) and Beta4, WinXP I am getting:

Note: I have about 4 tabs open for each window.

Preference is set to "Show My Home Page"
- With multiple windows open-> "Close Tabs" dialogue.
- With only one window open-> "Save and Quit" dialogue.

Preference set to "Show my windows and tabs from last time"
- With multiple windows open-> "Close Tabs" dialogue.
- With only one window open-> FireFox/Minefield close silently, reopen tabs on next start.

So this is a worksforme.  This is also a fresh install of XP without anything fancy on the entire system (except for the QA Companion FireFox addon).
i can also confirm this (win xp, beta4(german)). startup options don't change anything. with multiple windows open i do get the warning
DUPE of bug 417186?
Still confirmed in FF Beta 5. The "Warn me when closing multiple tabs" box is checked, and yet every time I attempt to exit the browser, it simply shuts down with NO "Close multiple tabs?" dialog box. Running on WinXP SP2. Reproducible every time. 

Also reproducible in safe mode. 

Marty: Make sure that you don't have set Firefox to "show [your] windows and tabs" at startup and that the pref browser.warnOnQuit is set to true in about:config . (And of course: that you've got more than one tab open when you close Firefox.)
I can also confirm this bug. I'm running FF3 Beta 5:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

When pressing CTRL+Q, there is no prompt confirming that I want to close my tabs.

However, when I click the close icon (x) on the browser window, I get prompted: "You are about to close 18 tabs. Are you sure you want to continue?".

My preferences are:
about:config shows browser.warnOnQuit=true
When Firefox starts: Show my windows and tabs from last time

@Simon: I don't see how the latter option should have any effect on the former. If browser.warnOnQuit=true, it should ALWAYS warn me before closing multiple tabs, regardless of the "When Firefox starts" option or HOW I actually attempt to quit Firefox.
I've finally figured out what conditions cause this bug. All of my configuration settings are correct. I was finally able to have the "confirm close" box come up, albeit on accident. The ONLY way this box comes up for me is if I open a second browser window (doesn't matter if there's content or not in this second window), and then bring the focus back to the first browser window, and attempt to close the browser. 

If the focus remains on the empty browser window, hitting close will only cause that browser window to close. But if you try to close the main browser window with another browser window open, the "confirm close" window will popup. The "confirm close" windows does NOT pop up when only one browser window is open, hence the bug. 

FYI I have the session manager extension running, but I seriously doubt that its causing this problem.  

I tried opening a second window, switching to the first, and then pressing CTRL+Q to close the first window. I still don't receive any confirmation asking me if I'm sure I want to close all my tabs.

I'm trying this WITHOUT any extensions installed.

I really hope this gets fixed in the final release, because it's definitely a bug in the OS X version of FF3 Beta 5.
I can also confirm this bug. I'm running FF3 RC1:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008051202 Firefox/3.0

Bug still present in RC1 for Windows XP as well.

This isn't a fix, but could provide some insight into why the close dialog box isn't working. The only way to get it to "work" is by opening a new browser window (as opposed to another tab in the existing window), and then put the focus on the original window, and then try to shut down the browser. You will get the close dialog box then, every single time.

I can only confirm this in FF3 B5 (running on Win XP SP2), as I have yet to take the jump to RC1. 
Apologies for my previous post. I just figured out that my information is redundant. And here I thought I was being original! :) 
Marty: even if I follow your steps I still don't get the warning message.
Perhaps you're doing it wrong, especially since it is now obvious (to me at least) that several other people have been able to get the workaround to work??? I don't know. 

And yes, I was able to reproduce both the bug and the workaround in comment # 15 in RC 1 running XP SP2
Marty's workaround in comment#15 is working, but is anyone working at this obvious bug if it appears since beta 4?
Looking at several bugs (bug #386067, bug #433123, bug #412640, bug #419009), it seems that not everybody is comfortable with the semantics of browser.warnOnQuit and browser.tabs.warnOnClose. I wonder if decoupling them a little more and giving them the semantics I describe in bug #384907 comment #21 would be a step in the right direction. Any thoughts?
The shutdown process is not as clean as it should be.  I think the problem that people are having here is that the "browser.warnOnQuit" setting was somehow set to false in FF2, or a previous beta or nightly for FF3.  I had the same problem.  From the source: "browser.warnOnQuit is a hidden global boolean to override all quit prompts"

If you start with a fresh profile, then it should be true, which is why it was not reproducible for some of you.

If you want the warn on quit dialog (Session restore) to show on quit, or closing the last window, you need to do the following:
1. Go to about:config
2. Filter "browser.warnOnQuit"
3. Reset it (or just set to true)

The session restore dialog is not the same as the tab warning dialog, but FF is working under the assumption that when you are closing the last window, you are quitting, and thus the different dialog.

That said, I think at this point in time this is a WONTFIX (or even a dup of some other bugs), but I wont mark it yet.
I'm using Firefox 3.0 RC1 on Mac OS X 10.5.3.

about:config shows "browser.warnOnQuit" = true

When I press Command+Q (Windows equivalent is Ctrl+Q), I do not get any warning. Firefox just quits.

When I click the X icon on top left (top right on Windows) to close Firefox, I get a warning message confirming I want to close.

Why is this a WONTFIX? I should get the warning message regardless of whether I'm quitting using a keyboard shortcut or using my mouse.
(In reply to comment #23)
#1 Firefox on Mac does not quit when you close the last window - it follows the Apple HIG and keeps the app running.  Therefore when you close the last window it gives you the "closing multiple tabs" prompt.

#2 Do you have the start up behavior to restore tabs & windows from last time? If so, when you quit (cmd-Q) the dialog regarding save session will not show and Firefox will quit.  Session will be restored upon starting Firefox.

This used to bug me until I thought about it more. Perhaps a dialog confirming that you intended to quit is in store for this case, but that would be a different bug. On the plus side, if you hit cmd-Q by accident your session should restore.
Yes, it's true. It can be helpful if you accidentally quit FF, but FF 2.0 wouldn't let you to close multiple tabs without confirmation. Nevertheless, if some error had occured and FF 2.0 had been closed by OS without confirmation, it asked to recover last session on next startup.
(In reply to comment #24)
Thank you for finally making this clear to me! I tried changing the startup behavior to just show "My Home Page" instead of "My windows and tabs from last time" and then tried Command+Q, fully expecting it to just quit without a prompt. Sure enough, for the first time (while using Command+Q) I got a dialog asking me to confirm that I wanted to close multiple tabs. Woohoo!

This dialog also has a "Save and Quit" button that restores all my tabs the next time Firefox starts, even though my preferences is set to show "My Home Page" upon startup.

That last part is probably the most misleading and confusing part of all this and it almost seems like a hidden feature (I never thought I would need to change my default startup setting to change the behavior of a quit warning). As Marek mentioned, FF2's default behavior was to always warn on quit if multiple tabs were open.

Never the less, I'm satisfied there is at least a way to get a warn on quit dialog when pressing Command+Q, even if it is a bit confusing. :)
So it's by design that using "Show my windows and tabs from last time" supersedes browser.warnOnQuit?

If so, then I will open a separate bug for this. It's true that FF will restore your session if you accidentally quit. However, the experience can still be quite poor: you'll lose your place in a Youtube video, have to re-enter authentication info for the sites you were viewing, etc.
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 419009
Duplicate of this bug: 441136
You need to log in before you can comment on or make changes to this bug.