'make distclean' misses some files

RESOLVED FIXED in mozilla1.9.1b2

Status

defect
RESOLVED FIXED
11 years ago
Last year

People

(Reporter: fta+bugzilla, Assigned: glandium)

Tracking

Trunk
mozilla1.9.1b2
x86
Linux
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

Reporter

Description

11 years ago
Posted patch cleanup, round 1 (obsolete) — Splinter Review
As a follow-up of bug 333308, here are even more cleanups for:

browser/installer/packages-static
browser/installer/removed-files
other-licenses/branding/firefox/locales/Makefile
other-licenses/branding/firefox/Makefile
Attachment #309498 - Flags: review?(benjamin)
Assignee

Comment 1

11 years ago
The other-licenses/branding stuff should go in a section specific to --enable-official-branding.
Reporter

Comment 2

11 years ago
Posted patch cleanup, round 1 rev2 (obsolete) — Splinter Review
updated to work with --enable-official-branding
Attachment #309498 - Attachment is obsolete: true
Attachment #309516 - Flags: review?(benjamin)
Attachment #309498 - Flags: review?(benjamin)

Comment 3

11 years ago
Comment on attachment 309516 [details] [diff] [review]
cleanup, round 1 rev2

Is there a reason you have to hardcode the MOZ_BRANDING_DIRECTORY check? Why not

add_makefiles "
  $MOZ_BRANDING_DIRECTORY/Makefile
  $MOZ_BRANDING_DIRECTORY/locales/Makefile
"
Attachment #309516 - Flags: review?(benjamin)
Assignee

Comment 4

11 years ago
The other-licenses/branding stuff is actually bug #429852 i just filed.
Assignee

Comment 5

11 years ago
I think this is better than attachment #309516 [details] [diff] [review], for the browser/installer part.
Attachment #316620 - Flags: review?(benjamin)
Assignee

Comment 6

11 years ago
Okay, I see that contrary to what i said in bug #429852, the Makefiles aren't generated from configure. This will obviously solve bug #429852 by cheating: Makefiles will be removed twice.
Attachment #309516 - Attachment is obsolete: true
Attachment #316622 - Flags: review?(benjamin)

Updated

11 years ago
Attachment #316620 - Flags: review?(benjamin) → review+

Updated

11 years ago
Attachment #316622 - Flags: review?(benjamin) → review+
Assignee: nobody → mh+mozilla
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Depends on: 461309
Depends on: 461051
Assignee

Updated

10 years ago
Duplicate of this bug: 429852

Updated

Last year
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.