Last Comment Bug 424339 - Error when trying to download latest updated Add-ons
: Error when trying to download latest updated Add-ons
Status: RESOLVED FIXED
:
Product: addons.mozilla.org Graveyard
Classification: Graveyard
Component: Public Pages (show other bugs)
: unspecified
: x86 All
: -- critical
: ---
Assigned To: Wil Clouser [:clouserw]
:
:
Mentors:
: 422562 424335 426350 439859 443688 452673 (view as bug list)
Depends on: 425315
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-21 06:28 PDT by Carsten Book [:Tomcat]
Modified: 2016-02-04 14:51 PST (History)
27 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Carsten Book [:Tomcat] 2008-03-21 06:28:00 PDT
Currently it seems that the latest updated Addons having Problems to install since i get "Invalid file hash (possible download corruption)
-261"

This affects addons like:
- https://addons.mozilla.org/en-US/firefox/addon/6349
- https://addons.mozilla.org/en-US/firefox/addon/3867

Seems this affects all Addons updated March 20.
Comment 1 Fred Wenzel [:wenzel] 2008-03-21 06:49:18 PDT
*** Bug 424335 has been marked as a duplicate of this bug. ***
Comment 2 Alex Polvi 2008-03-21 08:44:31 PDT
If this is related to bug 422562, a cache expiration will fix it. However, this seems to be a bigger issue.
Comment 3 Alex Polvi 2008-03-21 08:47:02 PDT
I've recalc'd the hash on 3867... but wont be able to tell if it fixed it for a couple hours. I'll keep investigating.
Comment 4 Alex Polvi 2008-03-21 08:53:38 PDT
Filed 424362 to get IT to start messing with cache sizes... which we think is a temporary fix.
Comment 5 Alex Polvi 2008-03-21 15:56:03 PDT
I know the broken add-ons where updated this morning. Not sure if the correct fix has happened yet. Any update?
Comment 6 Michael Morgan [:morgamic] 2008-03-21 17:12:29 PDT
Found that there is an error in the file copy code that presented itself after php5 migration but have not located it yet.  Will send updates once we are able to reproduce on dev environment.
Comment 7 Stephen Donner [:stephend] 2008-03-25 22:25:03 PDT
Seems to be fine for me; Tomcat, you?
Comment 8 M. R. Galbreath 2008-03-26 04:22:22 PDT
Issue seems to be resolved for me.
Comment 9 Cesar Oliveira [:cesar] 2008-03-29 17:29:50 PDT
There have been reviews for addons 4639, 6297, and 2390 (and more) that also seem to have this problem (invalid hash). All the dates are posted on March 29th, so after the new AMO site went online.

However, I was able to install all three addons mentioned above without a problem.
Comment 10 MPsi 2008-03-30 05:11:24 PDT
I encountered this bug when tried to install addon 5978 using newly created account. When trying to download the addon directly (i.e. by pasting the link to address bar), I get redirected to a page with following information:
"The add-on you're looking for is in the sandbox, which you do not have enabled in your user preferences."
I suppose the sandbox is enabled by default now for logged in users, so this redirection is outdated. I guess this might be the reason for the bug.
Comment 11 Thomas Bertels 2008-03-30 05:21:22 PDT
There's still https://addons.mozilla.org/fr/firefox/addon/4142
Comment 12 [:philipp] 2008-04-01 14:43:06 PDT
i do experience the same problem with my own extension recently uploaded (#6822) on AMO.
however, i'm only getting this error, when i try installing it with the current minefield nightlies - firefox 2.0.0.13 + 3b5 do work correctly
Comment 13 Fred Wenzel [:wenzel] 2008-04-02 01:20:29 PDT
Bug 426350 has a big list of add-ons that apparently fail to install (for 2.0.0.13). What's going on?
Comment 14 Fred Wenzel [:wenzel] 2008-04-02 01:20:55 PDT
*** Bug 426350 has been marked as a duplicate of this bug. ***
Comment 15 Basil Hashem [:baz] 2008-04-03 08:38:38 PDT
We need some attention to this bug, so I'm retargeting for 3.2.1 consideration. Here's another addon that has this issue:

https://addons.mozilla.org/en-US/firefox/addon/6910

Do we simply need to run a "recalc hash" on a whole bunch of add-ons and wait for the cache update? Or is it deeper than that?
Comment 16 Fred Wenzel [:wenzel] 2008-04-03 08:54:00 PDT
(In reply to comment #15)
> Here's another addon that has this issue:
> 
> https://addons.mozilla.org/en-US/firefox/addon/6910

This is an experimental add-on, for experimental add-ons the problem is likely caused by the problem in bug 426468 (fixed and needs push). This does not apply to public add-ons though.

Fwiw, all other add-ons mentioned here install fine for me, except the latest version of 4142 (see comment 11) which I get an error 261 for, also.
Comment 17 mh512 2008-04-03 09:49:26 PDT
My addon is having this issue as well.
https://addons.mozilla.org/en-US/firefox/addon/5850

I uploaded my ext on 30 Mar (GMT+8) (probably means 29 Mar...) and encountered this problem. I uploaded a newer version today and the problem persists.

Comment 18 mh512 2008-04-03 09:56:48 PDT
(In reply to comment #17)
> My addon is having this issue as well.
> https://addons.mozilla.org/en-US/firefox/addon/5850
> 
> I uploaded my ext on 30 Mar (GMT+8) (probably means 29 Mar...) and encountered
> this problem. I uploaded a newer version today and the problem persists.
> 

Sorry guys, I just realize that my problem is due to https://bugzilla.mozilla.org/show_bug.cgi?id=425483 and not this.
Comment 19 Brandon Peters 2008-04-04 09:54:31 PDT
My add-on is having the same issue. I uploaded it yesterday (Apr 03, 08).

https://addons.mozilla.org/en-US/firefox/addon/6927

Thanks.
Comment 20 Fred Wenzel [:wenzel] 2008-04-04 10:08:12 PDT
(In reply to comment #19)
> My add-on is having the same issue. I uploaded it yesterday (Apr 03, 08).
> 
> https://addons.mozilla.org/en-US/firefox/addon/6927

This is an experimental add-on and therefore likely suffers from bug 426468. See the discussions over there for a temporary workaround. It's fixed and will be pushed soon.
Comment 21 Michael Morgan [:morgamic] 2008-04-09 11:00:43 PDT
Experimental add-ons are fixed now, we are working on bug 425315 to resolve any 261 errors caused by mismatched memcache entries.
Comment 22 Michael Morgan [:morgamic] 2008-04-16 14:24:21 PDT
Are people still having problems with the 261 error?  Issue in bug 426468 and I haven't seen much traffic since.
Comment 23 [:philipp] 2008-04-16 14:57:29 PDT
i tried uploading a new version of my extension after your former post, but am still receiving the -261 error when attempting to install with minefield...
https://addons.mozilla.org/de/firefox/addons/policy/0/6822/26738
Comment 24 Alexander Dietrich 2008-04-16 23:50:26 PDT
I'm also still seeing this with my extension and FF 3.0b5:
https://addons.mozilla.org/en-US/firefox/addon/6875
Comment 25 u88484 2008-04-30 16:16:28 PDT
A user tried to download my sandboxed extension on April 26th and reported this also. Addon: https://addons.mozilla.org/en-US/firefox/addon/6933

Reported in on a forum though and not in the review.
Comment 26 u88484 2008-05-01 10:26:24 PDT
(In reply to comment #25)
> A user tried to download my sandboxed extension on April 26th and reported this
> also. Addon: https://addons.mozilla.org/en-US/firefox/addon/6933
> 
> Reported in on a forum though and not in the review.
> 
This was the users reply to when I posted this bug report to see if it was the same thing.
"Turns out that if you have "Accept third-party cookies" disabled, the Mozilla cookie can't be read or written too (Maybe they're using the wrong domain, who knows), I have to accept third party cookies to download."
Comment 27 Alexander Dietrich 2008-05-03 09:32:38 PDT
Good find! I was able to install my extension after allowing third-party cookies.
Comment 28 Mark Smith (:mcs) 2008-05-23 09:13:09 PDT
I encountered this same problem today.  I was also able to work around it by enabling 3rd party cookies.  But the error message will definitely confused most people.
Comment 29 Wil Clouser [:clouserw] 2008-06-04 12:54:28 PDT
AMO uses several Urchin cookies with a domain of ".addons.mozilla.org" and an AMOv3 cookie with a domain of "addons.mozilla.org"

There shouldn't be any others set.  Are you guys seeing any other cookies set?
Comment 30 Fred Wenzel [:wenzel] 2008-06-04 16:08:06 PDT
If third-party cookies are the problem here, bug 437174 would be a dupe of this.
Comment 31 Alexander Dietrich 2008-06-05 01:05:10 PDT
Wil: I just checked it again with a fresh PortableApps installation of FF 3.0RC2, there's the same number of cookies regardless of the 3rd party cookies setting (four ".addons.mozilla.org" cookies and one "addons.mozilla.org"). Still, with 3rd party cookies disabled, the installation fails.
Comment 32 Fred Wenzel [:wenzel] 2008-06-18 05:35:13 PDT
*** Bug 439859 has been marked as a duplicate of this bug. ***
Comment 33 Dave Garrett 2008-07-04 20:56:36 PDT
*** Bug 443688 has been marked as a duplicate of this bug. ***
Comment 34 Peter Parke 2008-07-27 04:38:04 PDT
I have an extension in the sandbox which has been updated for FF3. It has a reasonable number of users/downloads. However, a user in the Philippines has contacted me to report a persistent 261 error when attempting download of the update (this user had my previous version on the same machine without problem). This is the only report I have had.

I note the discussion about 3rd party cookies. In testing my extension I have downloaded it both with and without 3rd party cookies enabled, and haven't met with this error.
Comment 35 Myk Melez [:myk] [@mykmelez] 2008-08-06 16:21:54 PDT
A number of folks are seeing this problem with Snowl, which I added to the site yesterday:

https://addons.mozilla.org/en-US/firefox/addon/8397
Comment 36 Michael Morgan [:morgamic] 2008-08-27 11:40:22 PDT
It has to deal with the installation button element having information that is mismatched.

There is also the possibility that it is taking too long for releases.mozilla.org to get updated files from AMO and that is why we are getting the 261 error -- because the files at the location requested doesn't actually exist (404).
Comment 37 Michael Morgan [:morgamic] 2008-08-27 11:43:37 PDT
Bug 425315 covers the cache invalidation problem, but we'll follow-up with stats/info on the mirror pushes of newly updated files.  Need to find out:
* what the slowest mirror is when it comes to rsyncing new files from AMO
* what our configured file delay is for the downloads controller
Comment 38 Cesar Oliveira [:cesar] 2008-08-28 13:43:07 PDT
*** Bug 452673 has been marked as a duplicate of this bug. ***
Comment 39 Michael Morgan [:morgamic] 2008-09-16 16:10:07 PDT
Bug 425315 was recently resolved, we will see if this problem is still prevalent after the update before proceeding.

To be thorough, I checked on the mirror delay and also asked that the config be updated to lengthen the mirror delay timeout so new files get more time to propagate before being hosted solely on r.m.o.

Time will be increased from 30 minutes to 1 hour.  Bug 455608.
Comment 40 Michael Morgan [:morgamic] 2008-10-29 21:27:09 PDT
*** Bug 422562 has been marked as a duplicate of this bug. ***
Comment 41 Michael Morgan [:morgamic] 2008-10-29 23:22:43 PDT
*** Bug 458446 has been marked as a duplicate of this bug. ***
Comment 42 Michael Morgan [:morgamic] 2008-10-29 23:27:27 PDT
I'm reopening this, found some other instances.  Notes:
* We need to implement the cache invalidation rules for the download controller and all pages touching the install element (the invalidation from bug 425315)
* We need to serve downloads via AMO for much longer than 1 hour to allow for releases to receive updated files
Comment 43 Dave Townsend [:mossop] 2008-11-02 04:46:54 PST
Don't think this blocks 437174, the issue there is a client side problem with not sending cookies to AMO, I think it just initially looked like the same problem.
Comment 44 Peter Parke 2008-11-10 23:37:37 PST
9th November 08. I have had a further report of this error (261) from someone trying to download one of my sandbox add-ons. What advice should I give them? Any suggestions welcome.
Comment 45 Myk Melez [:myk] [@mykmelez] 2008-11-11 00:06:35 PST
(In reply to comment #44)
> 9th November 08. I have had a further report of this error (261) from someone
> trying to download one of my sandbox add-ons. What advice should I give them?
> Any suggestions welcome.

Per discussion earlier in this bug, the workaround is to enable third-party cookies, i.e. open Preferences/Options and check the "Accept third-party cookies" checkbox in the Privacy pane (you can re-uncheck it after installing the extension).
Comment 46 Wil Clouser [:clouserw] 2009-03-11 15:47:29 PDT
Is this still a problem?  If so, are there clear steps to reproduce it?
Comment 47 Myk Melez [:myk] [@mykmelez] 2009-03-11 16:12:41 PDT
I couldn't reproduce a moment ago.
Comment 48 Ngamer01 2009-04-11 12:45:19 PDT
If this bug isn't the right place for this, let me know.  

Anyways I'm getting this error now for experimental add-ons with the recent push of Bug 441739 that went live on AMO.  When logged out, any experimental add-on gets me the "-261 Invalid File Hash" error when I check the "Let me install this experimental add-on." box.

When I log into AMO, then I can fetch any experimental add-on I want.  No errors.
Comment 49 Wil Clouser [:clouserw] 2009-04-12 17:58:12 PDT
(In reply to comment #48)
> If this bug isn't the right place for this, let me know.  
> 
> Anyways I'm getting this error now for experimental add-ons with the recent
> push of Bug 441739 that went live on AMO.  When logged out, any experimental
> add-on gets me the "-261 Invalid File Hash" error when I check the "Let me
> install this experimental add-on." box.
> 
> When I log into AMO, then I can fetch any experimental add-on I want.  No
> errors.

What is the status of your 3rd party cookies?  Can anyone else reproduce this?
Comment 50 Ngamer01 2009-04-12 18:49:10 PDT
(In reply to comment #49)
> What is the status of your 3rd party cookies?

All cookies allowed.  Including third party ones.  I did further investigating of the problem and it turns out while logged out, copying and pasting the link to download an experimental add-on still makes AMO prompt you into logging into AMO.  Bug 441739 will probably need reopening on that though (I can provide screenshots to that bug if asked).
Comment 51 Myk Melez [:myk] [@mykmelez] 2009-04-12 19:49:34 PDT
> What is the status of your 3rd party cookies?  Can anyone else reproduce this?

I have third party cookies disabled, and I am unable to reproduce with the Snowl <https://addons.mozilla.org/en-US/firefox/addon/8397/> and You Old Enough? <https://addons.mozilla.org/en-US/firefox/addon/9128> experimental extensions.
Comment 52 Wil Clouser [:clouserw] 2009-04-13 08:13:30 PDT
Thanks, I'll call this fixed then.

Ngamer01:  if what you're experiencing isn't bug 488092 then feel free to open another bug with specific steps to reproduce and example URLs. Thanks.

Note You need to log in before you can comment on or make changes to this bug.