Remove toolkit help viewer

RESOLVED DUPLICATE of bug 1290756

Status

SeaMonkey
Help Viewer
RESOLVED DUPLICATE of bug 1290756
10 years ago
2 years ago

People

(Reporter: Gavin, Assigned: Jeff Walden (gone starting June 8))

Tracking

(Depends on: 1 bug)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

It was disabled by default in bug 423486, the only known user is SeaMonkey. Once they create their own help viewer (bug 424130) we can remove the toolkit version entirely.
Depends on: 424130

Comment 1

10 years ago
Thunderbird is a potential user, assuming future progress on bug 253334.
(Obviously), if TB wants to use it too, it could be better to keep it (shared) in Toolkit.
Depends on: 253334
Version: unspecified → Trunk
(In reply to comment #2)
> (Obviously), if TB wants to use it too, it could be better to keep it (shared)
> in Toolkit.
> 
In addition, any extensions that use the Toolkit.

http://developer.mozilla.org/en/docs/Help_Viewer

Comment 4

10 years ago
> (comment #3) In addition, any extensions that use the Toolkit.

Apparently, bug 427621 was filed for that reason.
Depends on: 427621

Comment 5

10 years ago
> In addition, any extensions that use the Toolkit.
Not to mention any number of XULRunner Applications.

Comment 6

9 years ago
I'm a XULRunner application developer and would like to see the Mozilla Help Viewer remain in the toolkit instead of maintaining my own help viewer. It is small and isn't contributing much "bloat."

Comment 7

8 years ago
As a XULRunner developer, I agree that the platform needs a usable help viewer, including TOC sidebar, search etc.. (I have no opinion about the current implementation.)

Updated

7 years ago
Duplicate of this bug: 686168
Product: Toolkit → Seamonkey
The help viewer has been moved to Seamonkey in bug 686168 and deleted from Toolkit in bug 1290756. Sorry we missed the existing bug. I am closing this as a duplicate of Bug 1290756.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1290756
You need to log in before you can comment on or make changes to this bug.