Move help viewer to comm-central

RESOLVED FIXED in seamonkey2.47

Status

SeaMonkey
Help Viewer
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: Matheus Kerschbaum, Assigned: frg)

Tracking

Trunk
seamonkey2.47
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.47 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

7 years ago
AFAICT help viewer is only used by SeaMonkey, so this code shouldn't live on mozilla-central.
Flags: in-testsuite-

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 425541

Comment 2

7 years ago
XULRunner applications use the help viewer as well. See bug 425541.
(Assignee)

Comment 3

2 years ago
Actually this isn't a duplicate as IanN pointed out over irc.
Assignee: nobody → frgrahl
Blocks: 1243203
Status: RESOLVED → REOPENED
Flags: in-testsuite-
Resolution: DUPLICATE → ---
(Assignee)

Comment 4

2 years ago
Created attachment 8771867 [details] [diff] [review]
686168-SuiteHelpAdd.patch

Patch to move the help viewer over.
Attachment #8771867 - Flags: review?(iann_bugzilla)
(Assignee)

Updated

2 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Updated

2 years ago
No longer blocks: 1243203
Depends on: 1243203
(Assignee)

Updated

2 years ago
Component: Build Config → Help Viewer
Product: Core → SeaMonkey

Comment 5

2 years ago
patching file suite/common/jar.mn
Hunk #1 FAILED at 0
Hunk #2 FAILED at 125
2 out of 2 hunks FAILED -- saving rejects to file suite/common/jar.mn.rej
patching file suite/themes/classic/jar.mn
Hunk #2 FAILED at 30
Hunk #3 succeeded at 86 with fuzz 2 (offset 9 lines).
1 out of 3 hunks FAILED -- saving rejects to file suite/themes/classic/jar.mn.rej
patch failed, unable to continue (try -v)
patch failed, rejects left in working directory
errors during apply, please fix and qrefresh 686168-SuiteHelpAdd.patch
(Assignee)

Comment 6

2 years ago
I just checked and the patch applies clean to a current unmodified c-c. Could you check your tree. If you applied the error console patch before it will clash with it. Use hg import -f and edit the rejects manually if you need both patches at once. 

I will see if I can pull the history in here too if the patch is ok. Not easy because another repository.
Flags: needinfo?(iann_bugzilla)

Updated

2 years ago
Depends on: 1288981

Comment 7

2 years ago
File copy with history done via https://hg.mozilla.org/comm-central/pushloghtml?changeset=376136cbab3b
Had to use hg rebase in the end
Flags: needinfo?(iann_bugzilla)

Comment 8

2 years ago
Comment on attachment 8771867 [details] [diff] [review]
686168-SuiteHelpAdd.patch

Patch needs to be rebased now the files have been copied with history from m-c.
Attachment #8771867 - Flags: review?(iann_bugzilla)
(Assignee)

Comment 9

2 years ago
Created attachment 8774759 [details] [diff] [review]
686168-SuiteHelpAdd-V2.patch [Checked in: Comment 12]
Attachment #8771867 - Attachment is obsolete: true
Attachment #8774759 - Flags: review?(iann_bugzilla)
(Assignee)

Comment 10

2 years ago
Moved all parts to helpviewer to distinguish it from the actual help. Kept the orginal locations for css and other stuff via skin and content statement.

Comment 11

2 years ago
Comment on attachment 8774759 [details] [diff] [review]
686168-SuiteHelpAdd-V2.patch [Checked in: Comment 12]

r/a=me
Attachment #8774759 - Flags: review?(iann_bugzilla) → review+

Comment 12

2 years ago
Comment on attachment 8774759 [details] [diff] [review]
686168-SuiteHelpAdd-V2.patch [Checked in: Comment 12]

https://hg.mozilla.org/comm-central/rev/b87713baaa13
Attachment #8774759 - Attachment description: 686168-SuiteHelpAdd-V2.patch → 686168-SuiteHelpAdd-V2.patch [Checked in: Comment 12]

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago2 years ago
status-seamonkey2.47: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.47
(Assignee)

Comment 13

2 years ago
I just noticed that we still pull in the old help viewer via moz_help_viewer=1 in confvars.sh and modern theme files are in the wrong dir.

Reopening the bug for a quick followup fix.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

2 years ago
Blocks: 1289851
(Assignee)

Comment 14

2 years ago
Created attachment 8775265 [details] [diff] [review]
686168-SuiteHelpAdd-part2.patch

Tested and works for me.
Attachment #8775265 - Flags: review?(iann_bugzilla)

Comment 15

2 years ago
Comment on attachment 8775265 [details] [diff] [review]
686168-SuiteHelpAdd-part2.patch

r=me
Attachment #8775265 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 16

2 years ago
https://hg.mozilla.org/comm-central/rev/a744f83c0ab5

I think we are done here. See you in the follow up bugs.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Blocks: 1290756

Updated

2 years ago
Depends on: 1296668
You need to log in before you can comment on or make changes to this bug.