Status

Thunderbird
Mail Window Front End
--
critical
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: jcranmer, Assigned: Joey Minta)

Tracking

({regression})

Trunk
x86
Linux
regression
Dependency tree / graph
Bug Flags:
blocking-thunderbird3.0a1 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs landing of patch in bug 426715])

(Reporter)

Description

10 years ago
Similar to the bug 428662 in that the Account dropdown is empty. Marking as critical since this makes changing server-side filters via the UI impossible. SM might or might not have the same problem. Probably a regression of bug 413781.
Flags: blocking-thunderbird3.0a1?

Comment 1

10 years ago
Marking blocking-3.0a1+, as this is a regression that breaks functionality.
Flags: blocking-thunderbird3.0a1? → blocking-thunderbird3.0a1+
(Assignee)

Comment 2

10 years ago
This bug likely has the same root cause as bug 426715.  Both are caused by code that assumes that an nsIMsgAccount will have a non-null incomingServer.  It's not yet clear to me under what conditions that assumption is false.

Updated

10 years ago
Blocks: 413781
Keywords: regression
(Assignee)

Comment 3

10 years ago
Joshua,
   Are there any errors in the javascript console when you open the dialog? I'd like to be able to confirm my comment #2 hypothesis.
(Reporter)

Comment 4

10 years ago
These are the errors I get in the console:

###!!! ASSERTION: couldn't lazily create the server
: 'NS_SUCCEEDED(rv)', file /src/mozilla/mailnews/base/src/nsMsgAccount.cpp, line 93
JavaScript error: chrome://messenger/content/mail-folder-bindings.xml, line 243: acct.incomingServer is null

(/me gripes about that \n in the nsMsgAccount assertion)
(Assignee)

Comment 5

10 years ago
OK, perfect.  Bug 428887 will fix this.
Status: NEW → ASSIGNED
Depends on: 428887

Updated

10 years ago
Whiteboard: [needs landing of patch in bug 426715]
(Assignee)

Comment 6

10 years ago
This should be fixed now.  Please verify.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.