Closed Bug 429345 Opened 13 years ago Closed 13 years ago

indicate account on tab for folder name in tabbed interface

Categories

(Thunderbird :: Mail Window Front End, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b1

People

(Reporter: wsmwk, Assigned: mkmelin)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 2 obsolete files)

indicate account on tab for folder name in tabbed interface so you know which tab to click

account name is in the window title bar for the _current_ folder.  But that doesn't help in choosing which of several non-focused "inbox" tabs one should click to get to account X. (inbox being just one example)
Flags: wanted-thunderbird3?
Severity: normal → enhancement
OS: Windows XP → All
Hardware: PC → All
Definitely wanted+, might even be blocking, as it's pretty crummy usability-wise.  Adding clarkbw for an opinion here.
Flags: wanted-thunderbird3?
Flags: wanted-thunderbird3+
Flags: blocking-thunderbird3?
Should be smart too - if you only have one account, who cares, but if you have multiple, the account name should display.  Or perhaps only display for non-unique folders like Inbox.
While we're at this I think we should also be using the same display method that the Folder Pane uses such that we indicate the number of (un)read status of the folder as well.

.--------------. 
| *Inbox (12)* | 

If we went with longer titles to show the account I think our tabs are going to grow in size pretty quickly.  And I'm not really sure how you start compressing down the account name effectively. 

.------------------------------------. .---------------------------------.
| *Inbox (12)* - clarkbw@example.com | | Sent Mail - clarkbw@example.com |

.-----------------------------. .---------------------------.
| *Inbox (12)* - clarkbw@ex...| | Sent Mail - clarkbw@ex... |

.--------------------------. .----------------------.
| *In (12)* - clarkbw@ex...| | Sent - clarkbw@ex... |

I think the non-unique folder name method of displaying accounts wouldn't help the person know which of their inboxes is already in a tab.

I'm wondering if we should be using color or possibly some other kind of identifier to indicate different accounts.  At least by combining both the account name addition and some color support we could compress only the account name and leave the folder name in complete.  Assuming the Folder Pane used the same color codes to display the accounts it should be pretty obvious which tab relates to which account while compressed.  Might have to see what it looks like.
Duplicate of this bug: 460521
An alternate idea I discussed with david a day ago was to use account icons as identifiers in a similar fashion to fav icons for the web. ( exactly what firefox does )  Icons would always be visible from the left hand side of the tab and likely would be less distracting that changing the color of the text.

Here's how icons / color blocks could work.

The new folder pane ( bug 446306 ) will look about like this when showing different accounts.  [ Assume that %% and ## are icons or color blocks ]

+------------------------+
| Inbox                  |
| .....                  |
|                        |
| %% clarkbw@example.com |
| ## clarkbw@example.org |
|                        |
+------------------------+

Which would give us tabs with the following layout.

.-----------------. .---------.
| ## *Inbox (12)* | | %% Sent |

A point was also made that it might be possible to grab fav icons from the domain source.  Thunderbird could ask example.com and example.org for fav icons as a default.

An icon / color block chooser is going to be needed to help people pick a an icon that makes sense for their account.  Komodo has a nice icon chooser that we might be able to use.  

By default we should be choosing icons or color blocks that are different from the existing accounts icon / color blocks people could then customize our chosen default at their leisure.
The icon / color tandem will definitely save space on tabs, which is also needed.
Good ideas.  To throw out another - a user chosen mnemonic of one or two characters would work for me.
Isn’t this simply an allowance to user to modify the tab name? Sounds very good to me.

It could be even empty. Then what? If icons are available at provider site who owns IMAP, POP, SMTP, etc. servers, it is always possible to pick them there too. Firefox shows that icons are always there.
We already have a color block chooser that we use with individual calendars; if we go with color blocks, we'll want to think about the usage colors holistically (across at least calendars, colors, message tags, and calendar categories), I suspect.
Icon / Color – this couple are also excellent natural insurer to avoid pointing to nowhere (in case if text is null). It might be something from what Application / OS can supply by default in rotation.
A few observations, opinions, views which might be found useful:

Product, Version, Platform: Thanderbird: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b2pre) Gecko/20081022 Lightning/1.0pre Shredder/3.0b1pre

Component: Mail Window Front End

1.After restart Thanderbird does not restore tabs:
Account1, …, AccountN, …, Calendar, Tasks, …

2.Accounts – Folders tree and Tabs are not synchronized.
- Selecting tab does not highlight appropriate node on the tree
- Selecting node on the tree does not change the tabs focus

2.Tabs do not keep their names after clicking on them.

3.Tabs are not dragable.

4.Tab names better be “Account - Folder” as more self explanatory.
Assignee: nobody → mkmelin+mozilla
Attached patch proposed fix (obsolete) — Splinter Review
I'm actually quite surprised to notice none of my mail accounts' favicons could be obtained simply requesting example.com/favicon.ico ... 

Anyways, this patch 
 o makes the tab title be
   * for accounts: account name
   * for folders: foldername - account name
   * for messages: subject - foldername - account name

 o makes the tab icon use the same icons we use in the folder pane

The pinstripe css changes are dry coded...
This patch depends on the patch in bug 462045 to show the secure icon for pop/imap.

You may have to apply this patch with "patch -p1 --fuzz=5", not to get conflicts with bug 462681...
Attachment #345885 - Flags: ui-review?(clarkbw)
Attachment #345885 - Flags: review?(philringnalda)
Personal preference

I personally prefer the Firefox tabs style “Site Icon – Site Name”. Then, correspondingly for Thunderbird tab names would be “Account Site Icon - Account Folder Name”.
Do I want my provider's icon to distinguish different accounts? Possibly yes, if I have my accounts with different providers. Possibly not, if I keep more accounts with the same provider that I prefer (e.g. for keeping business and private mail separate).

A color code icon - like with calendars - sounds very helpful. This would help users to use a once chosen markup throughout the application consistently (e.g. red for "business", blue for "private).

Why not additionally display the account name that the user has chosen? He will choose short names (e.g. "home", "office") if that helps him get along with the tabs.
I've been trying this out for a little while now and really makes the tab names long.  If you only have one account you get really long names for no real reason.

I'm feeling like the additional text isn't really helpful, it creates so much text that it's a bit overwhelming.  I'd like to try using the calendar color chooser to give some default colors and see how that works instead.  I can start with some mockups of what it could look like.
How about site icons as Firefox does? Tab length is also limited there. After reaching the limit on tabs all you can do is just scroll the tab bar.
Comment on attachment 345885 [details] [diff] [review]
proposed fix

Looked fine to me at doing what it was doing, but it sounds like you'll be fighting out the ui-r for a while...
Attachment #345885 - Flags: review?(philringnalda)
Re "long additional text": sure it doesn't always (though often) fit in the tab - but a more the rule than an exception for tabs in the browser too. Personally I don't think it hurts, the lonely folder name looks much more out of it's element than a tab with a long title. I imagine one common use cases is to have two or a few inboxes open in tabs, then looking for folders, messages in the tab selection list. Using colors in the tab selection list is bound to look odd... 

Where in the tab would you add the color? Coloring the tab itself just makes it look non-native. Even it we'd add some colors, that's not enough. "Thou shalt not use colors alone to convey meaning", and all that...
(In reply to comment #16)
> How about site icons as Firefox does? Tab length is also limited there. After
> reaching the limit on tabs all you can do is just scroll the tab bar.

What the patch does is add icons like that yes, not the "site icon" though.
Site icons sound good before you start thinking more closely about it.
 - it's a bit of a hack to get them
 - what icon would you use
   * of your ISP -> you'd just get a bunch of tabs with the same icon - not nice
   * of the sender -> privacy implications we don't want, and outside the corporate environment, not very informative/representative of the sender either
I'd like to add a visualization of my own comment #14:

.--------------------------. .----------------------.
| *Inbox (12)* - home      | | Sent - office        |

I can't see why these texts should be too long.
(In reply to comment #20)
> I'd like to add a visualization of my own comment #14:
> 
> .--------------------------. .----------------------.
> | *Inbox (12)* - home      | | Sent - office        |
> 
> I can't see why these texts should be too long.

Hmm ... ? Where is the sign of folder origin? Home? Office? I guess these are destinations ... nothing else ... not really much sense ... Source tells a lot more about meaning, then sorting, ordering, renaming, etc. after the fact of receiving.
I assume those (home/office) are the account names...
Exactly. The visualization in comment #20 refers to comment #14 where I have described the example using "home" and "office" as account names. I suggest using them. Then it's up to the user to choose short account names that help him find the right tabs easily.
How in the world mail client may know the meaning of Home or Office. These are your personal imagination entities no matter where it comes from or where it goes to. It is possible even in the current version to have folder Office with subfolders, say departments, and Home consequently with family members or friends.

All this is the same as organizing and storing files on a hard drive.

But it is possible to spend less time on the above, if better organize outer sources, redirect them to different destinations. For example: all business messages go to GMail, all personal messages go to MSN Live or Hotmail, or vice versa, it is up to you to decide.

Managing the sources makes much easier management and sorting by meaning and importance.
"Home" or "Office" are just examples (of what the account node is called), the account name is editable in the account settings.

Is your complaint about the folder structure not showing in the title, or what?
Now all comes to the point where this all has been started. If users have generic predefined local or remote folders (eg: Inbox, Outbox, Trash, etc.), if they are also allowed to have their own local or remote folders (eg: Office, IT Department, Accounting, etc.)

why not to show the Icon (Local or picked from the remote site) and folder name on the tab?

Why not to have the selection of folder on the tree and correspondent folder tab synchronized and highlighted simultaneously?
(In reply to comment #26)
> why not to show the Icon (Local or picked from the remote site) and folder name
> on the tab?

That's what we currently do. Minus the remote site icon, see comment 19.
AFAIK you can already create as many subfolders for each account as you like. But if you use different accounts for different purposes you may have subfolders that are named alike. I believe that using different accounts is a first level of separating mail by whatever purpose.

I would want the name of the folder AND the name of the account on the tab, like:
folder_name - account_name

Can it be any more obvious?
But it seems like Magnus is the only one who understands my point.
(In reply to comment #27)
> (In reply to comment #26)
> > why not to show the Icon (Local or picked from the remote site) and folder name
> > on the tab?
> 
> That's what we currently do. Minus the remote site icon, see comment 19.



> ... Minus the remote site icon ...

That is what I think would be nice to have.

And, of course, good to have them (tree and bar) synchronized.

Thank you.
Bryan: I'd still like to get this in.

The icon part I assume would be supplementary in any case - whether we get site icons/colors or whatever, and I don't see how you'd get it done completely with colors in the end... esp. when you consider accessibility concerns.
Icons ...

http://shared.live.com/ceiKB83P7mF6XW7lyeP3rg/WindowsLive.png
https://a248.e.akamai.net/sec.yimg.com/i/us/nt/ma/ma_mail_1.gif
https://a248.e.akamai.net/sec.yimg.com/i/us/uh/bt2/yahoov1.gif
https://mail.google.com/mail/help/images/logo.gif
https://webauth.att.net/img/ui/1x1.gif
http://www.mozilla.com/img/tignish/products/title-thunderbird.png

etc.

I guess there is something similar in all the above. There is always img, jpg, gif, png, etc. file. If a problem is possible with finding such file, there is always Google to help. Not a man job to find all possible/suitable images, my guess it is very easy to automate, algorithm is very clear what to search and how to do this. Am I right?
No, you are wrong. Just because servers that are primarily about webmail may or may not have a favicon somewhere that may or may not be accessible without first logging in doesn't mean that non-webmail servers do, or that there's a standard way to go from an POP3/IMAP server name to where the corresponding webmail server is, or that a person using a non-webmail client would recognize that favicon as meaning their mail account (anything you choose for mx1.balanced.spacey.mail.dreamhost.com will not mean "my mail at my Dreamhost-hosted domain" to me), or that the webmail favicon would in any way help people with multiple accounts on a single server distinguish between those account.

However, big bonus points for including that 1x1 pixel transparent gif for att.net, that's a nice argument against your plan :)

It would be possible to use a user-chosen image, but it would inevitably be awkward UI, would then lose the chance to use an icon to distinguish types of folders and folders from messages and messages from whatever else we stick in tabs, and I don't see anyone stepping up to write that code.
Then Folders … and Icons …

It becomes only possible after the successful event of defining user account. When connection is established it becomes possible to find and retrieve site icon. to retrieve and replicate all remote folder names (with at least “table of contents”) after the connection defined and established. This is sufficient requirement; this is how all web browsers do.
And I still do not understand what the icon of my ISP has to do with my mail account.

Take for instance my mail address: I am using any of the common webmail providers (like yahoo.com, hotmail.com etc.) but my own domain which has no association with my ISP. I could even change my ISP still using the same address.

What if I have to different accounts with the same ISP? How would the ISP's icon help me to distiguish those two?

Face it: email is not a website, a POP/IMAP mail account is not webmail and a mail client is not a webbrowser.
Space is needed on tabs? This is the way how to save it. Icon is a shortest possible replacement for ISP Web site name, I think.
Did you say "web site name"? We are talking about mail accounts, not about websites.

The proposed fix by Magnus is just fine.
In this case:

> Take for instance my mail address: I am using any of the common webmail
> providers (like yahoo.com, hotmail.com etc.) but my own domain which has no
> association with my ISP. I could even change my ISP still using the same
> address.

You may want to have an option to change the icon or add some short description
to it (because of the space; that is up to users what they want to see).

So, make interface easier to understand, but do not try to resolve all possible
problems. Let users decide what they want.
Magnus: can you come up with a patch that only adds the account name when there are two or more accounts (and for extra credit, picks something better than using an undefined variable when there are fewer than one, to catch bug 460409 at the same time)? I think you're right, the way to paint this bikeshed is to just paint it, rather than continue to shout our favorite color of paint past each other, and you're also right that a11y means using color is off the table unless the forthcoming design has some alternate way of using text, in which case, hey, you'll have provided the text for it!
Attachment #345885 - Flags: ui-review?(clarkbw) → ui-review+
Comment on attachment 345885 [details] [diff] [review]
proposed fix

Magnus: I don't have much of a solution right now so we might as well get something in.  It'd be good to have something that doesn't use the long format when there is only one account, however this is a good start.

If you want to move forward on this for now we can at least get some more testing and work on another version later when we have a better idea of what that change is.
Attached patch proposed fix, v2 (obsolete) — Splinter Review
Attachment #345885 - Attachment is obsolete: true
Attachment #348434 - Flags: review?(philringnalda)
Attached patch proposed fix, v3Splinter Review
Minor error in the previous patch...

Don't include the account name if we only have one real account.

Avoid "undefined" title by setting it to "" during first account setup. (At least for now, not to break the string freeze.)

The commandglue.js change is just getting rid of unnecessary code, which was always causing a caught exception for rss account folders.
Attachment #348434 - Attachment is obsolete: true
Attachment #348509 - Flags: review?(philringnalda)
Attachment #348434 - Flags: review?(philringnalda)
And just pretend "are is" reads "is" ;)
Comment on attachment 348509 [details] [diff] [review]
proposed fix, v3

Looks reasonable to me, let's try it.
Attachment #348509 - Flags: review?(philringnalda) → review+
changeset:   1151:dd1309481ad9
http://hg.mozilla.org/comm-central/rev/dd1309481ad9

->FIXED
Status: NEW → RESOLVED
Closed: 13 years ago
Flags: blocking-thunderbird3?
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0b1
Duplicate of this bug: 435360
You need to log in before you can comment on or make changes to this bug.