In some versions, "Import Everything" does nothing, shows a dialog with no options

RESOLVED FIXED in Thunderbird 50.0

Status

defect
--
major
RESOLVED FIXED
11 years ago
3 years ago

People

(Reporter: gkw, Assigned: aceman)

Tracking

({qawanted})

Trunk
Thunderbird 50.0
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [workaround:ImportExportTools addon])

Attachments

(2 attachments, 2 obsolete attachments)

Occurred on Vista SP1 while testing Shredder Alpha 1 build 1, with build ID
version 3.0a1 (2008050715).

I didn't think this occurred in the 10.4 testing, as the "Import Everything" option wasn't selectable for 10.4.

When I clicked Tools -> Import, chose the "Import Everything" option, I come to a screen saying that I should import data from <a blank space>. Basically there's no selectable options and clicking "next" does nothing.
Flags: wanted-thunderbird3?
gary (component) Import or Migrate?  still see this?  
Import WFM, but I see only Netscape ... as selection items
(In reply to comment #1)
> gary (component) Import or Migrate?  still see this?  
> Import WFM, but I see only Netscape ... as selection items

I think I was referring to menu item Tools -> Import, if that's the case then it's probably MWFE.

I don't have a Vista readily at fingertip yet, but Vista doesn't have Import Everything as a selectable option?
Flags: wanted-thunderbird3?
Keywords: qawanted
Maybe this should be a bug report by itself, but it seems to be the same problem repored here ... so here are some additional symptoms

Bug:  Post installion Import Fails to "import everything" setting into Eudora 1.0.0b4 from any location.

Details:  Starting from "Tools -> Import ... -> Starts process, brings up menu list where I choose "import everything" and select Eudora.  Process hangs at the point where it asks or states "... import from:". At this point it hangs waiting for someone or something???  This failure occurs for all import options except for the "nicknames".

Note:  This process works (or at least it does not hang and imports info) when I choose "import names/nicknames".  It asks for the folder location to search -- which worked fine with a network drive.

Environment:  Building a new system on a "brand new" computer system.  System "hard disk" crash on previous system.
1.  New System is Vista Ultimate on 2.8G intel processor, 4G memory, 200G hard disk
2.  Eudora 7.1 settings, folders, nicknames, attachements located on a network drive  (also tried to from a copy on the C drive)

Happy to supply additional information and/or work with team for resolution.  I tried to find information on the Import process and other bug info, but I haven't developed sufficient skills to navigate the bugzilla database.  Hence, I need some help on how to proceed to solving this problem.

I would consider this issue a Major Bug Issue.

Sincerely,
Jack

jacksystemmaintence@gmail.com
@Gary: can you still confirm this bug with latest nightly ?

(In reply to comment #1)
> Import WFM, but I see only Netscape ... as selection items
on what OS / what supported migrations you believe are missing ?

I can't reproduce this bug but I have a problem with import everything and Outlook 2003 SP3 (no mail is imported; lack of account import is another bug) - I will probably file a bug for this if there isn't one already.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b3pre) Gecko/20090111 Shredder/3.0b2pre
Summary: "Import Everything" does nothing, shows a screen with no options → "Import Everything" does nothing, shows a dialog with no options
I think we added support for windows live mail recently, so this should be fixed now.
When I clicked Tools -> Import, chose the "Import Everything" option, there's no selectable options and clicking "next" does nothing.

We can reproduce this bug on Solaris Next latest build_151, and Linux OS, the TB version is TB 3.1.6. 

So I change this bug to All platform.
OS: Windows Vista → All
Hardware: x86 → All
I am having the same problem (Tools - Import - Everything - option less window with <Next> that does nothing) with Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.16) Gecko/20101125 SUSE/3.0.11 Thunderbird/3.0.11 -- Open SuSE 11.2 64 bit.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 561562
(In reply to comment #8)
> 
> *** This bug has been marked as a duplicate of bug 561562 ***

I just updated 561562 noting that the problem I am having has nothing to do with the problem that 561562 reports. My statement "...Everything - option less window" meant that the window/panel/screen displayed had NO OPTIONS to select from, not that I could not select a Windoze system to import from. After all, I was and still am running Linux (SuSE 11.2).
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: DUPLICATE → ---
Confirming with Thunderbird 7 beta and 8 (alpha).
See: http://getsatisfaction.com/mozilla_messaging/topics/cannot_import_mail_settings_in_earlybird_8_0a2

Impact (at least) Windows and Linux.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [gs]
I do not reproduce that bug anymore on TB9.0a2.
Any idea if something explain how this could have been fixed?
(In reply to caméléon from comment #11)
> I do not reproduce that bug anymore on TB9.0a2.
> Any idea if something explain how this could have been fixed?

Obviously, the bug is still there on 10.0a2 :-(
don't reproduce it with TB 11.0a2 on Windiws XP... Very strange...
"Import Everything" is now not a selectable option on

Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:12.0a1) Gecko/20120109 Thunderbird/12.0a1

(There is a radio button, but can't be selected)
Duplicate of this bug: 722677
Duplicate of this bug: 751692
This has been a bug for 4 years now. Are there any plans to fix it?
(In reply to Ludovic Hirlimann [:Usul] (away until August 5th) from comment #8)
> 
> *** This bug has been marked as a duplicate of bug 561562 ***
Well, I cannot import from anything, but in this case I would like to import from Outlook, not from Windows live. So this is not a dublicate as a whole.

For some people this was the problem from import Windows live, but not all. Actually I cannot import even when I select import mail. But this is also a true and existing bug.
Now I know that someone is needing extra info, so I will write:
Platform was Windows Vista, Program Microsoft Outlook, and after selecting import everything there was no choises to continue. At least a message saing, that there seems been no data to import. But after selecting import mail Thuderbird finds those mails.

The computer was not mine, and I cannot try again. Thunderbird version was latest (stable) on last weekend. I have no idea about Outlook version, but is was quite old, but all security updates were installed.
A platform where problems:
OS:Microsoft® Windows Vista™ Home Premium
Versio	6.0.6002 Service Pack 2 Koontikäännös 6002

Microsoft Office 2007 (12.0.6661.5003)SP3 MSO (12.0.6662.5000)

And at least Thunderbird 14.0 and 15.0 fails.
Adding that I have not found version where this work, fails at least:
15.0.1
10.0.7 (ESR)
16.0

I mainly test in builds that are made for finnish langue. I assume all are finnish versions.
(In reply to Ilari Halminen from comment #21)
> Adding that I have not found version where this work, fails at least:
> 15.0.1
> 10.0.7 (ESR)
> 16.0
> 
> I mainly test in builds that are made for finnish langue. I assume all are
> finnish versions.

And I assume Office is the same. And also Windows Vista Home Premium

Microsoft Office 2007 (12.0.6661.5003)SP3 MSO (12.0.6662.5000)
I'm using Thunderbird 17.0.2 on a Ubuntu 12.10 machine and this bug is alive and well.

Tools --> Import --> Import everything --> next is a dead-end.

Tools --> Import --> Mail --> "Please select the type of file that you would like to import:" shows an empty area.
i'm using Thunderbird 17.0.4 on Ubuntu 12.04 LTS, and I experienced exactly what vinayg18@gmail.com  in  Comment 23 wrote...  :((

also tried installing  the "importExportTools" extension, but this didn't make any difference...
The behaviors listed in comment #23 are also present in Debian Wheezy's rebranded IceDove 17.0.10.
A friend of mine reported this behavior on Windows 7. I tested it on my Linux Mint 17 machine and also experienced it. We've been helping some Thunderbird users transferring data around using workarounds, but this is a serious problem. Also, installing the ImportExportTools extension was not helpful, as other users here have described.
It has been 6 years since this serious bug was reported and it still hasn't isn't fixed?? I still see it with Linux Fedora 20. Can we start a new thread to determine the best alternative email client? I have been using Thunderbird for years, but this is enough for me.
It has been 6 years since this serious bug was reported and it still hasn't isn't fixed?? I still see it with Linux Fedora 20. Can we start a new thread to determine the best alternative email client? I have been using Thunderbird for years, but this is enough for me.
Meanwhile I think that this is not considered a bug really. If you have a look at windows version of Thunderbird, then only "Outlook" and "Outlook Express" are choosable as further options then. And everything is imported from the local Outlook (Express) installation then. On Linux distributions these two options are not supported, of course, because on Linux there doesn't exist any Outlook (Express), aside from using Wine or similar stuff... And so it's no surprise that there's an empty space at this dialog window. Well, it's bad usabilty, and at least there should be some explanatory text...  --  As a workaround one can use add-ons (extensions) like ImportExportTools, but then the functionality isn't added by filling this empty space... Instead functionality is added at other menus (or context menus) of Thunderbird then, mostly.
maybe worth to mention furthermore: There exist tools which convert/export existing emails from Outlook (Express) to the mbox format. And ImportExportTools can import this format ...
There are indeed versions of outlook that we don't handle. I don't remember which. 

Someone could improve, reproduce, combine, etc any/all of the cases so that we have a better undersetanding of what's happening  https://bugzilla.mozilla.org/buglist.cgi?list_id=10812600&short_desc=import%20everything&resolution=---&resolution=FIXED&resolution=INVALID&resolution=WONTFIX&resolution=DUPLICATE&resolution=WORKSFORME&query_format=advanced&short_desc_type=allwordssubstr&product=MailNews%20Core&product=Thunderbird
Summary: "Import Everything" does nothing, shows a dialog with no options → In some versions, "Import Everything" does nothing, shows a dialog with no options
Whiteboard: [gs] → [workaround:ImportExportTools addon]
So what do you guys expect to import from? What is the email client that should be in the list on your machine?

Somehow I do not understand what this bug is about. Is some installed client missing in the list? Or is it just that if nothing usable is found TB should say so and exit the wizard cleanly?
(In reply to :aceman from comment #33)
> So what do you guys expect to import from? What is the email client that
> should be in the list on your machine?
> 
> Somehow I do not understand what this bug is about. Is some installed client
> missing in the list? Or is it just that if nothing usable is found TB should
> say so and exit the wizard cleanly?

@aceman: I have also M$ Outlook 365 in the computer for my university job, but I guess that if nothing is found it should not have the "Next" button enabled.
When I tried I used
Microsoft Office 2007 (12.0.6661.5003)SP3 MSO (12.0.6662.5000)

And it do not show anything to import from.
OK, let me try this.
Assignee: nobody → acelists
Posted patch patch (obsolete) — Splinter Review
So the current state is like this:
1. if you choose "import all", you may get an empty window with nothing to import (attachment 8631001 [details]). However, the Next button is no longer enabled, which is probably fixed by bug 1186141.
2. if you select some of the partial imports (AB, mail, filters, etc.), e.g. on Linux most of the lists of import methods are empty. The Next button is disabled properly.

So half of this bug is already fixed by other bugs.

So as the remaining part I do this:
For 1. if there is nothing to import, show the special "Nothing" item that we already have available, so that the user has more of a clue what is going on. If a better string is needed, we can improve it (this was the least intrusive fix).
For 2. if there is nothing to import, show a special message saying that to the user. The message could be improved in the ui-review :)
Attachment #8757663 - Flags: ui-review?(richard.marti)
Attachment #8757663 - Flags: review?(mozilla)
Status: NEW → ASSIGNED
Depends on: 1186141
My situation on Windows is this (after hiding my SM profile):
1. Import all shows nothing and the "Cancel" button is disabled.
   So I can review any improvement here.
2. All five individual items (AB, mail, feeds, settings, filters) have non-empty lists.
   So I can't review that part. Note that apart from feeds, Becky! shows up in all items.
Correction: 1. The "Next" button is disabled, the "Cancel" button is enabled.
Comment on attachment 8757663 [details] [diff] [review]
patch

Review of attachment 8757663 [details] [diff] [review]:
-----------------------------------------------------------------

OK. With this patch I get for "Import Everything": 
"Don't import anything", "Next" disabled, "Cancel" enabled.
I can't test the individual imports, but given the few changes and given that this isn't on the critical code path, I'll trust Aceman on this.

On the UI side, I find this puzzling.
The enabled radio button "Don't import anything" looks like the user has an active choice. Well, he does not. I'd put:
"Nothing to import" and make the radio button disabled. So it looks more like a message. Ideally we should have no radio button but only a message. But I can live with the radio button.

I'll revisit after Richard commented.

::: mail/components/migration/content/migration.js
@@ +100,5 @@
> +    } else {
> +      // If no usable import module was found, select the "Import nothing" item.
> +      let nothingItem = document.getElementById("nothing");
> +      nothingItem.hidden = false;
> +      document.getElementById("importSourceGroup").selectedItem = nothingItem;

This appears to be the only functional change, together with two tweaks below.

::: mailnews/import/content/importDialog.js
@@ +127,5 @@
>    nextButton.setAttribute("disabled", "true");
>    var backButton = document.getElementById("back");
>    backButton.setAttribute("disabled", "true");
>  
> +  if (listbox && (listbox.selectedCount == 1))

This is clean-up, right?

@@ +132,3 @@
>    {
>      importType = document.getElementById("importFields").value;
> +    var index = listbox.selectedItem.getAttribute('list-index');

More clean-up.

@@ +329,2 @@
>    {
> +    let index = listbox.selectedItem.getAttribute('list-index');

And more.

@@ +1034,5 @@
>      {
>        SwitchType(radioGroup.value);
> +      deck.selectedIndex = 1;
> +      document.getElementById("modulesFound").selectedIndex =
> +        (document.getElementById("moduleList").itemCount > 0) ? 0 : 1;

Tweak 1.

@@ +1051,5 @@
>  
>  function SelectFirstItem()
>  {
>    var listbox = document.getElementById("moduleList");
> +  if ((listbox.selectedIndex == -1) && (listbox.itemCount > 0))

Tweak 2. That was it.

@@ +1060,5 @@
>  function enableAdvance()
>  {
>    var listbox = document.getElementById("moduleList");
>    var nextButton = document.getElementById("forward");
> +  if (listbox.selectedCount > 0)

More clean-up.
Attachment #8757663 - Flags: feedback+
(In reply to Jorg K (PTO during summer, NI me) from comment #40)
> ::: mailnews/import/content/importDialog.js
> @@ +127,5 @@
> >    nextButton.setAttribute("disabled", "true");
> >    var backButton = document.getElementById("back");
> >    backButton.setAttribute("disabled", "true");
> >  
> > +  if (listbox && (listbox.selectedCount == 1))
> 
> This is clean-up, right?

All the changes you marked clean-up are only half-cleanup :)

Before I removed the 'style="height: 0px;"' rule, there were cases where the listbox was collapsed to zero height, had no items, but these .selectedItems property was still returning non-empty selection. Then later in the function we were fetching strings for non-existent items and it was throwing errors into error console. I don't know if that is a bug in XUL listbox or is intended operation (somehow skipping hidden elements). So I tried to fix this by changing to these new properties.

But I can easily move these changes under bug 1276482.
(In reply to :aceman from comment #41)
> But I can easily move these changes under bug 1276482.
Up to you. I was just trying to understand it.
Comment on attachment 8757663 [details] [diff] [review]
patch

It's already an improvement.

2. is looking fine. ui-r+
1. Like Jörg wrote, it looks a bit weird with the radio button in front of the entry. Also does this entry's sentence look wrong. It's more like a command. Like in 2. could you only add a information which says: "Nothing found to import"?

I know the import all is a new dialog on top of the other import dialog, but would it be possible to activate the Back button to return to the selection dialog like it's also possible in 2.? Then the user could directly try to import other things like AB's feeds. Closing the whole import dialog after nothing found could be a bit abrupt.
Attachment #8757663 - Flags: ui-review?(richard.marti) → ui-review-
Posted patch patch v2 (obsolete) — Splinter Review
Is this better?
Attachment #8757663 - Attachment is obsolete: true
Attachment #8757663 - Flags: review?(mozilla)
Attachment #8757715 - Flags: ui-review?(richard.marti)
Comment on attachment 8757715 [details] [diff] [review]
patch v2

Yes, this is better. Thank you.
Attachment #8757715 - Flags: ui-review?(richard.marti) → ui-review+
Comment on attachment 8757715 [details] [diff] [review]
patch v2

Review of attachment 8757715 [details] [diff] [review]:
-----------------------------------------------------------------

Like Richard, I like this better. Maybe Kent can review the wizard stuff.

::: mail/locales/en-US/chrome/messenger/migration/migration.dtd
@@ +6,5 @@
>  <!ENTITY migrationWizard.title          "Import Wizard">
>  
>  <!ENTITY importFromWin.label            "Import Options, Account Settings, Address Book, Filters and other data from:">
>  <!ENTITY importFromNonWin.label         "Import Preferences, Account Settings, Address Book, Filters, and other data from:">
> +<!ENTITY importSourceNotFound.label     "No application to import found.">

English derailed a little here ;-)
We don't import applications, we import data from applications. So:
No application to import data from found.
No application to import from found.
Nothing to import.
Nothing to import found.
Attachment #8757715 - Flags: feedback+
Posted patch patch v2.1Splinter Review
Yes, thanks.
Attachment #8757715 - Attachment is obsolete: true
Attachment #8757727 - Flags: review?(mkmelin+mozilla)
Duplicate of this bug: 117844
Duplicate of this bug: 101999
Comment on attachment 8757727 [details] [diff] [review]
patch v2.1

Review of attachment 8757727 [details] [diff] [review]:
-----------------------------------------------------------------

::: mail/locales/en-US/chrome/messenger/importDialog.dtd
@@ +37,5 @@
>  <!ENTITY selectDescriptionB.label "Please select an existing account or create a new account:">
>  <!ENTITY selectDescription.accesskey "P">
>  <!ENTITY acctName.label           "Name:">
>  <!ENTITY acctName.accesskey       "N">
> +<!ENTITY noModulesFound.label     "No usable method/file type to import found.">

"Nothing to import from found" perhaps? What's a non usable method?
Attachment #8757727 - Flags: review?(mkmelin+mozilla) → review+
(In reply to Magnus Melin from comment #50)
> "Nothing to import from found" perhaps? What's a non usable method?
And "nothing" references an application? Hmm, I still suggest one of
- No application to import data from found.
- No application to import from found.
- Nothing to import.
- Nothing to import found.

The second option would be close to Magnus' suggestion.
"Method" was that the individual importers allowed to also import directly from a file (like addressbooks). But if Import Everything only imports from an installed application (or its profile dir), then "application" will be more correct.
(In reply to Jorg K (GMT+2, PTO during summer, NI me) from comment #51)
> (In reply to Magnus Melin from comment #50)
> > "Nothing to import from found" perhaps? What's a non usable method?
> And "nothing" references an application?

No, the file basically.

If it can only be an installed application's profile, the yes, I agree Jörg's suggestions are good. Maybe the "Nothing to import found" is best.
The importSourceNotFound.label is used in the "Import everything" subdialog, that imports from apps like Outlook, Outlook Express or Seamonkey. I can assume it either looks for their profiles, or somehow calls that app to provide the data. So I used "no application to import data from found".

The noModulesFound.label is used in the partial importers. You choose e.g. "address book" and it shows you file types that you can open (show in the picker) and then import from (e.g. LDIF). But if you choose e.g. Filters, it shows you apps (e.g. Becky) and for some of them you can't choose the file, e.g. for Becky it again looks into its profile and looks for the file (there is a bug already requesting the possibility to picking the file).
So here I used "No usable method/file type to import found." Should I change it to "No application or file type to import found." ?
(In reply to :aceman from comment #54)
> So here I used "No usable method/file type to import found." Should I change
> it to "No application or file type to import found." ?
As I said in comment #46:
We do *not* import applications or file types.
We import data from applications or files of a certain type. So:

- No application to import data from found.
- No application to import from found.
- Nothing to import.
- Nothing to import found (Magnus' favourite).

Or if you want to mention files:

- No application or file to import data from found.
- No application or file to import from found.
- Nothing to import.
- Nothing to import found. (Magnus' favourite)
OK, I like "No application or file to import data from found." the most. I'd like to also mention that we support no file types that we could import from. So the more text the better so the user gets more clues (the dialog still looks empty anyway:)).
Since it was my suggestion, I wholeheartedly agree ;-)
Comment on attachment 8757727 [details] [diff] [review]
patch v2.1

Ratty, there is one SM string.
Attachment #8757727 - Flags: review?(philip.chee)
Comment on attachment 8757727 [details] [diff] [review]
patch v2.1

r=me a=me Thanks.
Attachment #8757727 - Flags: review?(philip.chee) → review+
https://hg.mozilla.org/comm-central/rev/092a6d3d82f1ee2045563cc5ba59ce042b96cc72
Status: ASSIGNED → RESOLVED
Closed: 8 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 50.0
this is great, but 
"No application or file to import data from found."

is rather awkward en-US.  minimally it should be changed to:
"No application or file to import data from was found."

better yet:
"No application or import data file was found."
Probably too few native English speakers looked at it :)

Rkent, Wayne, can we get a quick opinion on comment 61?
Flags: needinfo?(vseerror)
Flags: needinfo?(rkent)
"No application or file to import data from found."

It is also factually imprecise with respect to the "application". But so was the original wording.  How but the longer but more precise...

Unable to import - either the source application is not installed or import data is missing.
Flags: needinfo?(vseerror)
"No application or file to import data from found." is fairly typical somewhat stilted computer phrasing. I don't really have a strong objection to it, and this issue seems to me it has already been discussed in detail.

My understanding in reading that is that there was no source found for import data, so me as user needs to figure out why Outlook or whatever was not found when I thought that it should be. This is different from a situation where something was found, but there was nothing there that could be imported. I hope that is the intention.

"No application or file to import data from was found." is slightly less awkward though longer, if space is not an issue this could be acceptable.
Flags: needinfo?(rkent)
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #63)
Sorry, that's no good. The use of the definite article "the" refers to a specific application. However, in that case no application whatsoever to import data is installed.

And "Unable to import" is misleading. Sounds like due to some problem you couldn't import and if the problem were solved, you would be able to import. That's not the case. There is simply nothing to import.

You wouldn't say: Wayne is unable to help the blind man across the street if there is simply no blind man requiring help.

If alta88 doesn't like
No application or file to import data from found.
we can add a verb and make it:
No application or file to import data from was found.
I support that.

r+ in advance from me for that change ;-)

Looks like Kent agrees, so let's go with that.
quite simply, my point is "No application" for the average user totally lacks context. 
but, this is really why i don't like people asking my these kinds of questions - status quo
Looks like we discussed so much that in the end we never fixed the message.
Here we go:
https://hg.mozilla.org/comm-central/rev/4355c7d0f406
I put r=rkent since he approved the wording in comment #65.
You need to log in before you can comment on or make changes to this bug.