Thunderbird fails to check that it is the default email client on startup

RESOLVED FIXED in Thunderbird 3

Status

Thunderbird
General
--
minor
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: gkw, Assigned: sid0)

Tracking

(Blocks: 1 bug)

Trunk
Thunderbird 3
Dependency tree / graph
Bug Flags:
wanted-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Occurred on 10.4 Tiger, while testing Shredder Alpha 1 build 1 and on Vista SP1 as well.

Thunderbird fails to check that it is the default email client on startup. On Vista, I even made sure that I checked "Windows Mail" as the default prior to starting Thunderbird. I ended at the account wizard without Thunderbird ever asking me if Thunderbird was to become the default client.

On first run, as a comparison, Firefox does ask if it should be the default web browser, so the same should apply for Thunderbird.
Flags: wanted-thunderbird3?

Comment 1

10 years ago
I tried it on Windows XP.  After setting up an account, the next restart of Thunderbird made it ask whether it should be the default.  It would be wrong for it to ask before any account is set up, because a default mail client with no account is useless.
Duplicate of this bug: 450110
Gary, do you have multiple profile? I bet so. I can remember to a bug where that happens with multiple profiles. Could you run a test with a cleaned folder under Library?
(Reporter)

Comment 4

10 years ago
Henrik, fresh profile.

I must note that this happens on and off. Sometimes the dialog comes up, other times not. Pretty inconsistent to be honest. Also, Mail.app wasn't touched, and the 10.5 system was pretty fresh.
Sure. But do you use multiple profiles? If not then it's a bit suspicious. Any idea why that only happens time by time? Any special conditions e.g. after a software update or others?
(Reporter)

Comment 6

10 years ago
No, no multiple profiles. No software update. And no idea why it only happens from time to time.
(Assignee)

Comment 7

10 years ago
As part of bug 430614, the startup situation does need to be improved.
Blocks: 430614
Status: NEW → ASSIGNED
Flags: blocking-thunderbird3.0b1?
(Assignee)

Comment 8

10 years ago
Created attachment 333992 [details] [diff] [review]
fix v1

The code's a pain to look at in general :(
Assignee: nobody → sid1337
(Assignee)

Updated

10 years ago
Attachment #333992 - Flags: superreview?(bienvenu)
Attachment #333992 - Flags: review?(bienvenu)

Comment 9

10 years ago
Thx for the patch, Sid! Can you explain a little what the problem was? Is this a regression?
(Assignee)

Comment 10

10 years ago
I'm not sure where if it's a regression or not (it could be related to bug 438050), but what was happening was that the account wizard dialog was being opened asynchronously, immediately returning to the code that checks whether there's an account or not (the default client dialog only pops up if there's already an account configured).

Now I'm forcing things to be in order through a callback.
I don't think this is really a blocker because it's just not that painful for the user.  But it'd sure be nice to have; so marking wanted-thunderbird3+.
Flags: wanted-thunderbird3?
Flags: wanted-thunderbird3+
Flags: blocking-thunderbird3.0b1?

Comment 12

10 years ago
Comment on attachment 333992 [details] [diff] [review]
fix v1

ok, thx, Sid.
Attachment #333992 - Flags: superreview?(bienvenu)
Attachment #333992 - Flags: superreview+
Attachment #333992 - Flags: review?(bienvenu)
Attachment #333992 - Flags: review+
(Assignee)

Updated

10 years ago
Keywords: checkin-needed
(Assignee)

Comment 13

10 years ago
Note to testers: please start with a fresh profile. (This should work fine on all Windows installations at least -- others might me missing something that is required for the default client dialog to show.)

You should see the account wizard. If you create the account, you should see the default client dialog immediately after the account wizard finishes. If you don't, you shouldn't.
http://hg.mozilla.org/comm-central/index.cgi/rev/72a87349675b
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3

Comment 15

10 years ago
Comment on attachment 333992 [details] [diff] [review]
fix v1

>+  setTimeout(function() { msgOpenAccountWizard(wizardCallback); }, 0);
Actually you can write this as
setTimeout(msgOpenAccountWizard, 0, wizardCallback);

Updated

9 years ago
Depends on: 480388
You need to log in before you can comment on or make changes to this bug.