Closed Bug 434354 Opened 15 years ago Closed 15 years ago

CalDAV provider should cope with multiple principal-collection-sets

Categories

(Calendar :: Provider: CalDAV, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: browning, Assigned: browning)

References

Details

Attachments

(1 file)

The CalDAV provider does various types of discovery concerning the remote calendar on the first call to getItems(), including a principal-collection-set query. The current code assumes that only one href will be returned by this query, and that is not necessarily the case. This is the underlying cause of the "pcs.charAt is not a function" error console message reported in bug 433906. The provider should cope with a response locating multiple principal-collection-sets, querying as many of them as necessary to achieve the next discovery step.
Requesting blocking-calendar0.8. As described in bug 441611, this can look like Lightning isn't loading anything after start up.
Flags: blocking-calendar0.9?
a fix for this is included in the draft caldav-sched patch in bug 409921
Depends on: 409921
Flags: blocking-calendar0.9? → blocking-calendar0.9+
probably also worth noting that currently Kerio is the only CalDAV server that triggers this bug
If this bug is not fixed by bug 409921 (which is assigned to bruno), please reassign if needed.
Assignee: nobody → browning
pulled this patch out of the bigger caldav-sched patch since it's unrelated; makes for easier review and better code history
Attachment #332383 - Flags: review?(daniel.boelzle)
Status: NEW → ASSIGNED
Version: Sunbird 0.8 → unspecified
Comment on attachment 332383 [details] [diff] [review]
handle multiple principal-collection paths

looks good; r=dbo (though I haven't tested it)
Attachment #332383 - Flags: review?(daniel.boelzle) → review+
The latest patch seems to make Lightning happy with Kerio, from my brief testing so far.
patch checked in on HEAD and MOZILLA_1_8_BRANCH

->FIXED
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.9
I can confirm this issue with iceowl (sunbird )0.8.6 on debian sid with darwin calendar server and multiple calendar. I hope it is resolved with version 0.9.
You need to log in before you can comment on or make changes to this bug.