All users were logged out of Bugzilla on October 13th, 2018

Submitting an empty login form leads to bogus error

VERIFIED FIXED

Status

--
minor
VERIFIED FIXED
11 years ago
3 years ago

People

(Reporter: wenzel, Assigned: rdoherty)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
Submitting a completely empty login form on AMO leads to a page stating "Please confirm your user account first with the code you received by email.".

That of course makes little sense and we should tell the user to fill in the blanks correctly, instead.
(Reporter)

Comment 1

10 years ago
Btw. we already have a "this field must not be empty" string, so we don't even need new l10n for this. Woot.
(Assignee)

Updated

10 years ago
Assignee: nobody → rdoherty
(Assignee)

Comment 2

10 years ago
We're getting this error because someone, somehow, entered no email address when registering. ??

I'll create the sql query to remove it and file an IT bug.
(Assignee)

Updated

10 years ago
Depends on: 445662

Comment 3

10 years ago
Hmmm..I was curious if maybe our user edit form allows users to somehow delete their email address...trying to remove one's address from https://addons.mozilla.org/en-US/firefox/users/edit then clicking save replies with "Profile Updated" but then clicking "My Account" takes you back and fills in the value. We should probably warn about that. Created bug 445664 to cover that.

Changing the value will generate a change-of-address confirmation email.
(Reporter)

Comment 4

10 years ago
"Wrong username or password!" -> FIXED
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Updated

10 years ago
Duplicate of this bug: 446360
Since this isn't fixed, does bug 446360 cover it?  If so, we should just mark this a dup of that bug.
NM, this is really that "preview's DB isn't updated" bug that I always gets tripped up on, sigh.  I'll verify this in production, then?
(Reporter)

Comment 8

10 years ago
(In reply to comment #7)
> I'll verify this in production, then?

Yes, please.
Verified FIXED; I get the "Wrong username or password!" text on https://addons.mozilla.org/en-US/firefox/users/login
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.