Closed Bug 43675 Opened 20 years ago Closed 18 years ago

Download alert shouldn't say "Netscape"

Categories

(Core :: Plug-ins, defect, P3)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: bugzilla, Assigned: timeless)

References

Details

(Keywords: helpwanted)

Attachments

(3 files)

It should only say it in the commercial branch...
Attached image screenshot
Blocks: 14532
summary to "Download alert shouldn't say "Netscape""
Summary: Download alert shouldn't say "Netscape" in the Mozilla branch → Download alert shouldn't say "Netscape"
AV, are you going to fix this?
Keywords: mozilla1.0
The text was put in by Ed Burns here:
xpfe/components/xfer/resources/locale/en-US/downloadProgress.properties
I think whoever is responsible for the GUI wording should take a look.
Not a Netscape 6 RTM blocker. FUTURE. This bug has been marked Future because
the Netscape engineer it is assigned to is overburdened.
Target Milestone: --- → Future
(Am I the only one who thinks it's mind-bendingly funny to say that having
"Netscape" in the UI isn't a Netscape 6 ship-stopper?  Mr. Krock, I've
underestimated your sense of humour.)

If edburns put that text in there, I'm sure he'll tell us why.  Hey Ed?  What's
up?  Can you undo that mistake?

(cvs annotate says that you approved it, Bill, so I've added you to the
discussion.  No mention of a reviewer -- is that what you meant by ``a='', Ed?)

If av is really so overburdened that he can't check in a simple text change,
then I will take this bug out of pity, and in the spirit of Mozilla comradery.
Assignee: av → shaver
We don't want Netscape 6.0 users to see a dialog that says "mozilla", and we
don't want mozilla users to see a dialog that says "netscape".  Here are some
options.

1. We modify the downloadProgress.properties file so it says neither "netscape"
nor "mozilla".

2. We leverage some existing facility for "netscape only" strings and put the
information there.

I think we should go with option 1.  

If you think it's that important, go ahead and edit the file.
#2 is fine. Just use brand.dtd or brand.properties.
If Netscape doesn't want Netscape 6.0 users to see the string ``Mozilla'', then
they should replace such instances in their branded builds and private tree, not
``pollute'' the Mozilla tree for the sake of convenience.

There are lots of messages in the tree that say ``Mozilla'', and I think that's
perfectly appropriate.  If Netscape wants to hide their browser-heritage, they
can do that somewhere away from our tree. =)

I'll produce the trivial patch this weekend, if nobody beats me to it.
Status: NEW → ASSIGNED
shaver: Did you ever create the trivial patch?
shouldn't we use &brandshortname; or something?

and do we want to point people to netscape.com?
Timeless:

quoting shaver: "There are lots of messages in the tree that say ``Mozilla'',
and I think that's perfectly appropriate.".

So that's not a problem. Now, let's r= and sr= this little wording change.
Progress, indeed.  I wish we had a better URL to point them at, but the sad fact
is that we don't.  So, worse-is-better, sr=shaver.
r=timeless
will commit tonight
Assignee: shaver → hwaara
Status: ASSIGNED → NEW
Keywords: mozilla1.0patch
Target Milestone: Future → mozilla0.9
fix checked in
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Shouldn't this be localizable?
peter: the patch is to a file in the en-us dist, so yes it's already 
localizable.

unfortunately, tao broke this.

i'm going to check in the same patch against the new files.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This dialog is clipped with some themes on Windows and Mac. I there any way we 
can make the dialog just a tad bigger....a few pixels wide and tall?
r=doron on timeless's patch
No, this is incorrect. Please fix this immediately. 

The properties file should use stringbundle's formatStringFromName or whatever 
it's called and %s embedded in the string, as well as loading brand.properties 
to obtain the client's brand name. Otherwise all vendors (Netscape, Beonex, etc) 
have strings say "Mozilla does.. blahblah"

Same thing probably needs to be done for the default plugin in bug 56653 but 
it's not a bundle, it's a Windows resource file. Ben, how to do this?
seems like we need some sort of build dependent .rc file. Not sure how that 
stuff is set up... 
i do have a bug to rewrite the plugin downloader plugin using xpcom +xul. if 
anyone wants to fix this sooner feel free but i wouldn't bother.

re ben's request, ok will fix.
Assignee: hwaara → timeless
Status: REOPENED → NEW
Timeless,

I'd like to see your new plugin. Can you or attach it?

Are these patches just waiting for approval?
Are you still shooting for 0.9 on this? If so please email drivers@mozilla.org
with a status on you progress. If not please retarget against a later Milestone.
Thanks.
I can't find my xul plugin downloader, i'll try to search for the crasher i 
filed wrt it ...
Target Milestone: mozilla0.9 → mozilla0.9.2
ok, so bug 55261 magically resurfaced, it had
attachment 16330 [details] chrome://navigator/content/nullpluginDialog.xul
attachment 16331 [details] chrome://navigator/content/nullpluginDialog.js
attachment 16332 [details] chrome://navigator/locale/nullpluginDialog.dtd
attachment 16333 [details] [diff] [review] Patch [doesn't work, probably a security violation]
I'm going to check on this, hopefully this week.

The current patch was veto'd by ben.  I'll need to spend a few minutes fixing 
it.  If anyone wants to work on either set of patches, feel free.
Status: NEW → ASSIGNED
Keywords: helpwanted
Target Milestone: mozilla0.9.2 → mozilla0.9.3
to 0.9.5 for timeless
Target Milestone: mozilla0.9.3 → mozilla0.9.5
Checked in by timeless, Feb 22nd. (!)

Gerv
Status: ASSIGNED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → FIXED
Hang on. Timeless checked it in, the tao removed it completely.

Tao - what's going on here? 

Gerv
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
> ------- Additional Comments From Mike Shaver 2001-02-21 08:35 -------
> 
> Progress, indeed.  I wish we had a better URL to point them at, but the sad 
> fact is that we don't.  So, worse-is-better, sr=shaver.


This is referring to the Netscape.com URL. I'd disagree, this URL presents no
advantage to the user. On the Netscape.com homepage you usually get some news
and a popup ad, there's no way to find the plugin downloader plugin on
Netscape.con, add to the fact that Netscape doesn't support all platforms
mozilla does and as the null plugin is platform dependent code then even if the
plugin did appear on Netscape.com it'd not solve the problem for all users.
tao what gives?
Assignee: timeless → tao
Severity: minor → normal
Status: REOPENED → NEW
Target Milestone: mozilla0.9.5 → ---
Comment on attachment 26637 [details] [diff] [review]
fix tao's regression

r=tao. All resource containing customizable urls, such as "http://", should be referenced by 
"package-region" type chrome url. It wasn't my intention
to remove it completely.
Attachment #26637 - Flags: review+
ok, now i just need an sr= ... or can i recycle the previous one..?
Assignee: tao → timeless
for reference, i have an untested patch in bug 71562 which does %s stuff. And it's been a while since i asked for an sr= via 'correct' channels.
Status: NEW → ASSIGNED
Comment on attachment 26637 [details] [diff] [review]
fix tao's regression

sr=jst
Attachment #26637 - Flags: superreview+
from
http://bonsai.mozilla.org/cvslog.cgi?file=mozilla/xpfe/global/resources/locale/en-US/region.properties:

1.7 timeless%mac.com Dec 27 2001 Bug 43675ÿDownload alert shouldn't say "Netscape"
r=tao sr=jst

marking fixed.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago18 years ago
Resolution: --- → FIXED
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.