Bug 438441 (bifftones)

Custom bifftones for mail filters (like custom ringtones)

NEW
Unassigned

Status

MailNews Core
Filters
--
enhancement
10 years ago
7 years ago

People

(Reporter: Grey Hodge (jX), Unassigned)

Tracking

Bug Flags:
wanted-thunderbird3 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
I can set my phone's address book to play special ringtones whenever certain people call me, alerting me to the potential importance of the call based purely on sound.

Rather than just the solitary biff sound for new mail, we should be able to set custom bifftones in the address book or filters so we can hear who mailed us without switching apps.
I like this.
Flags: wanted-thunderbird3+

Comment 2

10 years ago
This is most likely to be implemented using a mail filter with a custom action to play a certain tone as a notification response - which requires bug 11040. So I'll add that dependency and propogate the wanted request there.
Depends on: 11040

Comment 3

10 years ago
This looks like a dupe of Bug 118952 to me.

Comment 4

10 years ago
Indeed.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 118952
(Reporter)

Comment 5

10 years ago
Since davida has +'ed this, gonna dupe 118952 forward to this. Clean slate without the "me too" comments.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Updated

10 years ago
Duplicate of this bug: 118952

Comment 7

10 years ago
If you guys need to play who's-duping-who, then please set the components right...
Status: REOPENED → NEW
Component: General → MailNews: Filters
Product: Thunderbird → Core
QA Contact: general → filters
Version: unspecified → Trunk
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 8

10 years ago
Not a primary focus for the thunderbird3 release; wanted- doesn't indicate we wouldn't accept patches.
Flags: wanted-thunderbird3+ → wanted-thunderbird3-

Comment 9

9 years ago
I've got this working as a custom filter action, and will make it available in extension FiltaQuilla which will be available after TB beta1 releases.

Comment 10

9 years ago
I've now released to AMO an extension ToneQuilla that provides sounds as a custom filter action to TB and SM, working with TB beta1 shic was recently released. The URL for the addon is https://addons.mozilla.org/en-US/thunderbird/addon/9956 Information about the addon is available at http://mesquilla.com/extensions/tonequilla/

There is not a well defined process for deciding and resolving bugs that are available in extensions. (Nor is there a decent process to find extensions that implement features, but that is another story). I'm going to leave this bug as "New" which I will define to mean "implement the ToneQuilla functionality in the core mailnews product".
No longer depends on: 11040

Comment 11

9 years ago
Kent, yes, that's the correct thing to do.

Comment 12

9 years ago
kent, why not work on implementing it as a patch as well and see if it gets accepted?

Updated

8 years ago
Duplicate of this bug: 536842
Duplicate of this bug: 551975
You need to log in before you can comment on or make changes to this bug.