Closed Bug 438647 Opened 12 years ago Closed 12 years ago

In <am-copies.js>, "Error: document.getElementById(accountPickerId).selectedItem is null"

Categories

(SeaMonkey :: MailNews: Account Configuration, defect, major)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED
seamonkey2.0a1

People

(Reporter: sgautherie, Assigned: sgautherie)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(2 files, 3 obsolete files)

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9pre) Gecko/2008061102 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

1. Open Properties for 'Local Folders'. (for example)
2. Select 'Copies & Folders' tree-item.
3. Select another tree-item.
3r.
{{
Error: document.getElementById(accountPickerId).selectedItem is null
Source File: chrome://messenger/content/am-copies.js
Line: 270
}}

Account Manager (seems to) works fine, except for this item.

Workaround: close AM then reopen it...
Flags: blocking-seamonkey2.0a1?
What about if you select a different Folder before switching to another pane?
(In reply to comment #0)
> 1. Open Properties for 'Local Folders'. (for example)
> 2. Select 'Copies & Folders' tree-item.

Actually, any mail/news account, other than LF which has no C&F tree-item ;->

*****

(In reply to comment #1)

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9pre) Gecko/2008061202 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

I can't select another folder in that pane:
the boxes all display 'Local Folders' (or 'Sent' or 'Drafts');
and the (3+) drop-down list(s) is empty when it opens. [<-- root cause !!?]

***

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9pre) Gecko/2008061203 Thunderbird/3.0a2pre] (nightly) (W2Ksp4)

No problem with TB.
Severity: minor → major
OK, that seems much more like what I expected.  SeaMonkey doesn't ship mail-folder-binding.xml, so it just ends up with an empty menulist.
(In reply to comment #3)
> SeaMonkey doesn't ship mail-folder-binding.xml

<http://mxr.mozilla.org/mozilla/source/mail/base/content/mail-folder-bindings.xml>
added by "Bug 413781 XBLify folder-selection menus".

Is there a way to unbrake SM, until we port that bug ?
The only way to unbreak SM, without porting that bug would be to (1) restore the removed portions of msgFolderPickerOverlay.xul (2) #ifdef inclusion of that overlay and (3) #ifdef the js changes to am-copies.

Given that the porting steps are (1) move mail-folder-bindings.xml to from mail/ to mailnews (2) add mail-folder-bindings.xml to SM's jar.mn, and (3) add http://mxr.mozilla.org/seamonkey/source/mail/base/content/messenger.css#262 to SM's messenger.css, that actually seems like the simpler solution to me.
(In reply to comment #5)
> Given that the porting steps are (1) move mail-folder-bindings.xml to from
> mail/ to mailnews

Could you/someone do that (cvs copy/move, etc) ?
cvs moves require coordination with mozilla IT.  Given the limited history/blame for the file, my vote would be to just cvs remove/add it in a standard patch.  That's a decision for the peers though.
jminta's suggested solution in comment 5 sounds right to me.  Coordination with IT just means "filing a bug", I think, so I guess I'd vote for that, assuming the turnaround on that sort of bug isn't too long.  I could live with the cvs remove/add plan too.
Yes, we should strive /
for comment 5.
Blocks: TB2SM
Depends on: 439058
Assignee: mail → sgautherie.bz
Status: NEW → ASSIGNED
Attachment #325859 - Flags: review?(dmose)
> (Av1-TB) <jar.mn> update after bug 439058

You need to change SeaMonkey's respective jar.mn as well.
Attached patch (Bv1-SM) <mailnews/*> Port to SM (obsolete) — Splinter Review
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.1pre) Gecko/2008061902 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

Per comment 5 suggestion.
Attachment #325867 - Flags: superreview?(neil)
Attachment #325867 - Flags: review?(neil)
Comment on attachment 325859 [details] [diff] [review]
(Av1-TB) <jar.mn> update after bug 439058

r=dmose
Attachment #325859 - Flags: review?(dmose) → review+
Blocks: 441270
Av1-TB, updated with new/future file name.
Attachment #325859 - Attachment is obsolete: true
Attachment #327434 - Flags: review?(dmose)
Comment on attachment 327434 [details] [diff] [review]
(Av1a-TB) <base/*/*> update after bug 439058
[Checkin: Comment 19]

r=dmose
Attachment #327434 - Flags: review?(dmose) → review+
Comment on attachment 327434 [details] [diff] [review]
(Av1a-TB) <base/*/*> update after bug 439058
[Checkin: Comment 19]

Phil,
I'm looking for a confirmation of previous DanM's r+.
(DanM is not around at the moment.)
Attachment #327434 - Flags: review?(philringnalda)
Attachment #327434 - Flags: review?(dmose)
Attachment #327434 - Flags: review+
Comment on attachment 327434 [details] [diff] [review]
(Av1a-TB) <base/*/*> update after bug 439058
[Checkin: Comment 19]

Argh, silent bugzilla collision:
{{
dmose@mozilla.org  	2008-07-10 14:34:32 PDT  	  Attachment #327434 [details] [diff]  Flag  	review?(dmose@mozilla.org)  	review+
}}
Attachment #327434 - Flags: review?(philringnalda)
Attachment #327434 - Flags: review?(dmose)
Attachment #327434 - Flags: review+
Bv1-SM, updated with new file name.
Attachment #325867 - Attachment is obsolete: true
Attachment #329096 - Flags: superreview?(neil)
Attachment #329096 - Flags: review?(neil)
Attachment #325867 - Flags: superreview?(neil)
Attachment #325867 - Flags: review?(neil)
Keywords: checkin-needed
Whiteboard: [c-n: Av1a-TB and cvs-remove the old xml file // Leave opened]
Comment on attachment 327434 [details] [diff] [review]
(Av1a-TB) <base/*/*> update after bug 439058
[Checkin: Comment 19]

Landed this on CVS trunk aka 1.9.0. Leaving bug open until SM patch is in also.
Attachment #327434 - Attachment description: (Av1a-TB) <base/*/*> update after bug 439058 → (Av1a-TB) <base/*/*> update after bug 439058 [checked in]
Comment on attachment 329096 [details] [diff] [review]
(Bv1a-SM) <mailnews/*> Port to SM

>+    content/messenger/folderWidgets.xml)                                       (base/resources/content/folderWidgets.xml)
                                         ^ Spurious close bracket.
r+sr=me with that fixed.
Attachment #329096 - Flags: superreview?(neil)
Attachment #329096 - Flags: superreview+
Attachment #329096 - Flags: review?(neil)
Attachment #329096 - Flags: review+
Bv1a-SM, with comment 20 suggestion(s).
Attachment #329096 - Attachment is obsolete: true
Attachment #327434 - Attachment description: (Av1a-TB) <base/*/*> update after bug 439058 [checked in] → (Av1a-TB) <base/*/*> update after bug 439058 [Checkin: Comment 19]
Whiteboard: [c-n: Av1a-TB and cvs-remove the old xml file // Leave opened] → [c-n: Bv1b-SM and cvs-remove the old xml file]
Comment on attachment 329166 [details] [diff] [review]
(Bv1b-SM) <mailnews/*> Port to SM
[Checkin: Comment 22]

Landed this on CVS trunk aka 1.9.0.
Attachment #329166 - Attachment description: (Bv1b-SM) <mailnews/*> Port to SM → (Bv1b-SM) <mailnews/*> Port to SM [checked in]
Attachment #329166 - Attachment description: (Bv1b-SM) <mailnews/*> Port to SM [checked in] → (Bv1b-SM) <mailnews/*> Port to SM [Checkin: Comment 22]
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Flags: blocking-seamonkey2.0a1?
Keywords: checkin-needed
OS: Windows 2000 → All
Hardware: PC → All
Resolution: --- → FIXED
Whiteboard: [c-n: Bv1b-SM and cvs-remove the old xml file]
No longer blocks: 441270
Duplicate of this bug: 441270
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.2pre) Gecko/2008071202 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

It fixed a third case (= Junk Settings) too:
{{
Error: document.getElementById("actionAccountPopup").selectFolder is not a function
Source File: chrome://messenger/content/am-junk.js
Line: 60
}}

V.Fixed
No longer blocks: TB2SM
Status: RESOLVED → VERIFIED
Blocks: 444913
Flags: in-litmus-
Depends on: 444994
No longer depends on: 444994
Flags: in-litmus- → in-testsuite-
QA Contact: mailnews-account
You need to log in before you can comment on or make changes to this bug.