Closed Bug 441364 Opened 12 years ago Closed 8 months ago

Panning (canvas-view) not responsive while page loading

Categories

(Firefox for Android Graveyard :: Panning/Zooming, defect, P1)

x86
Maemo
defect

Tracking

(Not tracked)

RESOLVED WONTFIX
fennec1.0a2

People

(Reporter: romaxa, Assigned: pavlov)

References

()

Details

Steps:
Build latest fennec for ARM version 0.4 or download it from
http://people.mozilla.org/~dougt/fennec-0.4/fennec-0.4.en-US.linux-arm.tar.gz

Run fennec and open page www.fishki.net
After first page paint (canvas update) try to pan content and drag/scroll it.

EXPECTED OUTCOME:
Canvas view always responsive and ready to pan.

ACTUAL OUTCOME:
Page loading (images, long content), and canvas view almost not responsive.
OS: Linux → Linux (embedded)
Flags: blocking-fennec1.0+
Priority: -- → P1
Target Milestone: --- → Fennec A1
Assignee: nobody → doug.turner
Assignee: doug.turner → pavlov
I was playing with latest fennec 21f625bd9726 with news.google.com...
And after clicking on some random link I got next page:
http://www.businessweek.com/careers/managementiq/archives/2008/10/damaging_capito.html

After first visible update/paint I start to drag and scroll canvas content, but it was almost not possible or very very slow....

Probably this problem not reproducible on phone gprs connection, but it is very good visible on my home connection (~16Mb).

Can we do anything with canvas event loop? make it somehow higher priority, or move it in separate thread?
Depends on: 459150
Blocks: 455820
Depends on: 459290
Depends on: 459271
Depends on: 459705
Depends on: 459870
Depends on: 461031
No longer depends on: 459271
this is substantially better now, but will leave open for additional work
Target Milestone: Fennec A1 → Fennec A2
Depends on: 474689
tracking-fennec: --- → 1.0b2+
Can we close this now?  It's marked as blocking, but there's no description of additional work needed.
vote for not blocking1.0 - it's good enough to not block 1.0

I think we _should_ close this and open new bugs as needed
OK, talked with Stuart... we need to look at the knobs exposed through the GECKO_REFLOW environment variables and see how turning them affects interactivity with complicated pages.  We want to err on the side of slower flow, since the devices are slower and used don't want to be blocked.
this is pretty good now, but will leave open for 1.1 for some additional work
tracking-fennec: 1.0b2+ → ---
Flags: blocking-fennec1.0+ → wanted-fennec1.0+
Component: General → Panning/Zooming
tested www.lemonde.fr with b2 fennec and N900.
We still have lot of short freezes on Fennec while loading page, Microb still works much more responsive and don't freeze at all on that page (even with flash content)
Closing all opened bug in a graveyard component
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.