Can't change junk folder in account settings

RESOLVED FIXED in Thunderbird 3.0a3

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: rkent, Assigned: rkent)

Tracking

({regression})

Trunk
Thunderbird 3.0a3
regression
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

6.32 KB, patch
neil@parkwaycc.co.uk
: review+
neil@parkwaycc.co.uk
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

10 years ago
As a probably regression from bug 436630, I cannot change the folder used for moves of junk messages.

STR:

1) Create a new profile. Add a single IMAP account.
2) On both the IMAP account, and the Local Folders account, enable adaptive
junk controls and "Move new junk messages to" and choose the default ('"Junk"
folder on' and then the account name).
3) Go to the IMAP account. Change the "Junk" folder on ... to Local Folders.
Press OK.
4) Re-enter the Account Settings dialog.

Expected Results:

'"Junk" folder on' points to Local Folders

Actual result:

'"Junk" folder on' continues to point to the original value (for the IMAP
account).

The bug does not appear in a 2008-06-15 nightly, but does appear in 2008-06-18
Flags: blocking-thunderbird3?

Updated

10 years ago
Flags: blocking-thunderbird3? → blocking-thunderbird3+
(Assignee)

Comment 1

10 years ago
Created attachment 332625 [details] [diff] [review]
The fix

This doesn't seem to be getting any love, so let me give it a shot. I want to test another day before review though.
Assignee: nobody → kent
Status: NEW → ASSIGNED
(Assignee)

Comment 2

10 years ago
Created attachment 333712 [details] [diff] [review]
Patch for review

I should point out that this patch restores using the long folder name (Junk on Local Folders) in selections, which is the pre-bug 436630 behavior, but is now inconsistent with other parts of the account manager which is using the folder name only. I don't know why it was changed, and I prefer the old style. I think the other folder selections should also be changed to revert to using long names as they did before.
Attachment #332625 - Attachment is obsolete: true
Attachment #333712 - Flags: superreview?(neil)
Attachment #333712 - Flags: review?(neil)

Comment 3

10 years ago
Comment on attachment 333712 [details] [diff] [review]
Patch for review

>+    var longFolderName = document.getElementById("bundle_messenger")
>+                                 .getFormattedString("verboseFolderFormat",
>+                                 [folder.prettyName, folder.server.prettyName]);

>+  var folderName;
>+  if (folder.isServer)
>+    folderName = folder.prettyName;
>+  else
>+    folderName = document.getElementById("bundle_messenger")
>+                         .getFormattedString("verboseFolderFormat",
>+                         [folder.prettyName, folder.server.prettyName]);
Why two completely different looking pieces of code?
(Assignee)

Updated

10 years ago
Duplicate of this bug: 448112
(Assignee)

Comment 5

10 years ago
(In reply to comment #3)
> Why two completely different looking pieces of code?
> 

The first section initializes the "Other" field which is always a folder, not a
server. Hence the name is always a long name, and I don't need to support the
server option.

The second section updates either the folder or account field, so it needs to
support a server (with no long name) as well as a folder (with a long name).

So there actually is a reason for the differences - and otherwise they are
practically identical!

Updated

10 years ago
Whiteboard: [has patch]

Updated

10 years ago
Attachment #333712 - Flags: superreview?(neil)
Attachment #333712 - Flags: superreview+
Attachment #333712 - Flags: review?(neil)
Attachment #333712 - Flags: review+
(Assignee)

Updated

10 years ago
Keywords: checkin-needed
Checked in, changeset id: 164:88e95f865bb6
Keywords: checkin-needed
Whiteboard: [has patch]
Target Milestone: --- → Thunderbird 3.0b1
(Assignee)

Updated

10 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Duplicate of this bug: 444550
You need to log in before you can comment on or make changes to this bug.