Some pages show up blank in the Ctrl+Tab preview panel

RESOLVED DUPLICATE of bug 449653

Status

()

defect
RESOLVED DUPLICATE of bug 449653
11 years ago
11 years ago

People

(Reporter: u88484, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
In the new ctrl+tab preview panel, the usaa.com preview shows up completely blank.  Also, https://home.ingdirect.com shows up partially.  I think ingdirect shows up partially due to the flash content not being shown.  

I know these aren't due to the code for the preview panel but I wasn't sure which code it uses to show the previews.
(Reporter)

Updated

11 years ago
Blocks: 395980
(Reporter)

Comment 2

11 years ago
Hmm, try just http://www.usaa.com.  Maybe IE gets forwarded to a different address and I just copied what I got at work.  If not I'll try with a clean slate at home and get a screenshot.

Comment 3

11 years ago
http://hg.mozilla.org/mozilla-central/ also is blank sometimes.  I think it happens when it is restored from the previous session.  

Comment 4

11 years ago
I think this bug is something to do with the page rendering/scaling of Firefox 3 since I have seen this happen in other extensions.
(Reporter)

Comment 5

11 years ago
Posted image Screenshot
Note gmail is also blank in this screenshot.  I can not figure out for the life of me the exact STR, it is so sporadic.
(In reply to comment #0)
> Also, https://home.ingdirect.com shows up partially.  I think ingdirect
> shows up partially due to the flash content not being shown.

That's is now covered by bug 445595.
No longer depends on: 313462
OS: Windows XP → All
Hardware: PC → All
Summary: USAA.com shows up blank in the new Ctrl+Tab preview panel → After session restore, some pages show up blank in the Ctrl+Tab preview panel
Posted patch workaroundSplinter Review
this fixes it for me
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #329969 - Flags: review?(mano)
Doesn't seem to be usaa.com-specific at all.
(Reporter)

Comment 9

11 years ago
This does happen after session restore but not always.  I triggered it yesterday by:

1) Starting Firefox (after I had to kill it from being frozen)
2) Clicked to start new session
3) Typed in "gm", selected http://mail.google.com in the awesomebar
4) CTRL+T, typed in "usa", selected http://www.usaa.com in the awesomebar
5) CTRL+T, typed in "ing", selected https://homes.ingdirect.com
6) CTRL+TAB, noticed usaa and gmail blank, ing partially blank
7) Switched to the gmail tab in the preview panel
8) CTRL+TAB usaa.com then showed content, gmail was still blank from there on out until I did something that automagically made it appear.
Attachment #329969 - Flags: review?(gavin.sharp)
If you have blank previews just enable another application and switch back to Firefox. Looks like that the list of previews is not updated when hitting Ctrl+Tab but when the application gets the focus again.

Updated

11 years ago
Duplicate of this bug: 446148
(In reply to comment #10)
> If you have blank previews just enable another application and switch back to
> Firefox. Looks like that the list of previews is not updated when hitting
> Ctrl+Tab but when the application gets the focus again.

With regard to the code that I wrote, that shouldn't make a difference, but maybe it's related to the underlying canvas bug (I doubt that too, though).
(In reply to comment #12)
> (In reply to comment #10)
> > If you have blank previews just enable another application and switch back to
> > Firefox. Looks like that the list of previews is not updated when hitting
> > Ctrl+Tab but when the application gets the focus again.
> 
> With regard to the code that I wrote, that shouldn't make a difference, but
> maybe it's related to the underlying canvas bug (I doubt that too, though).

I can clearly reproduce this issue with the current build. So if you cannot and need some information I could deliver, just give me a hint what I should check.
Comment on attachment 329969 [details] [diff] [review]
workaround

This looks pretty bad, the page should be drawable at this point, may you contact vlad please (or move this to core)?
Attachment #329969 - Flags: review?(mano)
Attachment #329969 - Flags: review?(gavin.sharp)
Assignee: dao → nobody
Status: ASSIGNED → NEW
Component: Tabbed Browser → Layout: Canvas
Product: Firefox → Core
QA Contact: tabbed.browser → layout.canvas
Attachment #329969 - Attachment description: patch → workaround
WORKSFORME on usaa.com with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a2pre) Gecko/2008080103 Minefield/3.1a2pre. I just went to the site, and pressed Ctrl+Tab, with no session restore, etc.
Dao, sadly we forgot to talk about that issue during the Summit.

As what I can see this is not session restore related. It's really a timing issue which will happen for sites which takes longer to load or probably if a redirect occurs. Here are the steps how to reproduce it:

1. Create a fresh profile (Minefield start page is shown)
2. Create a new tab and load e.g. https://www.usaa.com/
3. While page is loading create a new tab
4. Wait until page (step 2) has finished loading
5. Hit Ctrl+Tab => preview image of usaa is empty.

To resolve this you have to follow these steps:

6. Hit Ctrl+Tab again to open the empty tab again
7. Hit Ctrl+Tab twice to switch to the next application and back
8. Hit Ctrl+Tab => preview image of usaa is rendered.
Summary: After session restore, some pages show up blank in the Ctrl+Tab preview panel → Some pages show up blank in the Ctrl+Tab preview panel
Blocks: 329693
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 449653
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a2pre) Gecko/20080820020636 Minefield/3.1a2pre ID:20080820020636

This bug can probably depend on bug 449653 but isn't a dupe. Running the todays nightly builds on Windows and OS X 10.5 still show empty or outdated previews.
Status: RESOLVED → REOPENED
Depends on: 449653
Resolution: DUPLICATE → ---
Please file a new bug with clear steps to reproduce. What we've identified so far was a canvas bug and as such a duplicate of bug 449653.
(In reply to comment #19)
> Please file a new bug with clear steps to reproduce. What we've identified so
> far was a canvas bug and as such a duplicate of bug 449653.

It was partly an issue with the canvas bug, correct. But fixing bug 449653 doesn't fix this bug. It doesn't make sense to create a new bug for the same behavior. I'll come up with some STR later.
No, it has been moved to Core:"Layout: Canvas" entirely. Bug morphs and series of steps to reproduce for technically different issues aren't useful when it comes to working on bugs. Please file a new one.
If you do file a new bug, put a reference to it on this bug.
(In reply to comment #21)
> No, it has been moved to Core:"Layout: Canvas" entirely. Bug morphs and series
> of steps to reproduce for technically different issues aren't useful when it
> comes to working on bugs. Please file a new one.

This is bug 451618 now.

Reduping against bug 449653.
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 449653
You need to log in before you can comment on or make changes to this bug.