Closed Bug 447693 Opened 12 years ago Closed 12 years ago

Remove photon gfx port

Categories

(Core Graveyard :: GFX: Photon, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
mozilla1.9.1a2

People

(Reporter: joe, Assigned: joe)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

Attached patch Removal of Photon port (obsolete) — Splinter Review
The Photon port, according to Vlad, is dead. This patch removes it.
Attachment #330999 - Flags: review?(vladimir)
Max Feil ( mfeil@qnx.com ) is working / maintaining the photon port.
Do not delete it please.
Max told me:

The head branch QNX port of Firefox 3.0 is not being actively
maintained. We are still on the  MOZILLA_1_8_BRANCH for Firefox 2.0. So
it can theoretically be removed on head.

And yes, the plan for Firefox 3.0 port is to base it on Cairo. If and
when that work will be done I don't know.
Blocks: 449577
We don't actually want to remove all of photon/qnx/neutrino everywhere, only the gfx port. So that's what I'm going to make this patch do instead.
Summary: Remove photon/QNX/Neutrino port → Remove photon gfx port
Assignee: amardare → joe
Attachment #330999 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #332781 - Flags: review?
Attachment #330999 - Flags: review?(vladimir)
Attachment #332781 - Flags: review? → review?(vladimir)
Comment on attachment 332781 [details] [diff] [review]
remove the photon GFX port

Sounds good
Attachment #332781 - Flags: review?(vladimir) → review+
Keywords: checkin-needed
No longer blocks: 449577
Pushed as 17031:a5b849e7b07a.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Keywords: checkin-needed
OS: Mac OS X → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.1a2
Component: Widget: Photon → GFX: Photon
QA Contact: photon → photon
Duplicate of this bug: 384057
Joe, Next time please search bugzilla for existing bugs before creating a new one...
Status: RESOLVED → VERIFIED
Blocks: 430829
Blocks: 452316
Product: Core → Core Graveyard
Blocks: 563462
You need to log in before you can comment on or make changes to this bug.